summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-26 03:13:34 +0000
committerSam James <sam@gentoo.org>2022-02-26 03:43:03 +0000
commitd66b15988f972338e72ffd7c1c538d55416dcfba (patch)
tree175426bf0c22b7bce85c723e06928157e221a784
parentx11-libs/cairo: Drop dead build flags (diff)
downloadgentoo-d66b1598.tar.gz
gentoo-d66b1598.tar.bz2
gentoo-d66b1598.zip
dev-lua/luv: add 1.43.0.0
Closes: https://bugs.gentoo.org/834057 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-lua/luv/Manifest1
-rw-r--r--dev-lua/luv/files/luv-1.43.0.0-cmake_lua_version.patch13
-rw-r--r--dev-lua/luv/luv-1.43.0.0.ebuild86
3 files changed, 100 insertions, 0 deletions
diff --git a/dev-lua/luv/Manifest b/dev-lua/luv/Manifest
index 338dcf0a606b..51e54f591dde 100644
--- a/dev-lua/luv/Manifest
+++ b/dev-lua/luv/Manifest
@@ -1,2 +1,3 @@
DIST luv-1.36.0.0.tar.gz 107196 BLAKE2B 31a02c3e928559037355186810187299a3cb1420265a27756b0613781621c78c18edc272072cc29c46336787b040453cc9a06195264c0a72a985e49c48202022 SHA512 3119c1450a8317725d59cc1ab6afccfbde752b0c32b38909dfdd31bf88ea0751920dc68750da52cf17a6430637cf1094f4d5500e4c50d1145eca48bb12728ba1
+DIST luv-1.43.0.0.tar.gz 122337 BLAKE2B 435334d869487de38215ce9b551f586d4017c7f83497bc90637fc8acb8e63d1c36f6678a3f2c4d5b24b76fd904b2fa8c364a31bc1bd544416f60f2b8290903d3 SHA512 f51d9b3c733dd5617fca49534fdd77dbb6a3d6f58263f453db8dcde21679f4a471e15d6f5b05bcb22a2552455df8beb238d33b0999306bf2a5ad6755da4044ff
DIST luv-lua-compat-0.10.tar.gz 53695 BLAKE2B e570aedb23b8ed7ca38c4316ffab25b93a0f9f6f0fae79af563ca8a81dd6453ac273e1f9e70674c484a2dec68749e7d53a1c1736a72616c210b8e38a31b3f191 SHA512 f7f39085f4f6b16095f41e635b4c5477b3dab5e42b5b65a9d522941a3807ea521d4a27a77293a3c9d0ecea78a1f6c2a2497394b2d220f4d7d65e23510563d46d
diff --git a/dev-lua/luv/files/luv-1.43.0.0-cmake_lua_version.patch b/dev-lua/luv/files/luv-1.43.0.0-cmake_lua_version.patch
new file mode 100644
index 000000000000..d9c324935b91
--- /dev/null
+++ b/dev-lua/luv/files/luv-1.43.0.0-cmake_lua_version.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 78c0345..853ba90 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -140,7 +140,7 @@ else (LUA)
+ if (WIN32)
+ find_package(Lua REQUIRED)
+ else()
+- find_package(Lua)
++ find_package(Lua ${LUA_VERSION} EXACT REQUIRED)
+ endif()
+ if(NOT LUA_INCLUDE_DIR)
+ message( FATAL_ERROR "Failed to find Lua headers. Variable `LUA_INCLUDE_DIR' expected to be defined.")
diff --git a/dev-lua/luv/luv-1.43.0.0.ebuild b/dev-lua/luv/luv-1.43.0.0.ebuild
new file mode 100644
index 000000000000..9c3fb9018539
--- /dev/null
+++ b/dev-lua/luv/luv-1.43.0.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit cmake flag-o-matic lua-single unpacker
+
+# e.g. MY_PV = a.b.c-d
+MY_PV="$(ver_rs 3 -)"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Bare libuv bindings for lua"
+HOMEPAGE="https://github.com/luvit/luv"
+
+LUA_COMPAT_PV="0.10"
+SRC_URI="
+ https://github.com/luvit/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/keplerproject/lua-compat-5.3/archive/v${LUA_COMPAT_PV}.tar.gz -> ${PN}-lua-compat-${LUA_COMPAT_PV}.tar.gz
+"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="${LUA_DEPS}
+ >=dev-libs/libuv-1.32.0:="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.43.0.0-cmake_lua_version.patch
+)
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Fix libdir
+ # Match '/lib/' and '/lib"' without capturing / or ", replacing with libdir
+ sed -i -r "s/\/lib(\"|\/)/\/$(get_libdir)\1/g" CMakeLists.txt || die "Failed to sed CMakeLists.txt"
+ cmake_src_prepare
+}
+
+# This could in theory be multi-impl (and we have an ebuild in git history,
+# 1.32.0.0-r101, which implements it) - the only revdep currently in the tree,
+# app-editors/neovim, actually links against luv instead of trying to load it
+# as a module. We could probably implement some sort of a hack for this
+# - but given how messy it would be, don't bother unless someone actually requests
+# luv multi-impl support.
+src_configure() {
+ lua_compat_dir="${WORKDIR}/lua-compat-5.3-${LUA_COMPAT_PV}"
+
+ local mycmakeargs=(
+ -DBUILD_MODULE=OFF
+ -DLUA_BUILD_TYPE=System
+ -DLUA_COMPAT53_DIR="${lua_compat_dir}"
+ -DWITH_SHARED_LIBUV=ON
+ )
+ if [[ ${ELUA} == luajit ]]; then
+ mycmakeargs+=(
+ -DWITH_LUA_ENGINE=LuaJIT
+ )
+ else
+ mycmakeargs+=(
+ -DWITH_LUA_ENGINE=Lua
+ -DLUA_VERSION=$(ver_cut 1-2 $(lua_get_version))
+ )
+ fi
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ append-ldflags "-undefined dynamic_lookup"
+ fi
+
+ cmake_src_configure
+}
+
+src_test() {
+ # We need to copy the library back so that the tests see it
+ ln -s "${BUILD_DIR}/libluv.so" "./luv.so" || die "Failed to symlink library for tests"
+ ${ELUA} "tests/run.lua" || die "Tests failed"
+}