summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-26 11:11:16 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-26 11:48:30 +0100
commitd66c5adc14c6fee52850fdec390067647523c923 (patch)
tree0f1e3236ef9eaae78a1b809e2940eba75b4ac06c
parentwww-servers/apache: Moved IUSE handling back to eclass (diff)
downloadgentoo-d66c5adc.tar.gz
gentoo-d66c5adc.tar.bz2
gentoo-d66c5adc.zip
www-servers/apache: Moved dependencies into eclass
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--eclass/apache-2.eclass37
-rw-r--r--www-servers/apache/apache-2.4.46-r1.ebuild16
-rw-r--r--www-servers/apache/apache-2.4.46-r4.ebuild16
-rw-r--r--www-servers/apache/apache-2.4.46.ebuild16
4 files changed, 33 insertions, 52 deletions
diff --git a/eclass/apache-2.eclass b/eclass/apache-2.eclass
index e51c12cb0a28..fecf92eb0f7e 100644
--- a/eclass/apache-2.eclass
+++ b/eclass/apache-2.eclass
@@ -129,23 +129,52 @@ _apache2_set_mpms() {
_apache2_set_mpms
unset -f _apache2_set_mpms
-DEPEND="${COMMON_DEPEND}
+# Dependencies
+RDEPEND="
dev-lang/perl
=dev-libs/apr-util-1*:=[gdbm=,ldap?]
dev-libs/libpcre
+ apache2_modules_brotli? ( >=app-arch/brotli-0.6.0:= )
apache2_modules_deflate? ( sys-libs/zlib )
+ apache2_modules_http2? (
+ >=net-libs/nghttp2-1.2.1
+ kernel_linux? ( sys-apps/util-linux )
+ )
+ apache2_modules_md? ( >=dev-libs/jansson-2.10 )
apache2_modules_mime? ( app-misc/mime-types )
+ apache2_modules_proxy_http2? (
+ >=net-libs/nghttp2-1.2.1
+ kernel_linux? ( sys-apps/util-linux )
+ )
+ apache2_modules_session_crypto? (
+ libressl? ( dev-libs/apr-util[libressl] )
+ !libressl? ( dev-libs/apr-util[openssl] )
+ )
gdbm? ( sys-libs/gdbm:= )
ldap? ( =net-nds/openldap-2* )
+ selinux? ( sec-policy/selinux-apache )
ssl? (
!libressl? ( >=dev-libs/openssl-1.0.2:0= )
libressl? ( dev-libs/libressl:0= )
+ kernel_linux? ( sys-apps/util-linux )
)
- !=www-servers/apache-1*"
-RDEPEND+=" ${DEPEND}
- selinux? ( sec-policy/selinux-apache )"
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ suexec? ( suexec-caps? ( sys-libs/libcap ) )
+"
+if [[ ${EAPI} == 6 ]] ; then
+ DEPEND+=" ${BDEPEND}"
+fi
PDEPEND="~app-admin/apache-tools-${PV}"
+REQUIRED_USE+="
+ apache2_modules_http2? ( ssl )
+ apache2_modules_md? ( ssl )
+"
+
S="${WORKDIR}/httpd-${PV}"
# @VARIABLE: MODULE_DEPENDS
diff --git a/www-servers/apache/apache-2.4.46-r1.ebuild b/www-servers/apache/apache-2.4.46-r1.ebuild
index 16149fb8b80f..a9d64875c3c9 100644
--- a/www-servers/apache/apache-2.4.46-r1.ebuild
+++ b/www-servers/apache/apache-2.4.46-r1.ebuild
@@ -140,22 +140,6 @@ LICENSE="Apache-2.0 Apache-1.1"
SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x64-macos ~sparc64-solaris ~x64-solaris"
-COMMON_DEPEND="apache2_modules_brotli? ( >=app-arch/brotli-0.6.0:= )
- apache2_modules_http2? ( >=net-libs/nghttp2-1.2.1 )
- apache2_modules_proxy_http2? ( >=net-libs/nghttp2-1.2.1 )
- apache2_modules_md? ( >=dev-libs/jansson-2.10 )
- apache2_modules_session_crypto? (
- libressl? ( dev-libs/apr-util[libressl] )
- !libressl? ( dev-libs/apr-util[openssl] )
- )"
-
-DEPEND+="${COMMON_DEPEND}
- suexec? ( suexec-caps? ( sys-libs/libcap ) )"
-RDEPEND+="${COMMON_DEPEND}"
-
-REQUIRED_USE="apache2_modules_http2? ( ssl )
- apache2_modules_md? ( ssl )"
-
PATCHES=(
"${FILESDIR}/${PN}-2.4.41-libressl.patch" #668060
)
diff --git a/www-servers/apache/apache-2.4.46-r4.ebuild b/www-servers/apache/apache-2.4.46-r4.ebuild
index 676c0e2d246a..f3446c2754f4 100644
--- a/www-servers/apache/apache-2.4.46-r4.ebuild
+++ b/www-servers/apache/apache-2.4.46-r4.ebuild
@@ -140,22 +140,6 @@ LICENSE="Apache-2.0 Apache-1.1"
SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x64-macos ~sparc64-solaris ~x64-solaris"
-COMMON_DEPEND="apache2_modules_brotli? ( >=app-arch/brotli-0.6.0:= )
- apache2_modules_http2? ( >=net-libs/nghttp2-1.2.1 )
- apache2_modules_proxy_http2? ( >=net-libs/nghttp2-1.2.1 )
- apache2_modules_md? ( >=dev-libs/jansson-2.10 )
- apache2_modules_session_crypto? (
- libressl? ( dev-libs/apr-util[libressl] )
- !libressl? ( dev-libs/apr-util[openssl] )
- )"
-
-DEPEND+="${COMMON_DEPEND}
- suexec? ( suexec-caps? ( sys-libs/libcap ) )"
-RDEPEND+="${COMMON_DEPEND}"
-
-REQUIRED_USE="apache2_modules_http2? ( ssl )
- apache2_modules_md? ( ssl )"
-
PATCHES=(
"${FILESDIR}/${PN}-2.4.41-libressl.patch" #668060
)
diff --git a/www-servers/apache/apache-2.4.46.ebuild b/www-servers/apache/apache-2.4.46.ebuild
index 828a9a1a8348..1f2646bf81ed 100644
--- a/www-servers/apache/apache-2.4.46.ebuild
+++ b/www-servers/apache/apache-2.4.46.ebuild
@@ -138,22 +138,6 @@ LICENSE="Apache-2.0 Apache-1.1"
SLOT="2"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x64-macos ~sparc64-solaris ~x64-solaris"
-COMMON_DEPEND="apache2_modules_brotli? ( >=app-arch/brotli-0.6.0:= )
- apache2_modules_http2? ( >=net-libs/nghttp2-1.2.1 )
- apache2_modules_proxy_http2? ( >=net-libs/nghttp2-1.2.1 )
- apache2_modules_md? ( >=dev-libs/jansson-2.10 )
- apache2_modules_session_crypto? (
- libressl? ( dev-libs/apr-util[libressl] )
- !libressl? ( dev-libs/apr-util[openssl] )
- )"
-
-DEPEND+="${COMMON_DEPEND}
- suexec? ( suexec-caps? ( sys-libs/libcap ) )"
-RDEPEND+="${COMMON_DEPEND}"
-
-REQUIRED_USE="apache2_modules_http2? ( ssl )
- apache2_modules_md? ( ssl )"
-
PATCHES=(
"${FILESDIR}/${PN}-2.4.41-libressl.patch" #668060
)