summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-06-07 16:20:24 +0200
committerDavid Seifert <soap@gentoo.org>2020-06-07 16:20:24 +0200
commitd6737729ad6191a2d3fecb440afb5c040a5b8ab0 (patch)
tree689a8790e35097c8e74840aa68357d0b207251a6
parentdev-ruby/sys-uname: fix DOCS (diff)
downloadgentoo-d6737729ad6191a2d3fecb440afb5c040a5b8ab0.tar.gz
gentoo-d6737729ad6191a2d3fecb440afb5c040a5b8ab0.tar.bz2
gentoo-d6737729ad6191a2d3fecb440afb5c040a5b8ab0.zip
x11-libs/goffice: Version bump to 0.10.47
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--x11-libs/goffice/Manifest1
-rw-r--r--x11-libs/goffice/goffice-0.10.47.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/x11-libs/goffice/Manifest b/x11-libs/goffice/Manifest
index 6a3263aced13..3d9f1708fa29 100644
--- a/x11-libs/goffice/Manifest
+++ b/x11-libs/goffice/Manifest
@@ -1 +1,2 @@
DIST goffice-0.10.46.tar.xz 2397976 BLAKE2B a05696cde60b1cb1ee915bebd3a6e99d1f0a31dc232481615a1c6bbc05ee5433cdebfb05d96160026b260c752c2cfb11c0aecc338079cda66fd40b653fb8b0d1 SHA512 23714fef4dabccc76fe96b78d8eba9c9adb01cb9b3e2f1a9768598fb2a82742b2d2060a7d2548279998488c59e313d7a5863a96b2eb380f540b61fb08e0330f3
+DIST goffice-0.10.47.tar.xz 2400616 BLAKE2B 16a92b3aa5c6e53cb0fe3f51d3ce03a9df6a18f50c0d6890da6ca2529f9e90e3ba30bef63b3c840697d229f58a723957731f985bf02ba80ec4d63bc93d6b7c1a SHA512 0db26fbd049893ee9274ee492e1dc3f10ae789cf99cc0b9dda3f1c2f106423e4679cc56515eb08bbf752aaf48492212777eee08d43a9fefb0b22048e883f5a76
diff --git a/x11-libs/goffice/goffice-0.10.47.ebuild b/x11-libs/goffice/goffice-0.10.47.ebuild
new file mode 100644
index 000000000000..12d2ce5eb098
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.10.47.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org libtool
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="+introspection"
+
+# FIXME: add lasem to tree
+RDEPEND="
+ >=app-text/libspectre-0.2.6:=
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/libxml2-2.4.12:2
+ dev-libs/libxslt
+ >=gnome-base/librsvg-2.22:2
+ >=gnome-extra/libgsf-1.14.24:=[introspection?]
+ >=x11-libs/cairo-1.10:=[svg]
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/gtk+-3.20:3
+ >=x11-libs/pango-1.24:=
+ x11-libs/libXext:=
+ x11-libs/libXrender:=
+ introspection? (
+ >=dev-libs/gobject-introspection-1:=
+ >=gnome-extra/libgsf-1.14.23:=
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/perl
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35
+ virtual/perl-Compress-Raw-Zlib
+ virtual/perl-Getopt-Long
+ virtual/perl-IO-Compress
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-gtk-doc \
+ --disable-maintainer-mode \
+ --without-lasem \
+ --with-gtk \
+ --with-config-backend=gsettings \
+ $(use_enable introspection)
+}
+
+src_install() {
+ default
+ dodoc MAINTAINERS
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}