summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-12-20 17:23:19 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-12-20 17:53:58 +0100
commitd67626e9378ce4eb421053c53a53354e5d285339 (patch)
treea6939edddd3fba52369f1cf74cb18a5b42249cb5
parentdev-ros/robot_localization: add std_srvs dep (diff)
downloadgentoo-d67626e9.tar.gz
gentoo-d67626e9.tar.bz2
gentoo-d67626e9.zip
dev-ros/robot_localization: bump to 2.4.1
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-ros/robot_localization/Manifest1
-rw-r--r--dev-ros/robot_localization/robot_localization-2.4.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-ros/robot_localization/Manifest b/dev-ros/robot_localization/Manifest
index a82b24b39188..7f61bf43d3e1 100644
--- a/dev-ros/robot_localization/Manifest
+++ b/dev-ros/robot_localization/Manifest
@@ -1 +1,2 @@
DIST robot_localization-2.4.0.tar.gz 6448252 BLAKE2B c63ea67f4e9829127f8b3fa7a55384cd6593ddc7e600bb5ac412c58a35bd0762145a76648d15c93f82731217163859a5da151e5729eb099a8e6c184dbf77c49f SHA512 92a8c6d44f35a264fc16fe91d7ba6afcf361911164a96343d76d93c0263f0d6cb9e3b11f82cf30c0354a1ebb140cdb06348ae5ca92182dd85ab2e0fd77898724
+DIST robot_localization-2.4.1.tar.gz 6461786 BLAKE2B 73a7ac992fac1c22359c61627ddfbecd618aad406a2f1119c3d80be55155e1aafd5008a0ff88133f5aa7d02b9bb94ca6a42fd7491fad680eeb9af45dcacfc5e5 SHA512 032994ef56a6f65d33e671067342d0bc1da747fd2b1d135ad3310009b907ffbc05131d7a77a3ef1aaec853742f0b5d35cef8e142691c659bf3c6bd346af7d636
diff --git a/dev-ros/robot_localization/robot_localization-2.4.1.ebuild b/dev-ros/robot_localization/robot_localization-2.4.1.ebuild
new file mode 100644
index 000000000000..941ce5516c7a
--- /dev/null
+++ b/dev-ros/robot_localization/robot_localization-2.4.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/cra-ros-pkg/robot_localization"
+KEYWORDS="~amd64"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geographic_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Package of nonlinear state estimation nodes"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_updater
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/eigen_conversions
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/message_filters
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_geometry_msgs
+ dev-ros/tf2_ros
+ dev-ros/xmlrpcpp
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/roslint
+ dev-cpp/eigen:3
+ test? ( dev-ros/rosbag dev-ros/rostest dev-ros/rosunit )
+"