summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-07-08 06:23:57 +0200
committerHans de Graaff <graaff@gentoo.org>2023-07-08 06:25:06 +0200
commitd67a052682641e4e51346dc21b3786f07bc24820 (patch)
treeb609e790539dd72a15a2f7c5d70470ba67c23800
parentdev-perl/DateTime-Locale: restore keywords (diff)
downloadgentoo-d67a052682641e4e51346dc21b3786f07bc24820.tar.gz
gentoo-d67a052682641e4e51346dc21b3786f07bc24820.tar.bz2
gentoo-d67a052682641e4e51346dc21b3786f07bc24820.zip
dev-ruby/shoulda-context: add 2.0.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/shoulda-context/Manifest1
-rw-r--r--dev-ruby/shoulda-context/shoulda-context-2.0.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/shoulda-context/Manifest b/dev-ruby/shoulda-context/Manifest
index 1e75b8b29b29..436b7385e5a5 100644
--- a/dev-ruby/shoulda-context/Manifest
+++ b/dev-ruby/shoulda-context/Manifest
@@ -1 +1,2 @@
DIST shoulda-context-1.2.2.gem 24064 BLAKE2B a6068da369c00a36e6056a8ebba96eca90efddf94613dfc90c9f2a47bec2c054a41fa61b861b2f3ec1195e417bdc54ab60d53f91bc5e0f167eac07b84880892b SHA512 b09f5ce2db59bbb26d5678b17b6641b79df7983d25e81a31bc10c42b702bdba09795b692d711d59c103beb2f691b503567e37c46668f77e600416551ef2c5e05
+DIST shoulda-context-2.0.0.gem 34304 BLAKE2B b31f7e052b54fb60fb7fff84fc48beed406864b871f3c125db4f28d1ce0f400bb0ad3479d438d20a28f585b6e5da101b71228f598e6bdc177512f048273a8524 SHA512 c8d856a95b3dfe85fd92c79f18e03a2765ad219b83ab132017fefcffd0262b04bcebf267e6bbaec0ed3dff1d4d345bd74c1f9db1d2a22938ee8d85ee1078ac6e
diff --git a/dev-ruby/shoulda-context/shoulda-context-2.0.0.ebuild b/dev-ruby/shoulda-context/shoulda-context-2.0.0.ebuild
new file mode 100644
index 000000000000..f4025618e223
--- /dev/null
+++ b/dev-ruby/shoulda-context/shoulda-context-2.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="tasks"
+
+# Don't install the conversion script to avoid collisions with older
+# shoulda.
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Context framework extracted from Shoulda"
+HOMEPAGE="https://github.com/thoughtbot/shoulda-context"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="doc test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2
+ dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -e '/\(current_bundle\|CurrentBundle\)/ s:^:#:' \
+ -e '/pry-byebug/ s:^:#:' \
+ -e '/warnings_logger/ s:^:#: ; /WarningsLogger/,/^)/ s:^:#:' \
+ -e '/rails_application_with_shoulda_context/ s:^:#:' \
+ -i test/test_helper.rb || die
+ rm -f test/shoulda/{railtie,rerun_snippet,test_framework_detection}_test.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/shoulda/*_test.rb"].each { require _1 }' || die
+}