summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2018-03-29 18:03:35 +0000
committerSven Wegener <swegener@gentoo.org>2018-03-29 18:05:09 +0000
commitd67e1191e06c078eef31c717d5cdb24cc6bf2378 (patch)
tree5a67589d756932d3a212f4a7711f695556a199ed
parentapp-antivirus/clamav: x86 stable (bug #623534) (diff)
downloadgentoo-d67e1191.tar.gz
gentoo-d67e1191.tar.bz2
gentoo-d67e1191.zip
net-dns/pdns-recursor: Version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--net-dns/pdns-recursor/Manifest1
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-4.1.2.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/net-dns/pdns-recursor/Manifest b/net-dns/pdns-recursor/Manifest
index 835ce37a1f8c..5d411f882407 100644
--- a/net-dns/pdns-recursor/Manifest
+++ b/net-dns/pdns-recursor/Manifest
@@ -1,2 +1,3 @@
DIST pdns-recursor-4.0.8.tar.bz2 1071831 BLAKE2B d9ab0dada8efa4b05c136650b9a2eab3aec4acab28ffb6da5bb4f627dc085b2c2d046d1f0dac5cf6e7054b47d76b8d7b95f56cc096b613891a4422b77e9abe9d SHA512 9886fccd3042904b7133e03a7b45479c8f2f57ecb33e4a043703b5e84816cd04a331503870e16030c86b353c1e14d9283dba767c1247e46ed6e14b7e0e93a5ef
DIST pdns-recursor-4.1.1.tar.bz2 1224544 BLAKE2B 886353fabed5795696e84c6f70872577ff3832e449c5b88c81fec007777eb39b764091b92c9c8b5dfc7aa0af2fdb305a3ec3578ccaff469e9c305903bcea8089 SHA512 a8561bf0688752f30c4c997930f13d55c506b2a2113d22b074443757a51cde9be182ef948e61eb8c4d639bbf8679d8a4139aafb6983f483b3a917e049fa64e45
+DIST pdns-recursor-4.1.2.tar.bz2 1219927 BLAKE2B 3db5d383ad75406925c7196ad0b9552c938a60238fa60e4317c5f4037d716d2faf2ac897dac18661df809211129950a2988846a1c7aa1d24f89c5a682448abfc SHA512 eaf28ce424f1367e548cb78c09de9d39154dddd87e2f19ed238197b6304b20bd9fef599d7df44ca128d89d8cd04d3b7fdd455241bb34ecd688c8042a020c4a36
diff --git a/net-dns/pdns-recursor/pdns-recursor-4.1.2.ebuild b/net-dns/pdns-recursor/pdns-recursor-4.1.2.ebuild
new file mode 100644
index 000000000000..7e2d4e9bfdb5
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-4.1.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs flag-o-matic eutils versionator
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="libressl luajit protobuf snmp sodium systemd"
+
+DEPEND="!luajit? ( >=dev-lang/lua-5.1:= )
+ luajit? ( dev-lang/luajit:= )
+ protobuf? (
+ dev-libs/protobuf
+ >=dev-libs/boost-1.42:=
+ )
+ systemd? ( sys-apps/systemd:0= )
+ snmp? ( net-analyzer/net-snmp )
+ sodium? ( dev-libs/libsodium:= )
+ libressl? ( dev-libs/libressl:= )
+ !libressl? ( dev-libs/openssl:= )
+ >=dev-libs/boost-1.35:="
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_/-}
+
+pkg_setup() {
+ filter-flags -ftree-vectorize
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/powerdns \
+ $(use_enable systemd) \
+ $(use_enable sodium libsodium) \
+ $(use_with !luajit lua) \
+ $(use_with luajit luajit) \
+ $(use_with protobuf) \
+ $(use_with snmp net-snmp)
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/recursor.conf{-dist,}
+
+ # set defaults: setuid=nobody, setgid=nobody
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=nobody/' \
+ -e 's/^# quiet=$/quiet=on/' \
+ -e 's/^# chroot=$/chroot=\/var\/lib\/powerdns/' \
+ "${D}"/etc/powerdns/recursor.conf
+
+ newinitd "${FILESDIR}"/pdns-recursor-r1 pdns-recursor
+
+ keepdir /var/lib/powerdns
+}
+
+pkg_postinst() {
+ local old
+
+ for old in ${REPLACING_VERSIONS}; do
+ version_compare ${old} 4.0.0-r1
+ [[ $? -eq 1 ]] || continue
+
+ ewarn "Starting with 4.0.0-r1 the init script has been renamed from precursor"
+ ewarn "to pdns-recursor, please update your runlevels accordingly."
+
+ break
+ done
+}