summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-10 04:38:04 +0000
committerSam James <sam@gentoo.org>2022-12-10 04:38:04 +0000
commitd692fe5728413811fd1ffefcf6b65def1255cdf2 (patch)
tree1aaa39065b05afb912d6cf6d4719a205715f5e5d
parentnet-misc/chrony: drop 4.3-r1 (diff)
downloadgentoo-d692fe5728413811fd1ffefcf6b65def1255cdf2.tar.gz
gentoo-d692fe5728413811fd1ffefcf6b65def1255cdf2.tar.bz2
gentoo-d692fe5728413811fd1ffefcf6b65def1255cdf2.zip
app-forensics/aflplusplus: drop 4.02c-r1
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-forensics/aflplusplus/Manifest1
-rw-r--r--app-forensics/aflplusplus/aflplusplus-4.02c-r1.ebuild85
2 files changed, 0 insertions, 86 deletions
diff --git a/app-forensics/aflplusplus/Manifest b/app-forensics/aflplusplus/Manifest
index 3e32b229cde6..0693d54c0bc7 100644
--- a/app-forensics/aflplusplus/Manifest
+++ b/app-forensics/aflplusplus/Manifest
@@ -1,4 +1,3 @@
DIST aflplusplus-4.01c.tar.gz 2818445 BLAKE2B f3699c4b2fabec0ab238277c3b2c7b19b35af7a0b82b14a57c34b8579121cfa0644ef432132cf4a3382547db3faf799d2ab601512ddfb469e4a2246cdb61aa7f SHA512 d2b03ab4ff9538fe0b52aa3ed4778a6e5657d64d6f0e5f75a99305bad69c5179d6b1c882650f19a884a740577acb73dab7cee3d5c9c7b06ff2326ffeba37d1fe
-DIST aflplusplus-4.02c.tar.gz 2828429 BLAKE2B 0c4d7937626a699bb6768e2f67f369508f7ec131d1170cd48f8650d8081135b466733de34e52f2ac2213c4bd13ab8936b17d3b0f8debf28e8a32ad87d9dcb55d SHA512 f5159a84e0ecd2c260d2d8ce7df33fe4704c664bdf06f193a7fef377d48646e4d921ee90d0b66c7dac02d16e6b1607c6569351aaeea9b2ee3968d22b3f583763
DIST aflplusplus-4.03c-patches.tar.xz 4444 BLAKE2B 4eed2ee97e4f7aef987e5c931469b7bb1d85310cb101878e5e71431ac36329a07b0e05812ed1e743c6ed3ce76e10c4392f2bf7ccc98ec1537b75196c5629acfe SHA512 bcaa196640f47923be6daa65e3c5f8461eadaec3b939f2cfe0223eacc64be385c80166ec7dc0df25d0c38053a38c3efcfbc25d8387bed5c54c95a8781ed64b00
DIST aflplusplus-4.03c.tar.gz 2830718 BLAKE2B 1b55daf3c3a0a0b11c1ef0a7dd1005cfa1ec61fb54691b96519f57788233b1385b52948468f2d5beada3c58129bc0524f07aebfb25ee8cef1e5d5afd06b1233d SHA512 4bab00d964eb9d0664d97062f5da8090dfef599480f25b04d08b84e7f47676a9790fb23573f7e885b5da6ab813694f9ab26a0b5c9d341834892530558e3b83ef
diff --git a/app-forensics/aflplusplus/aflplusplus-4.02c-r1.ebuild b/app-forensics/aflplusplus/aflplusplus-4.02c-r1.ebuild
deleted file mode 100644
index 1e726329302b..000000000000
--- a/app-forensics/aflplusplus/aflplusplus-4.02c-r1.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-LLVM_MAX_SLOT=14
-inherit toolchain-funcs llvm optfeature python-single-r1
-
-DESCRIPTION="A fork of AFL, the popular compile-time instrumentation fuzzer"
-HOMEPAGE="https://github.com/AFLplusplus/AFLplusplus"
-SRC_URI="https://github.com/AFLplusplus/AFLplusplus/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/AFLplusplus-${PV}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# Tests involve heavy use of LD_PRELOAD in some cases
-# This isn't compatible with sandbox
-RESTRICT="test"
-
-# It turns out we need Clang too
-RDEPEND="${PYTHON_DEPS}
- >=sys-devel/llvm-13:=
- || (
- sys-devel/clang:13
- sys-devel/clang:${LLVM_MAX_SLOT}
- )
- !app-forensics/afl"
-DEPEND="${RDEPEND}
- test? ( dev-util/cmocka )"
-
-QA_PREBUILT="usr/share/afl/testcases/others/elf/small_exec.elf"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.02c-respect-flags.patch
- "${FILESDIR}"/${PN}-4.02c-no-ignore-errors-makefile.patch
- "${FILESDIR}"/${PN}-4.01c-lld-detect.patch
-)
-
-llvm_check_deps() {
- has_version -b "sys-devel/clang:${LLVM_SLOT}" && \
- has_version -b "sys-devel/llvm:${LLVM_SLOT}"
-}
-
-pkg_setup() {
- llvm_pkg_setup
- python-single-r1_pkg_setup
-}
-
-mymake() {
- emake \
- CC="$(tc-getCC)" \
- CXX="$(tc-getCXX)" \
- CFLAGS_FLTO="" \
- LLVM_CONFIG="$(get_llvm_prefix ${LLVM_MAX_SLOT})"/bin/llvm-config \
- PREFIX="${EPREFIX}/usr" \
- HELPER_PATH="${EPREFIX}/usr/$(get_libdir)/afl" \
- DOC_PATH="${EPREFIX}/usr/share/doc/${PF}" \
- MAN_PATH="${EPREFIX}/usr/share/man/man8" \
- "$@"
-}
-
-src_compile() {
- mymake
-}
-
-src_test() {
- mymake test
-}
-
-src_install() {
- mymake DESTDIR="${D}" install
- dostrip -x /usr/share/afl/testcases/
-}
-
-pkg_postinst() {
- # TODO: Any others?
- optfeature "fuzzing with AFL_USE_ASAN" sys-libs/compiler-rt-sanitizers[asan]
- optfeature "fuzzing with AFL_USE_MSAN" sys-libs/compiler-rt-sanitizers[msan]
-}