summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Parborg <darkdefende@gmail.com>2024-01-18 18:35:39 +0100
committerSam James <sam@gentoo.org>2024-03-25 18:54:56 +0000
commitd6a49278fce2aaedc156af350264b3a4bca9166e (patch)
tree1e112365ef10ebcfc22da6308ef78683aef893c8
parentmedia-gfx/blender: fix error "string sub-command REGEX, mode REPLACE needs at... (diff)
downloadgentoo-d6a49278.tar.gz
gentoo-d6a49278.tar.bz2
gentoo-d6a49278.zip
media-gfx/blender: Update required_use and make the configure step strict
With WITH_STRICT_BUILD_OPTIONS, it should now error out if a build option can not be enabled instead of just warning and disabling it. Signed-off-by: Sebastian Parborg <darkdefende@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-gfx/blender/blender-4.0.2.ebuild15
-rw-r--r--media-gfx/blender/blender-9999.ebuild16
2 files changed, 12 insertions, 19 deletions
diff --git a/media-gfx/blender/blender-4.0.2.ebuild b/media-gfx/blender/blender-4.0.2.ebuild
index 853b1444f8d1..a3d8c753a9c5 100644
--- a/media-gfx/blender/blender-4.0.2.ebuild
+++ b/media-gfx/blender/blender-4.0.2.ebuild
@@ -36,12 +36,12 @@ RESTRICT="test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
alembic? ( openexr )
cuda? ( cycles )
- cycles? ( openexr tiff )
+ cycles? ( openexr tiff tbb )
fluid? ( tbb )
nanovdb? ( openvdb )
- openvdb? ( tbb )
+ openvdb? ( tbb openexr )
optix? ( cuda )
- osl? ( cycles )
+ osl? ( cycles pugixml )
test? ( color-management )"
# Library versions for official builds can be found in the blender source directory in:
@@ -252,6 +252,7 @@ src_configure() {
-DWITH_ALEMBIC=$(usex alembic)
-DWITH_BOOST=yes
-DWITH_BULLET=$(usex bullet)
+ -DWITH_CLANG=$(usex osl)
-DWITH_CODEC_FFMPEG=$(usex ffmpeg)
-DWITH_CODEC_SNDFILE=$(usex sndfile)
-DWITH_CYCLES=$(usex cycles)
@@ -286,6 +287,7 @@ src_configure() {
-DWITH_INPUT_NDOF=$(usex ndof)
-DWITH_INTERNATIONAL=$(usex nls)
-DWITH_JACK=$(usex jack)
+ -DWITH_LLVM=$(usex osl)
-DWITH_MATERIALX=no
-DWITH_MEM_JEMALLOC=$(usex jemalloc)
-DWITH_MEM_VALGRIND=$(usex valgrind)
@@ -309,6 +311,7 @@ src_configure() {
-DWITH_PYTHON_INSTALL_ZSTANDARD=no
-DWITH_SDL=$(usex sdl)
-DWITH_STATIC_LIBS=no
+ -DWITH_STRICT_BUILD_OPTIONS=yes
-DWITH_SYSTEM_EIGEN3=yes
-DWITH_SYSTEM_FREETYPE=yes
-DWITH_SYSTEM_LZO=yes
@@ -343,12 +346,6 @@ src_configure() {
# Ease compiling with required gcc similar to cuda_sanitize but for cmake
use cuda && use cycles-bin-kernels && mycmakeargs+=( -DCUDA_HOST_COMPILER="$(cuda_gccdir)" )
fi
- if tc-is-clang ; then
- mycmakeargs+=(
- -DWITH_CLANG=yes
- -DWITH_LLVM=yes
- )
- fi
if use test ; then
local CYCLES_TEST_DEVICES=( "CPU" )
diff --git a/media-gfx/blender/blender-9999.ebuild b/media-gfx/blender/blender-9999.ebuild
index bbc7162d1b80..b6449853c804 100644
--- a/media-gfx/blender/blender-9999.ebuild
+++ b/media-gfx/blender/blender-9999.ebuild
@@ -36,13 +36,13 @@ RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
alembic? ( openexr )
cuda? ( cycles )
- cycles? ( openexr tiff )
+ cycles? ( openexr tiff tbb )
fluid? ( tbb )
hip? ( cycles )
nanovdb? ( openvdb )
- openvdb? ( tbb )
+ openvdb? ( tbb openexr )
optix? ( cuda )
- osl? ( cycles )
+ osl? ( cycles pugixml )
test? ( color-management )"
# Library versions for official builds can be found in the blender source directory in:
@@ -254,6 +254,7 @@ src_configure() {
-DWITH_ALEMBIC=$(usex alembic)
-DWITH_BOOST=yes
-DWITH_BULLET=$(usex bullet)
+ -DWITH_CLANG=$(usex osl)
-DWITH_CODEC_FFMPEG=$(usex ffmpeg)
-DWITH_CODEC_SNDFILE=$(usex sndfile)
-DWITH_CYCLES=$(usex cycles)
@@ -273,7 +274,6 @@ src_configure() {
-DWITH_FFTW3=$(usex fftw)
-DWITH_GHOST_WAYLAND=$(usex wayland)
-DWITH_GHOST_WAYLAND_APP_ID="blender-${BV}"
- -DWITH_GHOST_WAYLAND_DBUS=$(usex wayland)
-DWITH_GHOST_WAYLAND_DYNLOAD=no
-DWITH_GHOST_WAYLAND_LIBDECOR=no
-DWITH_GHOST_X11=$(usex X)
@@ -288,6 +288,7 @@ src_configure() {
-DWITH_INPUT_NDOF=$(usex ndof)
-DWITH_INTERNATIONAL=$(usex nls)
-DWITH_JACK=$(usex jack)
+ -DWITH_LLVM=$(usex osl)
-DWITH_MATERIALX=no
-DWITH_MEM_JEMALLOC=$(usex jemalloc)
-DWITH_MEM_VALGRIND=$(usex valgrind)
@@ -311,6 +312,7 @@ src_configure() {
-DWITH_PYTHON_INSTALL_ZSTANDARD=no
-DWITH_SDL=$(usex sdl)
-DWITH_STATIC_LIBS=no
+ -DWITH_STRICT_BUILD_OPTIONS=yes
-DWITH_SYSTEM_EIGEN3=yes
-DWITH_SYSTEM_FREETYPE=yes
-DWITH_SYSTEM_LZO=yes
@@ -345,12 +347,6 @@ src_configure() {
# Ease compiling with required gcc similar to cuda_sanitize but for cmake
use cuda && use cycles-bin-kernels && mycmakeargs+=( -DCUDA_HOST_COMPILER="$(cuda_gccdir)" )
fi
- if tc-is-clang ; then
- mycmakeargs+=(
- -DWITH_CLANG=yes
- -DWITH_LLVM=yes
- )
- fi
if use test ; then
local CYCLES_TEST_DEVICES=( "CPU" )