summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-27 13:31:47 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-27 14:17:11 +0100
commitd6df2aeba6c0a5aa9b88e706a76b2c535832dc46 (patch)
treef9124306151bbcc5bf0d4e1da9d11f144fc5b349
parentdev-cpp/gflags: arm stable wrt bug #700774 (diff)
downloadgentoo-d6df2aeb.tar.gz
gentoo-d6df2aeb.tar.bz2
gentoo-d6df2aeb.zip
dev-python/pytest: Remove redudant version
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest/Manifest1
-rw-r--r--dev-python/pytest/files/pytest-5.0.1-test_xfail_rmdir.patch38
-rw-r--r--dev-python/pytest/pytest-5.0.1.ebuild68
3 files changed, 0 insertions, 107 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index ae1fac75058f..0a0234192f65 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -1,5 +1,4 @@
DIST pytest-3.10.1.tar.gz 892420 BLAKE2B 38849ae69bf4380bc1a99aa105cac04be078da4460373dfc16fa555238b2830fa2f5ae6c19de8aa2af9ac18d87c5d2705d62f7b2e67e4a62d843f6a28bbd76fd SHA512 30ff79c0fdcbeef68e1191ff400a20428e391717f06957f554b694b94baaaa565dca01346fe989c3e443c4402f3b2bdbd5564f6303a4447f933fb54cba45628f
DIST pytest-4.5.0.tar.gz 943607 BLAKE2B 49a0e91fda7f4231fdd39f90eb2daa344d3034c10faff221330ea0ae7482a2a7d0fb9443a0a264db00f1d92568d5a6005cb73e07d8643b46906f7ecff831adcb SHA512 cbffc6216f83491b1de241058315c116697bfaa5206b5f558192a7f861d43dd036d30d0d689bedae7bdee4f0258dd19ef5827c356e11863dd596a5fabe8249fc
DIST pytest-4.6.6.tar.gz 954899 BLAKE2B d3d76ec1fff18d343cc799f1acd0889489f303cdba72747881dfab8656599bc1865f01b5ad2754f0d05bda04aca4d7edf8c2071f2257fdf41506308d1bc0f623 SHA512 c5b6c21c352787eadce06be7529ecb6f6fd5f5eb193ec29e5a4cfff3d7e305f50c6f07aeac15bddce007d88077a35a8f59633111815321792ed3d9fa1011b684
-DIST pytest-5.0.1.tar.gz 949744 BLAKE2B c949f0fb6bc0d1430ec7c780537f8aee8ca1ebea5f89035d882434236c6af7d431a610774dbafa93552406e38852627a9f949a6f9198a792de9371efadb4f6ff SHA512 92f5feb263a8708ef6cb8f4565688620b6bfeaef23536cfd24b9bc09515e37fdecd7fa8bcaeeb0775c0be1d8e9dcbd9a56e52f97fb13dc98116efc0056f870db
DIST pytest-5.3.0.tar.gz 992537 BLAKE2B 4386d1623bdc168313a75847dfa33413ab1b6a4de9380c67ae866a579dbeb62d8cd18da899bf0476827d6e4a76ddfc5fee7a2fdc652eff0c8848c0bd96045c47 SHA512 285d0b4f6b87b141d6d5dac368dc46eb80dd025d7ed4ad0db937fcc76efc1f8cf251ca9b0786ab1bdadd89c07ad8ddd74f2b3496f97326e9d7fccfd004b98aff
diff --git a/dev-python/pytest/files/pytest-5.0.1-test_xfail_rmdir.patch b/dev-python/pytest/files/pytest-5.0.1-test_xfail_rmdir.patch
deleted file mode 100644
index 5c6154cd92c0..000000000000
--- a/dev-python/pytest/files/pytest-5.0.1-test_xfail_rmdir.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From ab39502c98f40c03a2956dcf6c6b9daf5ee41a63 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
-Date: Fri, 26 Jul 2019 02:23:14 +0200
-Subject: [PATCH] In test_xfail_handling, only remove __pycache__ if it exists
-
-Previously, the test failed when the directory was not present,
-which could have been caused for example by invoking the tests
-with PYTHONDONTWRITEBYTECODE=1.
-
-Fixes https://github.com/pytest-dev/pytest/issues/5664
----
- changelog/5664.trivial.rst | 2 ++
- testing/test_stepwise.py | 3 ++-
- 2 files changed, 4 insertions(+), 1 deletion(-)
- create mode 100644 changelog/5664.trivial.rst
-
-diff --git a/changelog/5664.trivial.rst b/changelog/5664.trivial.rst
-new file mode 100644
-index 000000000..3928454ef
---- /dev/null
-+++ b/changelog/5664.trivial.rst
-@@ -0,0 +1,2 @@
-+When invoking pytest's own testsuite with ``PYTHONDONTWRITEBYTECODE=1``,
-+the ``test_xfail_handling`` test no longer fails.
-diff --git a/testing/test_stepwise.py b/testing/test_stepwise.py
-index 591d67b6c..f61425b6b 100644
---- a/testing/test_stepwise.py
-+++ b/testing/test_stepwise.py
-@@ -207,7 +207,8 @@ def test_d(): pass
-
- # because we are writing to the same file, mtime might not be affected enough to
- # invalidate the cache, making this next run flaky
-- testdir.tmpdir.join("__pycache__").remove()
-+ if testdir.tmpdir.join("__pycache__").exists():
-+ testdir.tmpdir.join("__pycache__").remove()
- testdir.makepyfile(contents.format(assert_value="0", strict="True"))
- result = testdir.runpytest("--sw", "-v")
- result.stdout.fnmatch_lines(
diff --git a/dev-python/pytest/pytest-5.0.1.ebuild b/dev-python/pytest/pytest-5.0.1.ebuild
deleted file mode 100644
index 15641dad00a6..000000000000
--- a/dev-python/pytest/pytest-5.0.1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{5,6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# When bumping, please check setup.py for the proper py version
-PY_VER="1.5.0"
-
-# pathlib2 has been added to stdlib before py3.6, but pytest needs __fspath__
-# support, which only came in py3.6.
-RDEPEND="
- >=dev-python/atomicwrites-1.0[${PYTHON_USEDEP}]
- >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python3_5 )
- >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
- <dev-python/pluggy-1
- >=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/wcwidth[${PYTHON_USEDEP}]
- virtual/python-funcsigs[${PYTHON_USEDEP}]"
-
-# flake cause a number of tests to fail
-DEPEND="${RDEPEND}
- test? (
- >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- >=dev-python/setuptools-40[${PYTHON_USEDEP}]
- !!dev-python/flaky
- )"
-
-PATCHES=(
- "${FILESDIR}/${PN}"-4.5.0-strip-setuptools_scm.patch
- "${FILESDIR}/${PN}"-5.0.1-test_xfail_rmdir.patch
-)
-
-python_prepare_all() {
- grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
-
- # Something in the ebuild environment causes this to hang/error.
- # https://bugs.gentoo.org/598442
- rm testing/test_pdb.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${EPYTHON}" "${BUILD_DIR}"/lib/pytest.py -vv --lsof -rfsxX \
- || die "tests failed with ${EPYTHON}"
-}