summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@gmail.com>2020-02-07 10:42:34 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-07 10:42:34 +0100
commitd6e49da338f6a6ce88c7bab2a4bbb643d603d95b (patch)
tree2b486ee2b9b6ee408449c0dcf27d7ba7b6a50acc
parentx11-libs/gtkdatabox: Remove old (diff)
downloadgentoo-d6e49da3.tar.gz
gentoo-d6e49da3.tar.bz2
gentoo-d6e49da3.zip
sci-biology/bcftools: fix PYTHON_COMPAT, add missing matplotlib dep
From NEWS one can infer bcftools was at least from about 1.7 version python3 compatible. Moreover, at the moment the shenbang lines specifically call python3.6. So, adjust the PYTHON_COMPAT accordingly. matplotlib is used by the python scripts, unconditionally. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Closes: https://github.com/gentoo/gentoo/pull/14421 Signed-off-by: Martin Mokrejs <mmokrejs@fold.natur.cuni.cz> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sci-biology/bcftools/bcftools-1.9-r1.ebuild (renamed from sci-biology/bcftools/bcftools-1.9.ebuild)8
-rw-r--r--sci-biology/bcftools/files/bcftools-1.9-buildsystem.patch10
2 files changed, 14 insertions, 4 deletions
diff --git a/sci-biology/bcftools/bcftools-1.9.ebuild b/sci-biology/bcftools/bcftools-1.9-r1.ebuild
index 53e47bc01a81..8141e6d22924 100644
--- a/sci-biology/bcftools/bcftools-1.9.ebuild
+++ b/sci-biology/bcftools/bcftools-1.9-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_6 )
inherit python-single-r1
@@ -14,18 +14,18 @@ SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
dev-lang/perl
+ dev-python/matplotlib[${PYTHON_USEDEP}]
=sci-libs/htslib-${PV}*:=
sys-libs/zlib:=
${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
PATCHES=(
- "${FILESDIR}"/${PN}-1.5-buildsystem.patch
+ "${FILESDIR}"/${PN}-1.9-buildsystem.patch
"${FILESDIR}"/${PN}-1.9-fix-shebangs.patch
)
diff --git a/sci-biology/bcftools/files/bcftools-1.9-buildsystem.patch b/sci-biology/bcftools/files/bcftools-1.9-buildsystem.patch
new file mode 100644
index 000000000000..a0df4b917bcb
--- /dev/null
+++ b/sci-biology/bcftools/files/bcftools-1.9-buildsystem.patch
@@ -0,0 +1,10 @@
+--- a/Makefile
++++ b/Makefile
+@@ -282,7 +282,6 @@
+ $(INSTALL_PROGRAM) $(PROGRAMS) $(DESTDIR)$(bindir)
+ $(INSTALL_SCRIPT) $(MISC_SCRIPTS) $(DESTDIR)$(misc_bindir)
+ $(INSTALL_MAN) doc/bcftools.1 $(DESTDIR)$(man1dir)
+- $(INSTALL_PROGRAM) plugins/*.so $(DESTDIR)$(plugindir)
+
+ clean: testclean clean-plugins
+ -rm -f gmon.out *.o *~ $(PROGRAMS) version.h plugins/*.so plugins/*.P