summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-09-02 07:17:53 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-09-02 07:28:07 -0400
commitd6e742b3835750d6992128d07b34165f65a57818 (patch)
treef252426d0ba829bc7964eff44320368d7e09d152
parentsci-libs/givaro: fix pkg-config libdir, update EAPI 7 -> 8 (diff)
downloadgentoo-d6e742b3.tar.gz
gentoo-d6e742b3.tar.bz2
gentoo-d6e742b3.zip
sci-libs/fflas-ffpack: fix pkg-config libdir, update EAPI 7 -> 8
Apply François Bissey's upstream patch in a new revision. Closes: https://bugs.gentoo.org/862747 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--sci-libs/fflas-ffpack/fflas-ffpack-2.4.3-r3.ebuild75
-rw-r--r--sci-libs/fflas-ffpack/files/fflas-ffpack-2.4.3-fix-pc-libdir.patch21
2 files changed, 96 insertions, 0 deletions
diff --git a/sci-libs/fflas-ffpack/fflas-ffpack-2.4.3-r3.ebuild b/sci-libs/fflas-ffpack/fflas-ffpack-2.4.3-r3.ebuild
new file mode 100644
index 000000000000..87c452d6e355
--- /dev/null
+++ b/sci-libs/fflas-ffpack/fflas-ffpack-2.4.3-r3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Library for dense linear algebra over word-size finite fields"
+HOMEPAGE="https://linbox-team.github.io/fflas-ffpack/"
+SRC_URI="https://github.com/linbox-team/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="openmp cpu_flags_x86_fma3 cpu_flags_x86_fma4 cpu_flags_x86_sse3 cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_avx512f cpu_flags_x86_avx512dq cpu_flags_x86_avx512vl"
+
+# Our autotools patch hacks in PKG_CHECK_MODULES calls.
+BDEPEND="virtual/pkgconfig"
+DEPEND="virtual/cblas
+ virtual/blas
+ virtual/lapack
+ dev-libs/gmp[cxx(+)]
+ =sci-libs/givaro-4.1*"
+RDEPEND="${DEPEND}"
+
+# The no-test-echelon patch works around a test failure that may
+# eventually be fixed upstream. Gentoo bug 725446 and upstream
+# Github issue 282. Same for test-fgesv (bug 807100).
+PATCHES=(
+ "${FILESDIR}/${PN}-2.3.2-blaslapack.patch"
+ "${FILESDIR}/${P}-no-test-echelon.patch"
+ "${FILESDIR}/${P}-no-test-fgesv.patch"
+ "${FILESDIR}/${P}-fix-internal-linking.patch"
+ "${FILESDIR}/${P}-no-fabi-version.patch"
+ "${FILESDIR}/${P}-fix-pc-libdir.patch"
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ tc-export PKG_CONFIG
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-precompilation \
+ $(use_enable openmp) \
+ $(use_enable cpu_flags_x86_fma3 fma) \
+ $(use_enable cpu_flags_x86_fma4 fma4) \
+ $(use_enable cpu_flags_x86_sse3 sse3) \
+ $(use_enable cpu_flags_x86_ssse3 ssse3) \
+ $(use_enable cpu_flags_x86_sse4_1 sse41) \
+ $(use_enable cpu_flags_x86_sse4_2 sse42) \
+ $(use_enable cpu_flags_x86_avx avx) \
+ $(use_enable cpu_flags_x86_avx2 avx2) \
+ $(use_enable cpu_flags_x86_avx512f avx512f) \
+ $(use_enable cpu_flags_x86_avx512dq avx512dq) \
+ $(use_enable cpu_flags_x86_avx512vl avx512vl)
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}
diff --git a/sci-libs/fflas-ffpack/files/fflas-ffpack-2.4.3-fix-pc-libdir.patch b/sci-libs/fflas-ffpack/files/fflas-ffpack-2.4.3-fix-pc-libdir.patch
new file mode 100644
index 000000000000..e397758b5fc5
--- /dev/null
+++ b/sci-libs/fflas-ffpack/files/fflas-ffpack-2.4.3-fix-pc-libdir.patch
@@ -0,0 +1,21 @@
+From b1f7cadc105bcf1264da68ab69e0cdc6f8a5aa63 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Fran=C3=A7ois=20Bissey?= <frp.bissey@gmail.com>
+Date: Sun, 7 Aug 2022 14:15:49 +1200
+Subject: [PATCH] Fix fflas-ffpack.pc.in for issue #364
+
+---
+ fflas-ffpack.pc.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/fflas-ffpack.pc.in b/fflas-ffpack.pc.in
+index b869dd8f..8d6c823a 100644
+--- a/fflas-ffpack.pc.in
++++ b/fflas-ffpack.pc.in
+@@ -1,6 +1,6 @@
+ prefix=@prefix@
+ exec_prefix=@prefix@
+-libdir=@prefix@/lib
++libdir=@libdir@
+ includedir=@prefix@/include
+
+ Name: fflas-ffpack