summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2022-10-01 14:29:52 -0500
committerJohn Helmert III <ajak@gentoo.org>2022-10-01 15:21:39 -0500
commitd6faeb93a9fd12841e72541af5fde5be7887be38 (patch)
tree24ae6f4aaa5ee7be98bd59849023e5adbe0f563b
parentnet-im/synapse: Stabilize 1.66.0 amd64, #873811 (diff)
downloadgentoo-d6faeb93a9fd12841e72541af5fde5be7887be38.tar.gz
gentoo-d6faeb93a9fd12841e72541af5fde5be7887be38.tar.bz2
gentoo-d6faeb93a9fd12841e72541af5fde5be7887be38.zip
app-misc/wally-cli: new package, add 2.0.1
Signed-off-by: John Helmert III <ajak@gentoo.org>
-rw-r--r--app-misc/wally-cli/Manifest2
-rw-r--r--app-misc/wally-cli/metadata.xml12
-rw-r--r--app-misc/wally-cli/wally-cli-2.0.1.ebuild27
3 files changed, 41 insertions, 0 deletions
diff --git a/app-misc/wally-cli/Manifest b/app-misc/wally-cli/Manifest
new file mode 100644
index 000000000000..3c8d2fedc5eb
--- /dev/null
+++ b/app-misc/wally-cli/Manifest
@@ -0,0 +1,2 @@
+DIST wally-cli-2.0.1-deps.tar.xz 2545464 BLAKE2B 3a1b41d5386e87db69a6d877fcc471cece97e34f913c3b9a4b87ed252f2f79aa335acacc1ffb0706d8a2596b9775ca9fab2d9fc4da9c11f7b8b933e05cb680cb SHA512 45cb90e614031ba674ea384cc829d748f706839b2d928f2e11e268f5991f7704a48f1333f794f4a140c16256cf29f4ee4da05a7a4e0be9107285d2c86a50ca77
+DIST wally-cli-2.0.1.tar.gz 6641 BLAKE2B 876a1e237d08c43b90c89ef596ad9015a6f641d3282296b9e3c846a7bf7fa27988605902deaae9e2c95b9c8bf10a2e2304c3ad5b1812001a45b6ca93eb0210bd SHA512 998035e5d932892245cd6db13682501dc5e65a79b724e9ed66733c955bf6646c46c5cb59214160cd5bc5710949dcd43f054ae72b5adb757aa12e3cece92df4bc
diff --git a/app-misc/wally-cli/metadata.xml b/app-misc/wally-cli/metadata.xml
new file mode 100644
index 000000000000..c6b4af121f15
--- /dev/null
+++ b/app-misc/wally-cli/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ajak@gentoo.org</email>
+ <name>John Helmert III</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">zsa/wally-cli</remote-id>
+ <changelog>https://github.com/zsa/wally-cli/releases</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/wally-cli/wally-cli-2.0.1.ebuild b/app-misc/wally-cli/wally-cli-2.0.1.ebuild
new file mode 100644
index 000000000000..d87dcb360f59
--- /dev/null
+++ b/app-misc/wally-cli/wally-cli-2.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Flash your ZSA Keyboard the EZ way"
+HOMEPAGE="https://github.com/zsa/wally-cli"
+SRC_URI="https://github.com/zsa/${PN}/archive/refs/tags/${PV}-linux.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~ajak/dist/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+S="${WORKDIR}/${P}-linux"
+
+LICENSE="Apache-2.0 BSD BSD-4 MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( README.md license.md )
+
+src_compile() {
+ go build
+}
+
+src_install() {
+ default
+ dobin wally-cli
+}