summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-10-25 11:03:27 -0400
committerBrian Evans <grknight@gentoo.org>2018-10-25 11:03:27 -0400
commitd700bd2e4b7ab2dd6874044ce2e60495dc1f1075 (patch)
treed2181640980038c2993a29a513b71d4b747e1ded
parentwww-client/opera-beta: Old (diff)
downloadgentoo-d700bd2e4b7ab2dd6874044ce2e60495dc1f1075.tar.gz
gentoo-d700bd2e4b7ab2dd6874044ce2e60495dc1f1075.tar.bz2
gentoo-d700bd2e4b7ab2dd6874044ce2e60495dc1f1075.zip
dev-lang/php: Always call elibtoolize
Certain functions of external commands, like pecl, may use an older libtool which is included with PHP. Now we always have an updated ltmain.sh by calling elibtoolize Bug: https://bugs.gentoo.org/669566 Signed-off-by: Brian Evans <grknight@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-lang/php/php-7.1.23.ebuild7
-rw-r--r--dev-lang/php/php-7.2.11.ebuild7
-rw-r--r--dev-lang/php/php-7.3.0_rc3.ebuild7
3 files changed, 18 insertions, 3 deletions
diff --git a/dev-lang/php/php-7.1.23.ebuild b/dev-lang/php/php-7.1.23.ebuild
index 4f54e9a7a856..b5d12b4aed60 100644
--- a/dev-lang/php/php-7.1.23.ebuild
+++ b/dev-lang/php/php-7.1.23.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit flag-o-matic eapi7-ver systemd
+inherit flag-o-matic eapi7-ver systemd autotools
DESCRIPTION="The PHP language runtime engine"
HOMEPAGE="https://secure.php.net/"
@@ -219,6 +219,11 @@ src_prepare() {
sed -i "s~^include=.*$~include=${PHP_INI_DIR}/fpm.d/*.conf~" \
sapi/fpm/php-fpm.conf.in \
|| die 'failed to move the include directory in php-fpm.conf'
+
+ # Bug 669566 - necessary so that build tools are updated for commands like pecl
+ # Force rebuilding aclocal.m4
+ rm -f aclocal.m4 || die "failed to remove aclocal.m4 in src_prepare"
+ eautoreconf
}
src_configure() {
diff --git a/dev-lang/php/php-7.2.11.ebuild b/dev-lang/php/php-7.2.11.ebuild
index 761d9460704b..818e210d1a58 100644
--- a/dev-lang/php/php-7.2.11.ebuild
+++ b/dev-lang/php/php-7.2.11.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit flag-o-matic eapi7-ver systemd
+inherit flag-o-matic eapi7-ver systemd autotools
DESCRIPTION="The PHP language runtime engine"
HOMEPAGE="https://secure.php.net/"
@@ -224,6 +224,11 @@ src_prepare() {
sed -i "s~^include=.*$~include=${PHP_INI_DIR}/fpm.d/*.conf~" \
sapi/fpm/php-fpm.conf.in \
|| die 'failed to move the include directory in php-fpm.conf'
+
+ # Bug 669566 - necessary so that build tools are updated for commands like pecl
+ # Force rebuilding aclocal.m4
+ rm -f aclocal.m4 || die "failed to remove aclocal.m4 in src_prepare"
+ eautoreconf
}
src_configure() {
diff --git a/dev-lang/php/php-7.3.0_rc3.ebuild b/dev-lang/php/php-7.3.0_rc3.ebuild
index 38dbc82aca6b..865dac62201a 100644
--- a/dev-lang/php/php-7.3.0_rc3.ebuild
+++ b/dev-lang/php/php-7.3.0_rc3.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit flag-o-matic eapi7-ver systemd
+inherit flag-o-matic eapi7-ver systemd autotools
MY_PV=${PV/_rc/RC}
DESCRIPTION="The PHP language runtime engine"
@@ -226,6 +226,11 @@ src_prepare() {
sed -i "s~^include=.*$~include=${PHP_INI_DIR}/fpm.d/*.conf~" \
sapi/fpm/php-fpm.conf.in \
|| die 'failed to move the include directory in php-fpm.conf'
+
+ # Bug 669566 - necessary so that build tools are updated for commands like pecl
+ # Force rebuilding aclocal.m4
+ rm -f aclocal.m4 || die "failed to remove aclocal.m4 in src_prepare"
+ eautoreconf
}
src_configure() {