summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-10-27 13:42:04 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-10-27 13:42:04 +0200
commitd7029dfdb533b3aa257b7b06376fddbe76eaaf39 (patch)
tree1c0368252d2ee0a006108a59f90c3e0d04413232
parentapp-portage/repoman: Remove old (diff)
downloadgentoo-d7029dfd.tar.gz
gentoo-d7029dfd.tar.bz2
gentoo-d7029dfd.zip
sys-cluster/minikube: Version bump to 0.23.0
Package-Manager: Portage-2.3.12, Repoman-2.3.3
-rw-r--r--sys-cluster/minikube/Manifest1
-rw-r--r--sys-cluster/minikube/minikube-0.23.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-cluster/minikube/Manifest b/sys-cluster/minikube/Manifest
index c8b34c4cdca6..44cd215dd04a 100644
--- a/sys-cluster/minikube/Manifest
+++ b/sys-cluster/minikube/Manifest
@@ -1 +1,2 @@
DIST minikube-0.22.3.tar.gz 18675181 SHA256 c27b870da46048b8d0eb775f86b8351e21583cf234f7c722ac92e18edf098dac SHA512 2ef1f64a5011bb57034e1d873730c55284ce008ab480775c64a66a148118bf0f66608177244a29527ac984aa34d9d39400d4d42006b930bdb35da6551e936833 WHIRLPOOL 92636e47bb9604211979cfcdc8b936fe4b5b1ce9938ceb8121a3c6fc25895fa383626226c7c8107838235fa16e8152162a602b37d8ca1c83962fd65b92d258a5
+DIST minikube-0.23.0.tar.gz 19015892 SHA256 a8f8d220a9082ae16d20f664051ab108092e51efeb10d00dc796fdaa8f69b9b8 SHA512 c89c633b6edf5dcabdc60e6c361b16934c47ee141b49d48192b7f5167e5612a7a7d44d79cf595161ac44826f8053051ace5300cdf64c710bd2c3b4247c159522 WHIRLPOOL 536a34cf88907dc8d89f4195d61ac239c4d3a3477f23cd3cfacc0b99910a33a019e21f8e6372e2dca28d4bec3b22e1275fdac25b285c5b0cb76f83485bf13bce
diff --git a/sys-cluster/minikube/minikube-0.23.0.ebuild b/sys-cluster/minikube/minikube-0.23.0.ebuild
new file mode 100644
index 000000000000..a345c984a945
--- /dev/null
+++ b/sys-cluster/minikube/minikube-0.23.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit python-any-r1 golang-build golang-vcs-snapshot
+
+EGO_PN="k8s.io/minikube"
+ARCHIVE_URI="https://github.com/kubernetes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Single Node Kubernetes Cluster"
+HOMEPAGE="https://github.com/kubernetes/minikube https://kubernetes.io"
+SRC_URI="${ARCHIVE_URI}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened"
+
+DEPEND="dev-go/go-bindata
+ ${PYTHON_DEPS}"
+RDEPEND=">=sys-cluster/kubectl-1.8.0"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ sed -i -e 's/ -s -w/ -w/' -e 's#$(GOPATH)/bin/go-bindata#go-bindata#' -e 's#GOBIN=$(GOPATH)/bin go get github.com/jteeuwen/go-bindata/...##' src/${EGO_PN}/Makefile || die
+ sed -i -e "s/get_rev(), get_version(), get_tree_state()/get_rev(), get_version(), 'gitTreeState=clean'/" src/${EGO_PN}/hack/get_k8s_version.py || die
+}
+
+src_compile() {
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
+ LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -C src/${EGO_PN}
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin out/minikube
+ dodoc -r docs CHANGELOG.md README.md
+ popd || die
+}