summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-12-02 22:58:12 -0500
committerMike Frysinger <vapier@gentoo.org>2015-12-02 23:00:26 -0500
commitd70614316ff6809f2b88a6aa773eb58523818e0d (patch)
tree3cce1478bd5b6d6c4cb73060c2ed2df2b3d26bce
parentx11-drivers/ati-drivers: remove fetch retriction on 15.9-r1 as file is now fe... (diff)
downloadgentoo-d7061431.tar.gz
gentoo-d7061431.tar.bz2
gentoo-d7061431.zip
www-client/elinks: add USE="gc xml" to control boehm-gc/expat deps
-rw-r--r--www-client/elinks/elinks-0.12_pre6-r1.ebuild11
-rw-r--r--www-client/elinks/elinks-0.12_pre6-r2.ebuild11
-rw-r--r--www-client/elinks/elinks-9999.ebuild11
-rw-r--r--www-client/elinks/metadata.xml2
4 files changed, 23 insertions, 12 deletions
diff --git a/www-client/elinks/elinks-0.12_pre6-r1.ebuild b/www-client/elinks/elinks-0.12_pre6-r1.ebuild
index a9ffcf6941dd..62908260f985 100644
--- a/www-client/elinks/elinks-0.12_pre6-r1.ebuild
+++ b/www-client/elinks/elinks-0.12_pre6-r1.ebuild
@@ -15,14 +15,15 @@ SRC_URI="http://elinks.or.cz/download/${MY_P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="bittorrent bzip2 debug finger ftp gopher gpm guile idn ipv6 \
- javascript lua +mouse nls nntp perl ruby samba ssl unicode X zlib"
+IUSE="bittorrent bzip2 debug finger ftp gc gopher gpm guile idn ipv6
+ javascript lua +mouse nls nntp perl ruby samba ssl unicode X xml zlib"
RESTRICT="test"
-DEPEND="dev-libs/boehm-gc
- >=dev-libs/expat-1.95.4
+DEPEND="
bzip2? ( >=app-arch/bzip2-1.0.2 )
+ gc? ( dev-libs/boehm-gc )
ssl? ( >=dev-libs/openssl-0.9.6g:0 )
+ xml? ( >=dev-libs/expat-1.95.4 )
X? ( x11-libs/libX11 x11-libs/libXt )
zlib? ( >=sys-libs/zlib-1.1.4 )
lua? ( >=dev-lang/lua-5:0 )
@@ -122,6 +123,7 @@ src_configure() {
$(use_with gpm) \
$(use_with zlib) \
$(use_with bzip2 bzlib) \
+ $(use_with gc) \
$(use_with X x) \
$(use_with lua) \
$(use_with guile) \
@@ -138,6 +140,7 @@ src_configure() {
$(use_enable finger) \
$(use_enable samba smb) \
$(use_enable mouse) \
+ $(use_enable xml xbel) \
${myconf}
}
diff --git a/www-client/elinks/elinks-0.12_pre6-r2.ebuild b/www-client/elinks/elinks-0.12_pre6-r2.ebuild
index 23044aac1892..88b93c0b8b1a 100644
--- a/www-client/elinks/elinks-0.12_pre6-r2.ebuild
+++ b/www-client/elinks/elinks-0.12_pre6-r2.ebuild
@@ -15,17 +15,18 @@ SRC_URI="http://elinks.or.cz/download/${MY_P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="bittorrent bzip2 debug finger ftp gopher gpm guile idn ipv6 \
- javascript libressl lua +mouse nls nntp perl ruby samba ssl unicode X zlib"
+IUSE="bittorrent bzip2 debug finger ftp gc gopher gpm guile idn ipv6
+ javascript libressl lua +mouse nls nntp perl ruby samba ssl unicode X xml zlib"
RESTRICT="test"
-DEPEND="dev-libs/boehm-gc
- >=dev-libs/expat-1.95.4
+DEPEND="
bzip2? ( >=app-arch/bzip2-1.0.2 )
+ gc? ( dev-libs/boehm-gc )
ssl? (
!libressl? ( dev-libs/openssl:0 )
libressl? ( dev-libs/libressl )
)
+ xml? ( >=dev-libs/expat-1.95.4 )
X? ( x11-libs/libX11 x11-libs/libXt )
zlib? ( >=sys-libs/zlib-1.1.4 )
lua? ( >=dev-lang/lua-5:0 )
@@ -125,6 +126,7 @@ src_configure() {
$(use_with gpm) \
$(use_with zlib) \
$(use_with bzip2 bzlib) \
+ $(use_with gc) \
$(use_with X x) \
$(use_with lua) \
$(use_with guile) \
@@ -141,6 +143,7 @@ src_configure() {
$(use_enable finger) \
$(use_enable samba smb) \
$(use_enable mouse) \
+ $(use_enable xml xbel) \
${myconf}
}
diff --git a/www-client/elinks/elinks-9999.ebuild b/www-client/elinks/elinks-9999.ebuild
index 476a6210fa07..3feac4b6c251 100644
--- a/www-client/elinks/elinks-9999.ebuild
+++ b/www-client/elinks/elinks-9999.ebuild
@@ -17,14 +17,15 @@ SRC_URI="https://dev.gentoo.org/~spock/portage/distfiles/elinks-0.10.4.conf.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="bittorrent bzip2 debug finger ftp gopher gpm guile idn ipv6 \
- javascript lua +mouse nls nntp perl ruby samba ssl unicode X zlib"
+IUSE="bittorrent bzip2 debug finger ftp gc gopher gpm guile idn ipv6
+ javascript lua +mouse nls nntp perl ruby samba ssl unicode X xml zlib"
RESTRICT="test"
-DEPEND="dev-libs/boehm-gc
- >=dev-libs/expat-1.95.4
+DEPEND="
bzip2? ( >=app-arch/bzip2-1.0.2 )
+ gc? ( dev-libs/boehm-gc )
ssl? ( >=dev-libs/openssl-0.9.6g:0= )
+ xml? ( >=dev-libs/expat-1.95.4 )
X? ( x11-libs/libX11 x11-libs/libXt )
zlib? ( >=sys-libs/zlib-1.1.4 )
lua? ( >=dev-lang/lua-5:0= )
@@ -91,6 +92,7 @@ src_configure() {
$(use_with gpm) \
$(use_with zlib) \
$(use_with bzip2 bzlib) \
+ $(use_with gc) \
$(use_with X x) \
$(use_with lua) \
$(use_with guile) \
@@ -107,6 +109,7 @@ src_configure() {
$(use_enable finger) \
$(use_enable samba smb) \
$(use_enable mouse) \
+ $(use_enable xml xbel) \
${myconf}
}
diff --git a/www-client/elinks/metadata.xml b/www-client/elinks/metadata.xml
index 88787459505e..6ee34d0bf74c 100644
--- a/www-client/elinks/metadata.xml
+++ b/www-client/elinks/metadata.xml
@@ -9,7 +9,9 @@
<use>
<flag name='bittorrent'>Enable support for the BitTorrent protocol</flag>
<flag name='finger'>Enable support for the finger protocol</flag>
+ <flag name='gc'>Enable garbage collection support via <pkg>dev-libs/boehm-gc</pkg></flag>
<flag name='gopher'>Enable support for the gopher protocol</flag>
<flag name='mouse'>Make elinks to grab all mouse events</flag>
+ <flag name='xml'>Enable support for bookmarks via <pkg>dev-libs/expat</pkg></flag>
</use>
</pkgmetadata>