summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-10-14 11:04:00 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-10-14 11:05:06 +0200
commitd7061c37088c4a9f1dc959c6984c77220aad3805 (patch)
tree91eb290311a36f007929e58fc68f0ad8428ed602
parentdev-libs/libnl: Update live ebuild (diff)
downloadgentoo-d7061c37088c4a9f1dc959c6984c77220aad3805.tar.gz
gentoo-d7061c37088c4a9f1dc959c6984c77220aad3805.tar.bz2
gentoo-d7061c37088c4a9f1dc959c6984c77220aad3805.zip
app-text/qpdf: Bump to version 9.0.1
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--app-text/qpdf/Manifest1
-rw-r--r--app-text/qpdf/qpdf-9.0.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-text/qpdf/Manifest b/app-text/qpdf/Manifest
index 72e059fecb22..7a83886e25a6 100644
--- a/app-text/qpdf/Manifest
+++ b/app-text/qpdf/Manifest
@@ -4,3 +4,4 @@ DIST qpdf-8.2.1.tar.gz 8256216 BLAKE2B 67e9b897ed938b9dd2e8508efaddd4dd6f63568aa
DIST qpdf-8.4.1.tar.gz 16990752 BLAKE2B 6e7ccd212cf8d01aea3dc615f5924c0575392f19cdd20b35327a71bd1f97d7e515fe1a73cd2e3901964f621cafa19ab07a1314af19f40ded28d3e9f683c02ab0 SHA512 d5ac3376345650f05278f8b4d99182cd58b927537085a4a6415d3df0b80b7ddd80a7c33778ec8c3b85d9788ea081ea3266bd4a9315eda9820988e9e54a22f80d
DIST qpdf-8.4.2.tar.gz 16988263 BLAKE2B 358836310575fd0f454d4504a70796b72d2e3120c5820e2c33e84ea79c5c115d1c84f8d58392d870b5357407d0fbed05028bd854d164be0b32b348c587845300 SHA512 9cde046fb5e42dc331933294155583fb20408704a0cab3075cc3e97bd4643e3178e4162b8de7434aa2304097e7734f985fdc8e7b05cc028c37193dce91797f7a
DIST qpdf-9.0.0.tar.gz 18172400 BLAKE2B 90b59d54dd87378ccc766f19bc142950f435e4314594fd78923f1c9099393a1b141bf7772f507df7553d9f4afbbe49414c75c0276296481c65017a48d3a5ff01 SHA512 bb20eaf4a12f33ad2ca6933a21123cdfd7d6031da472a881f8c60979881c19bc363db585c2be0635081c7380f0f0819921af7c3a4847de57505013c6e3959ea0
+DIST qpdf-9.0.1.tar.gz 18172693 BLAKE2B ddb389b773b4664c1c3da270f1804f015c8f0a04ed57df7a4a1de9ff80cd47c6fd07c29836573bd6459cde42e8fd3986855a68632495df5363d220d6062669c7 SHA512 1bca5cf39f0019443f744c01ddc93773febca6883063fcec7f3541dd68359d8da44f34cf111cacb3bd9564f10bf1b09ea58173efd3ae06116e5c3832e61e82cc
diff --git a/app-text/qpdf/qpdf-9.0.1.ebuild b/app-text/qpdf/qpdf-9.0.1.ebuild
new file mode 100644
index 000000000000..32bef49367a9
--- /dev/null
+++ b/app-text/qpdf/qpdf-9.0.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for structural, content-preserving transformation of PDF files"
+HOMEPAGE="http://qpdf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qpdf/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 Artistic-2 )"
+
+# subslot = libqpdf soname version
+SLOT="0/26"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~m68k-mint ~sparc-solaris"
+IUSE="doc examples perl static-libs test"
+
+CDEPEND="
+ sys-libs/zlib
+ virtual/jpeg:0=
+"
+DEPEND="${CDEPEND}
+ test? (
+ sys-apps/diffutils
+ media-libs/tiff
+ app-text/ghostscript-gpl[tiff]
+ )
+"
+# Only need perl for the installed tools.
+RDEPEND="${CDEPEND}
+ perl? ( >=dev-lang/perl-5.8 )
+"
+
+DOCS=( ChangeLog README.md TODO )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable test test-compare-images)
+ )
+ CONFIG_SHELL=/bin/bash econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if ! use perl ; then
+ rm "${ED}"/usr/bin/fix-qdf || die
+ rm "${ED}"/usr/share/man/man1/fix-qdf.1 || die
+ fi
+
+ if use examples ; then
+ dobin examples/build/.libs/*
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}