summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-10 15:16:19 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-10 15:16:19 -0500
commitd70e08faec77b9abdedf6369c1811615913fcb3c (patch)
treefea79258fa3fef6a72dfb6567716fa9eae90b1e3
parentapp-crypt/certbot-nginx: 1.8.0 stable amd64/x86 with cleanup (diff)
downloadgentoo-d70e08fa.tar.gz
gentoo-d70e08fa.tar.bz2
gentoo-d70e08fa.zip
dev-python/keystoneauth: 4.2.1 bump
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-python/keystoneauth/Manifest1
-rw-r--r--dev-python/keystoneauth/keystoneauth-4.2.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/keystoneauth/Manifest b/dev-python/keystoneauth/Manifest
index 7f4316ebf716..71b6a8da32a3 100644
--- a/dev-python/keystoneauth/Manifest
+++ b/dev-python/keystoneauth/Manifest
@@ -1 +1,2 @@
DIST keystoneauth1-4.0.1.tar.gz 257456 BLAKE2B 0903e782fcd291ba4c15ddbbec684c8f5c898062fdad0b34e8da892fb501a412108affd1d3ed7b9dc4e259b67bbe90dd361ab623da07f7ab97c32c1da6f5a1ad SHA512 b20e02dd521bb45406586f7ebdcbfe48ff22f4820950bbfa280a5fc969bc9cdacaff69678958412cd5880b732642cdd2079c228c9679e372ad76bef625e85c35
+DIST keystoneauth1-4.2.1.tar.gz 258328 BLAKE2B 62f8b065a77d4150c9491f4352a3a2d37d42cc54df8db6a1eabdbe93f18714838ebed2dec0d6188e91f2dc3708b0c3cfbcf17a96411df05dd96c409a1b6c8beb SHA512 cb137d259dba7cab31fa39293d40d6654c6b36157f088948995d55755fb4dc8c29df1f978a58fbc0881516f11db840f0a25c7621bb092ab95d901dde6bd210ca
diff --git a/dev-python/keystoneauth/keystoneauth-4.2.1.ebuild b/dev-python/keystoneauth/keystoneauth-4.2.1.ebuild
new file mode 100644
index 000000000000..e1333cf7d22a
--- /dev/null
+++ b/dev-python/keystoneauth/keystoneauth-4.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud."
+HOMEPAGE="https://github.com/openstack/keystoneauth"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}1/${PN}1-${PV}.tar.gz"
+S="${WORKDIR}/${PN}1-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/os-service-types-1.2.0[${PYTHON_USEDEP}]"