summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-24 22:17:21 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-24 22:36:18 +0300
commitd71c8b4d8548e722b4a710e07887190167819355 (patch)
treed88e2382fe93af546eb2796f2b515172dade5238
parentdev-python/openstacksdk: add 0.101.0 (diff)
downloadgentoo-d71c8b4d.tar.gz
gentoo-d71c8b4d.tar.bz2
gentoo-d71c8b4d.zip
dev-python/flatbuffers: add 2.0.7
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/flatbuffers/Manifest1
-rw-r--r--dev-python/flatbuffers/flatbuffers-2.0.7.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/flatbuffers/Manifest b/dev-python/flatbuffers/Manifest
index ce199c62dfa8..2e254d456eaf 100644
--- a/dev-python/flatbuffers/Manifest
+++ b/dev-python/flatbuffers/Manifest
@@ -1 +1,2 @@
DIST flatbuffers-2.0.6.tar.gz 1724250 BLAKE2B b6969b28dba753c4551b33d27409d9925c10a640ae860264f8054c19a470ce3da366c0bf7917bf7fe4f6cb57acbfbe1837f175fde40b84d311df6d1378d146ce SHA512 be631f34064c28d81876bf137c796e9736623cf2cc4f2a05dd45372e7195729c99fad1fa795f8ce71a408756a842edbdc0c3bc714a7cf63203a1de8681d86fb6
+DIST flatbuffers-2.0.7.gh.tar.gz 2018943 BLAKE2B 0fa27c79986292da1e3721c061d845b4ff3db5209956345ddf655dbbcd8fa8f460160d2359a77211139597b4635fc65fdc762cd3c62e87b361d65fb414d9c538 SHA512 15696f5f691414d2266f8bad1137ccbcf1e43e8d4fc22e8b5ef5b90351f6034b553bff7febf0e6f93a1be145e0714d7d4cb752786d0f67665165b1b6e5c1db24
diff --git a/dev-python/flatbuffers/flatbuffers-2.0.7.ebuild b/dev-python/flatbuffers/flatbuffers-2.0.7.ebuild
new file mode 100644
index 000000000000..7705da0c72e7
--- /dev/null
+++ b/dev-python/flatbuffers/flatbuffers-2.0.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="RFC 7049 - Concise Binary Object Representation"
+HOMEPAGE="
+ https://github.com/google/flatbuffers/
+ https://pypi.org/project/flatbuffers/
+"
+SRC_URI="
+ https://github.com/google/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+S=${WORKDIR}/${P}/python