summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-09-28 14:41:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-09-28 14:45:08 +0200
commitd720858567c3c758ca5543201d5016f2f235afa9 (patch)
tree01744f0f19e759840b289ccdfa1ec339bf9cbdf0
parentdev-python/rospkg: Remove old (diff)
downloadgentoo-d7208585.tar.gz
gentoo-d7208585.tar.bz2
gentoo-d7208585.zip
dev-python/rospkg: bump to 1.1.3
Package-Manager: Portage-2.3.10, Repoman-2.3.3
-rw-r--r--dev-python/rospkg/Manifest1
-rw-r--r--dev-python/rospkg/rospkg-1.1.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/rospkg/Manifest b/dev-python/rospkg/Manifest
index 327e5c864a13..fd12c4bc1a5b 100644
--- a/dev-python/rospkg/Manifest
+++ b/dev-python/rospkg/Manifest
@@ -1 +1,2 @@
DIST rospkg-1.1.2.tar.gz 89536 SHA256 2716ecff9b08ec97f000d716a294a043527ada7e6e46586dac063ea36fce6b58 SHA512 4fcabb88e749c0b756bc7230a8e3343098b3fc35b74bb70332e4a1ffd0df80054b9220604fb168f28ad819a3201c096a9f98ba450921a774aa8400703a7e7525 WHIRLPOOL a41b70a830846678949c4bdbfa6895c3cfb1be12428292540192c683ef62e6023a4b6d4d46c35c0e4be0211beb98009b5b1ee5644f57d79a0f723bb6499d00f0
+DIST rospkg-1.1.3.tar.gz 89534 SHA256 ba0948fbb3be14082f9e83763cbe3a12857127eb78e142748c9d16d41ab4479c SHA512 2bb0521fbb87492dbc83d2582a8de3034f2e5548c1a464cfc558915157f3ef9d34d6166a4378d5e5cb226f2c8f714df86879220f7041d37b58a9ad33be2ce3cd WHIRLPOOL 77082d0927626a5350300c556fd15eceb3527ee3a64239ade75aa2758288c1835e3f7797425ea6921674cab187593ec494406717a8daa88093dea874efad95d0
diff --git a/dev-python/rospkg/rospkg-1.1.3.ebuild b/dev-python/rospkg/rospkg-1.1.3.ebuild
new file mode 100644
index 000000000000..dff594067afb
--- /dev/null
+++ b/dev-python/rospkg/rospkg-1.1.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rospkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the ROS package system"
+HOMEPAGE="http://wiki.ros.org/rospkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+ # Needed for tests
+ S="${WORKDIR}/${PN}"
+ EGIT_CHECKOUT_DIR="${S}"
+else
+ SRC_URI="https://github.com/ros-infrastructure/rospkg/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )
+"
+PATCHES=( "${FILESDIR}/gentoo.patch" )
+
+python_test() {
+ nosetests --with-coverage --cover-package=rospkg --with-xunit test || die
+}