summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-08 10:06:04 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-08 10:56:39 +0200
commitd748eac6942e6e37b5ea4fdfe29bcb49e9a2b9ce (patch)
treee57ff5fd9633452b2725fdb637459b28465feabd
parentdev-python/trimesh: Bump to 3.10.8 (diff)
downloadgentoo-d748eac6942e6e37b5ea4fdfe29bcb49e9a2b9ce.tar.gz
gentoo-d748eac6942e6e37b5ea4fdfe29bcb49e9a2b9ce.tar.bz2
gentoo-d748eac6942e6e37b5ea4fdfe29bcb49e9a2b9ce.zip
dev-python/rope: Bump to 1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rope/Manifest1
-rw-r--r--dev-python/rope/rope-1.0.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index 37502321faab..2bbee94bc5a1 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1 +1,2 @@
DIST rope-0.23.0.tar.gz 260990 BLAKE2B 34064f45f72d6c9c5613eb5d9480dde25aeb5426ab3ea9b56e7ba5e4da1d9930735bd87757e3e885d4504ddcb24b23aa96b0d5be7c23ca4969201aedbaa3aa24 SHA512 1ab0a36c792fdc4d0fd1e554deec0fb6d1e877d91164fb8ee2e5f99240087f8a8d4608d1975be100bca87be0321d672b91579cf36795acffc742aa021cdf5e1b
+DIST rope-1.0.0.tar.gz 263335 BLAKE2B 5a2ecb494c7ab7833a75e54887e863fc5b35c2564d9ebcabb055084f1aff189bbedd2de13b1f8e0c56736886687c25111a42e47ff5ea84c217bb81927495e1a1 SHA512 f4a011750dfe51f092f29d1a911e4ce6c0425a31839f6ebade834d57472beeee9bae49cbd1f46ebcb2f3fe5c6aaf16edd583fd3a701b51b0f80d221c5aa23aed
diff --git a/dev-python/rope/rope-1.0.0.ebuild b/dev-python/rope/rope-1.0.0.ebuild
new file mode 100644
index 000000000000..a59e2a961a63
--- /dev/null
+++ b/dev-python/rope/rope-1.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="
+ https://pypi.org/project/rope/
+ https://github.com/python-rope/rope/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest