summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-12-25 01:44:31 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-12-25 01:44:31 +0100
commitd7523c558338b1c1aad83db37e356db9ec2d9b59 (patch)
tree892e555c0e6a696ec9e61c9f6bf6278ef891980d
parentkde-plasma/plasma-workspace: drop 5.25.5-r4 (diff)
downloadgentoo-d7523c558338b1c1aad83db37e356db9ec2d9b59.tar.gz
gentoo-d7523c558338b1c1aad83db37e356db9ec2d9b59.tar.bz2
gentoo-d7523c558338b1c1aad83db37e356db9ec2d9b59.zip
dev-util/boost-build: Remove last-rited package
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-util/boost-build/Manifest1
-rw-r--r--dev-util/boost-build/boost-build-1.79.0-r1.ebuild75
-rw-r--r--dev-util/boost-build/files/boost-build-1.71.0-disable_python_rpath.patch11
-rw-r--r--dev-util/boost-build/files/boost-build-1.71.0-fix-test.patch11
-rw-r--r--dev-util/boost-build/files/boost-build-1.73.0-add-none-feature-options.patch22
-rw-r--r--dev-util/boost-build/files/boost-build-1.76.0-respect-user-flags.patch11
-rw-r--r--dev-util/boost-build/files/boost-build-1.78.0-darwin-gentoo-toolchain.patch16
-rw-r--r--dev-util/boost-build/files/boost-build-1.78.0-no-implicit-march-flags.patch284
-rw-r--r--dev-util/boost-build/files/site-config.jam11
-rw-r--r--dev-util/boost-build/metadata.xml11
-rw-r--r--profiles/package.mask5
11 files changed, 0 insertions, 458 deletions
diff --git a/dev-util/boost-build/Manifest b/dev-util/boost-build/Manifest
deleted file mode 100644
index 7e0c56594141..000000000000
--- a/dev-util/boost-build/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST boost_1_79_0.tar.bz2 113456811 BLAKE2B 61f47ca022e60745868e6bdd3b5c75603dd68d878e126dcbb73de5b40fc03c0eec8eede3ec304ece58050435ef2fc1ed7eb763773c20673f85e32bbf4d5f978a SHA512 70909e0561c213d10a1fdd692f9ae7b293d3cdc63e925bdc207da9e9bba6e86474341100e7ee5de6d94f9561196b1a3a1597055a7b7382babf8931131170a312
diff --git a/dev-util/boost-build/boost-build-1.79.0-r1.ebuild b/dev-util/boost-build/boost-build-1.79.0-r1.ebuild
deleted file mode 100644
index 74cea514f585..000000000000
--- a/dev-util/boost-build/boost-build-1.79.0-r1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic toolchain-funcs
-
-MY_PV="$(ver_rs 1- _)"
-
-DESCRIPTION="A system for large project software construction, simple to use and powerful"
-HOMEPAGE="https://www.boost.org/build/"
-SRC_URI="https://boostorg.jfrog.io/artifactory/main/release/${PV}/source/boost_${MY_PV}.tar.bz2"
-S="${WORKDIR}/boost_${MY_PV}/tools/build/src"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples"
-RESTRICT="test"
-
-RDEPEND="!dev-util/b2"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.71.0-disable_python_rpath.patch
- "${FILESDIR}"/${PN}-1.78.0-darwin-gentoo-toolchain.patch
- "${FILESDIR}"/${PN}-1.73.0-add-none-feature-options.patch
- "${FILESDIR}"/${PN}-1.76.0-respect-user-flags.patch
- "${FILESDIR}"/${PN}-1.78.0-no-implicit-march-flags.patch
-)
-
-src_unpack() {
- tar xojf "${DISTDIR}/${A}" boost_${MY_PV}/tools/build || die "unpacking tar failed"
-}
-
-src_prepare() {
- default
-
- pushd .. >/dev/null || die
- eapply "${FILESDIR}"/${PN}-1.71.0-fix-test.patch
- popd >/dev/null || die
-}
-
-src_configure() {
- # need to enable LFS explicitly for 64-bit offsets on 32-bit hosts (#761100)
- append-lfs-flags
-}
-
-src_compile() {
- cd engine || die
- ${CONFIG_SHELL:-${BASH}} ./build.sh cxx --cxx="$(tc-getCXX)" --cxxflags="${CXXFLAGS}" -d+2 --without-python || die "building bjam failed"
-}
-
-src_test() {
- # Forget tests, bjam is a lost cause
- :
-}
-
-src_install() {
- dobin engine/{bjam,b2}
-
- insinto /usr/share/boost-build/src
- doins -r "${FILESDIR}/site-config.jam" \
- ../boost-build.jam bootstrap.jam build-system.jam ../example/user-config.jam *.py \
- build kernel options tools util
-
- find "${ED}"/usr/share/boost-build/src -iname '*.py' -delete || die
-
- dodoc ../notes/{changes,release_procedure,build_dir_option,relative_source_paths}.txt
-
- if use examples; then
- docinto examples
- dodoc -r ../example/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-util/boost-build/files/boost-build-1.71.0-disable_python_rpath.patch b/dev-util/boost-build/files/boost-build-1.71.0-disable_python_rpath.patch
deleted file mode 100644
index b7b47cc93a47..000000000000
--- a/dev-util/boost-build/files/boost-build-1.71.0-disable_python_rpath.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/tools/python.jam
-+++ b/tools/python.jam
-@@ -1000,7 +1000,7 @@
- # linux).
- : $(usage-requirements)
- <testing.launcher>$(set-PYTHONPATH)
-- <library-path>$(libraries) <dll-path>$(dll-path) <library>python.lib
-+ <library-path>$(libraries) <library>python.lib
- ;
- }
-
diff --git a/dev-util/boost-build/files/boost-build-1.71.0-fix-test.patch b/dev-util/boost-build/files/boost-build-1.71.0-fix-test.patch
deleted file mode 100644
index 3f8b177c7102..000000000000
--- a/dev-util/boost-build/files/boost-build-1.71.0-fix-test.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/test/startup_v2.py
-+++ b/test/startup_v2.py
-@@ -50,7 +50,7 @@
- return re.match(expected, actual, re.DOTALL) != None
-
-
--t = BoostBuild.Tester(match=match_re, boost_build_path="", pass_toolset=0)
-+t = BoostBuild.Tester(match=match_re, boost_build_path="/invalid/location", pass_toolset=0)
- t.set_tree("startup")
- check_for_existing_boost_build_jam(t)
-
diff --git a/dev-util/boost-build/files/boost-build-1.73.0-add-none-feature-options.patch b/dev-util/boost-build/files/boost-build-1.73.0-add-none-feature-options.patch
deleted file mode 100644
index 1918a2456af9..000000000000
--- a/dev-util/boost-build/files/boost-build-1.73.0-add-none-feature-options.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/tools/features/debug-feature.jam
-+++ b/tools/features/debug-feature.jam
-@@ -18,7 +18,7 @@
- |# # end::doc[]
-
- feature.feature debug-symbols
-- : on off
-+ : on off none
- : propagated ;
-
- #| tag::prof-doc[]
---- a/tools/features/optimization-feature.jam
-+++ b/tools/features/optimization-feature.jam
-@@ -16,7 +16,7 @@
- |# # end::doc[]
-
- feature.feature optimization
-- : off speed space
-+ : off none speed space
- : propagated ;
-
- #| tag::inline-doc[]
diff --git a/dev-util/boost-build/files/boost-build-1.76.0-respect-user-flags.patch b/dev-util/boost-build/files/boost-build-1.76.0-respect-user-flags.patch
deleted file mode 100644
index 2289e706ca74..000000000000
--- a/dev-util/boost-build/files/boost-build-1.76.0-respect-user-flags.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/engine/build.sh
-+++ b/engine/build.sh
-@@ -496,7 +496,7 @@
- if test_true ${B2_DEBUG_OPT} ; then B2_CXXFLAGS="${B2_CXXFLAGS_DEBUG}"
- else B2_CXXFLAGS="${B2_CXXFLAGS_RELEASE} -DNDEBUG"
- fi
-- ( B2_VERBOSE_OPT=${TRUE} echo_run ${B2_CXX} ${B2_CXXFLAGS} ${B2_SOURCES} -o b2 )
-+ ( B2_VERBOSE_OPT=${TRUE} echo_run ${B2_CXX} ${CPPFLAGS} ${B2_CXXFLAGS} ${LDFLAGS} ${B2_SOURCES} -o b2 )
- ( B2_VERBOSE_OPT=${TRUE} echo_run cp b2 bjam )
- }
-
diff --git a/dev-util/boost-build/files/boost-build-1.78.0-darwin-gentoo-toolchain.patch b/dev-util/boost-build/files/boost-build-1.78.0-darwin-gentoo-toolchain.patch
deleted file mode 100644
index 8de98014dbdc..000000000000
--- a/dev-util/boost-build/files/boost-build-1.78.0-darwin-gentoo-toolchain.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Avoid adding all kinds of things to the toolchain's flags that within
-Gentoo (Prefix) we really shouldn't, such as sysroot, deployment target,
-arch, etc.
-
---- a/tools/darwin.jam
-+++ b/tools/darwin.jam
-@@ -240,6 +240,9 @@
- }
- }
-
-+ # leave compiler flags etc. up to the toolchain
-+ return $(version-feature) ;
-+
- if $(version-feature)
- {
- if $(.debug-configuration)
diff --git a/dev-util/boost-build/files/boost-build-1.78.0-no-implicit-march-flags.patch b/dev-util/boost-build/files/boost-build-1.78.0-no-implicit-march-flags.patch
deleted file mode 100644
index 093f40d03071..000000000000
--- a/dev-util/boost-build/files/boost-build-1.78.0-no-implicit-march-flags.patch
+++ /dev/null
@@ -1,284 +0,0 @@
---- a/tools/gcc.jam
-+++ b/tools/gcc.jam
-@@ -1129,140 +1129,10 @@
- # x86 and compatible
- # The 'native' option appeared in gcc 4.2 so we cannot safely use it as default.
- # Use i686 instead for 32-bit.
--toolset.flags gcc OPTIONS <architecture>x86/<address-model>32/<instruction-set> : -march=i686 ;
--cpu-flags gcc OPTIONS : x86 : native : -march=native ;
--cpu-flags gcc OPTIONS : x86 : i486 : -march=i486 ;
--cpu-flags gcc OPTIONS : x86 : i586 : -march=i586 ;
--cpu-flags gcc OPTIONS : x86 : i686 : -march=i686 ;
--cpu-flags gcc OPTIONS : x86 : pentium : -march=pentium ;
--cpu-flags gcc OPTIONS : x86 : pentium-mmx : -march=pentium-mmx ;
--cpu-flags gcc OPTIONS : x86 : pentiumpro : -march=pentiumpro ;
--cpu-flags gcc OPTIONS : x86 : pentium2 : -march=pentium2 ;
--cpu-flags gcc OPTIONS : x86 : pentium3 : -march=pentium3 ;
--cpu-flags gcc OPTIONS : x86 : pentium3m : -march=pentium3m ;
--cpu-flags gcc OPTIONS : x86 : pentium-m : -march=pentium-m ;
--cpu-flags gcc OPTIONS : x86 : pentium4 : -march=pentium4 ;
--cpu-flags gcc OPTIONS : x86 : pentium4m : -march=pentium4m ;
--cpu-flags gcc OPTIONS : x86 : prescott : -march=prescott ;
--cpu-flags gcc OPTIONS : x86 : nocona : -march=nocona ;
--cpu-flags gcc OPTIONS : x86 : core2 : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : conroe : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : conroe-xe : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : conroe-l : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : allendale : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : wolfdale : -march=core2 -msse4.1 ;
--cpu-flags gcc OPTIONS : x86 : merom : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : merom-xe : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : kentsfield : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : kentsfield-xe : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : yorksfield : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : penryn : -march=core2 ;
--cpu-flags gcc OPTIONS : x86 : corei7 : -march=corei7 ;
--cpu-flags gcc OPTIONS : x86 : nehalem : -march=corei7 ;
--cpu-flags gcc OPTIONS : x86 : corei7-avx : -march=corei7-avx ;
--cpu-flags gcc OPTIONS : x86 : sandy-bridge : -march=corei7-avx ;
--cpu-flags gcc OPTIONS : x86 : core-avx-i : -march=core-avx-i ;
--cpu-flags gcc OPTIONS : x86 : ivy-bridge : -march=core-avx-i ;
--cpu-flags gcc OPTIONS : x86 : haswell : -march=core-avx-i -mavx2 -mfma -mbmi -mbmi2 -mlzcnt ;
--cpu-flags gcc OPTIONS : x86 : broadwell : -march=broadwell ;
--cpu-flags gcc OPTIONS : x86 : skylake : -march=skylake ;
--cpu-flags gcc OPTIONS : x86 : skylake-avx512 : -march=skylake-avx512 ;
--cpu-flags gcc OPTIONS : x86 : cannonlake : -march=skylake-avx512 -mavx512vbmi -mavx512ifma -msha ;
--cpu-flags gcc OPTIONS : x86 : icelake-client : -march=icelake-client ;
--cpu-flags gcc OPTIONS : x86 : icelake-server : -march=icelake-server ;
--cpu-flags gcc OPTIONS : x86 : cascadelake : -march=skylake-avx512 -mavx512vnni ;
--cpu-flags gcc OPTIONS : x86 : cooperlake : -march=cooperlake ;
--cpu-flags gcc OPTIONS : x86 : tigerlake : -march=tigerlake ;
--cpu-flags gcc OPTIONS : x86 : k6 : -march=k6 ;
--cpu-flags gcc OPTIONS : x86 : k6-2 : -march=k6-2 ;
--cpu-flags gcc OPTIONS : x86 : k6-3 : -march=k6-3 ;
--cpu-flags gcc OPTIONS : x86 : athlon : -march=athlon ;
--cpu-flags gcc OPTIONS : x86 : athlon-tbird : -march=athlon-tbird ;
--cpu-flags gcc OPTIONS : x86 : athlon-4 : -march=athlon-4 ;
--cpu-flags gcc OPTIONS : x86 : athlon-xp : -march=athlon-xp ;
--cpu-flags gcc OPTIONS : x86 : athlon-mp : -march=athlon-mp ;
- ##
--cpu-flags gcc OPTIONS : x86 : k8 : -march=k8 ;
--cpu-flags gcc OPTIONS : x86 : opteron : -march=opteron ;
--cpu-flags gcc OPTIONS : x86 : athlon64 : -march=athlon64 ;
--cpu-flags gcc OPTIONS : x86 : athlon-fx : -march=athlon-fx ;
--cpu-flags gcc OPTIONS : x86 : k8-sse3 : -march=k8-sse3 ;
--cpu-flags gcc OPTIONS : x86 : opteron-sse3 : -march=opteron-sse3 ;
--cpu-flags gcc OPTIONS : x86 : athlon64-sse3 : -march=athlon64-sse3 ;
--cpu-flags gcc OPTIONS : x86 : amdfam10 : -march=amdfam10 ;
--cpu-flags gcc OPTIONS : x86 : barcelona : -march=barcelona ;
--cpu-flags gcc OPTIONS : x86 : bdver1 : -march=bdver1 ;
--cpu-flags gcc OPTIONS : x86 : bdver2 : -march=bdver2 ;
--cpu-flags gcc OPTIONS : x86 : bdver3 : -march=bdver3 ;
--cpu-flags gcc OPTIONS : x86 : bdver4 : -march=bdver4 ;
--cpu-flags gcc OPTIONS : x86 : btver1 : -march=btver1 ;
--cpu-flags gcc OPTIONS : x86 : btver2 : -march=btver2 ;
--cpu-flags gcc OPTIONS : x86 : znver1 : -march=znver1 ;
--cpu-flags gcc OPTIONS : x86 : znver2 : -march=znver2 ;
--cpu-flags gcc OPTIONS : x86 : winchip-c6 : -march=winchip-c6 ;
--cpu-flags gcc OPTIONS : x86 : winchip2 : -march=winchip2 ;
--cpu-flags gcc OPTIONS : x86 : c3 : -march=c3 ;
--cpu-flags gcc OPTIONS : x86 : c3-2 : -march=c3-2 ;
--cpu-flags gcc OPTIONS : x86 : c7 : -march=c7 ;
- ##
--cpu-flags gcc OPTIONS : x86 : atom : -march=atom ;
- # Sparc
--cpu-flags gcc OPTIONS : sparc : v7 : -mcpu=v7 : default ;
--cpu-flags gcc OPTIONS : sparc : cypress : -mcpu=cypress ;
--cpu-flags gcc OPTIONS : sparc : v8 : -mcpu=v8 ;
--cpu-flags gcc OPTIONS : sparc : supersparc : -mcpu=supersparc ;
--cpu-flags gcc OPTIONS : sparc : sparclite : -mcpu=sparclite ;
--cpu-flags gcc OPTIONS : sparc : hypersparc : -mcpu=hypersparc ;
--cpu-flags gcc OPTIONS : sparc : sparclite86x : -mcpu=sparclite86x ;
--cpu-flags gcc OPTIONS : sparc : f930 : -mcpu=f930 ;
--cpu-flags gcc OPTIONS : sparc : f934 : -mcpu=f934 ;
--cpu-flags gcc OPTIONS : sparc : sparclet : -mcpu=sparclet ;
--cpu-flags gcc OPTIONS : sparc : tsc701 : -mcpu=tsc701 ;
--cpu-flags gcc OPTIONS : sparc : v9 : -mcpu=v9 ;
--cpu-flags gcc OPTIONS : sparc : ultrasparc : -mcpu=ultrasparc ;
--cpu-flags gcc OPTIONS : sparc : ultrasparc3 : -mcpu=ultrasparc3 ;
- # RS/6000 & PowerPC
--cpu-flags gcc OPTIONS : power : 403 : -mcpu=403 ;
--cpu-flags gcc OPTIONS : power : 505 : -mcpu=505 ;
--cpu-flags gcc OPTIONS : power : 601 : -mcpu=601 ;
--cpu-flags gcc OPTIONS : power : 602 : -mcpu=602 ;
--cpu-flags gcc OPTIONS : power : 603 : -mcpu=603 ;
--cpu-flags gcc OPTIONS : power : 603e : -mcpu=603e ;
--cpu-flags gcc OPTIONS : power : 604 : -mcpu=604 ;
--cpu-flags gcc OPTIONS : power : 604e : -mcpu=604e ;
--cpu-flags gcc OPTIONS : power : 620 : -mcpu=620 ;
--cpu-flags gcc OPTIONS : power : 630 : -mcpu=630 ;
--cpu-flags gcc OPTIONS : power : 740 : -mcpu=740 ;
--cpu-flags gcc OPTIONS : power : 7400 : -mcpu=7400 ;
--cpu-flags gcc OPTIONS : power : 7450 : -mcpu=7450 ;
--cpu-flags gcc OPTIONS : power : 750 : -mcpu=750 ;
--cpu-flags gcc OPTIONS : power : 801 : -mcpu=801 ;
--cpu-flags gcc OPTIONS : power : 821 : -mcpu=821 ;
--cpu-flags gcc OPTIONS : power : 823 : -mcpu=823 ;
--cpu-flags gcc OPTIONS : power : 860 : -mcpu=860 ;
--cpu-flags gcc OPTIONS : power : 970 : -mcpu=970 ;
--cpu-flags gcc OPTIONS : power : 8540 : -mcpu=8540 ;
--cpu-flags gcc OPTIONS : power : power : -mcpu=power ;
--cpu-flags gcc OPTIONS : power : power2 : -mcpu=power2 ;
--cpu-flags gcc OPTIONS : power : power3 : -mcpu=power3 ;
--cpu-flags gcc OPTIONS : power : power4 : -mcpu=power4 ;
--cpu-flags gcc OPTIONS : power : power5 : -mcpu=power5 ;
--cpu-flags gcc OPTIONS : power : powerpc : -mcpu=powerpc ;
--cpu-flags gcc OPTIONS : power : powerpc64 : -mcpu=powerpc64 ;
--cpu-flags gcc OPTIONS : power : rios : -mcpu=rios ;
--cpu-flags gcc OPTIONS : power : rios1 : -mcpu=rios1 ;
--cpu-flags gcc OPTIONS : power : rios2 : -mcpu=rios2 ;
--cpu-flags gcc OPTIONS : power : rsc : -mcpu=rsc ;
--cpu-flags gcc OPTIONS : power : rs64a : -mcpu=rs64 ;
--cpu-flags gcc OPTIONS : s390x : z196 : -march=z196 ;
--cpu-flags gcc OPTIONS : s390x : zEC12 : -march=zEC12 ;
--cpu-flags gcc OPTIONS : s390x : z13 : -march=z13 ;
--cpu-flags gcc OPTIONS : s390x : z14 : -march=z14 ;
--cpu-flags gcc OPTIONS : s390x : z15 : -march=z15 ;
- # ARM
--cpu-flags gcc OPTIONS : arm : cortex-a9+vfpv3 : -mcpu=cortex-a9 -mfpu=vfpv3 -mfloat-abi=hard ;
--cpu-flags gcc OPTIONS : arm : cortex-a53 : -mcpu=cortex-a53 ;
--cpu-flags gcc OPTIONS : arm : cortex-r5 : -mcpu=cortex-r5 ;
--cpu-flags gcc OPTIONS : arm : cortex-r5+vfpv3-d16 : -mcpu=cortex-r5 -mfpu=vfpv3-d16 -mfloat-abi=hard ;
- # AIX variant of RS/6000 & PowerPC
- toolset.flags gcc AROPTIONS <address-model>64/<target-os>aix : "-X64" ;
---- a/tools/gcc.py
-+++ b/tools/gcc.py
-@@ -737,138 +737,14 @@
- # x86 and compatible
- flags('gcc', 'OPTIONS', ['<architecture>x86/<address-model>32'], ['-m32'])
- flags('gcc', 'OPTIONS', ['<architecture>x86/<address-model>64'], ['-m64'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'native', ['-march=native'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'i486', ['-march=i486'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'i586', ['-march=i586'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'i686', ['-march=i686'], default=True)
--cpu_flags('gcc', 'OPTIONS', 'x86', 'pentium', ['-march=pentium'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'pentium-mmx', ['-march=pentium-mmx'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'pentiumpro', ['-march=pentiumpro'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'pentium2', ['-march=pentium2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'pentium3', ['-march=pentium3'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'pentium3m', ['-march=pentium3m'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'pentium-m', ['-march=pentium-m'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'pentium4', ['-march=pentium4'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'pentium4m', ['-march=pentium4m'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'prescott', ['-march=prescott'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'nocona', ['-march=nocona'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'core2', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'conroe', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'conroe-xe', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'conroe-l', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'allendale', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'wolfdale', ['-march=core2', '-msse4.1'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'merom', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'merom-xe', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'kentsfield', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'kentsfield-xe', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'yorksfield', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'penryn', ['-march=core2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'corei7', ['-march=corei7'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'nehalem', ['-march=corei7'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'corei7-avx', ['-march=corei7-avx'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'sandy-bridge', ['-march=corei7-avx'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'core-avx-i', ['-march=core-avx-i'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'ivy-bridge', ['-march=core-avx-i'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'haswell', ['-march=core-avx-i', '-mavx2', '-mfma', '-mbmi', '-mbmi2', '-mlzcnt'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'broadwell', ['-march=broadwell'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'skylake', ['-march=skylake'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'skylake-avx512', ['-march=skylake-avx512'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'cannonlake', ['-march=skylake-avx512', '-mavx512vbmi', '-mavx512ifma', '-msha'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'icelake-client', ['-march=icelake-client'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'icelake-server', ['-march=icelake-server'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'cascadelake', ['-march=skylake-avx512', '-mavx512vnni'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'cooperlake', ['-march=cooperlake'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'tigerlake', ['-march=tigerlake'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'k6', ['-march=k6'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'k6-2', ['-march=k6-2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'k6-3', ['-march=k6-3'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'athlon', ['-march=athlon'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'athlon-tbird', ['-march=athlon-tbird'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'athlon-4', ['-march=athlon-4'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'athlon-xp', ['-march=athlon-xp'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'athlon-mp', ['-march=athlon-mp'])
- ##
--cpu_flags('gcc', 'OPTIONS', 'x86', 'k8', ['-march=k8'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'opteron', ['-march=opteron'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'athlon64', ['-march=athlon64'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'athlon-fx', ['-march=athlon-fx'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'k8-sse3', ['-march=k8-sse3'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'opteron-sse3', ['-march=opteron-sse3'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'athlon64-sse3', ['-march=athlon64-sse3'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'amdfam10', ['-march=amdfam10'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'barcelona', ['-march=barcelona'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'bdver1', ['-march=bdver1'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'bdver2', ['-march=bdver2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'bdver3', ['-march=bdver3'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'btver1', ['-march=btver1'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'btver2', ['-march=btver2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'znver1', ['-march=znver1'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'znver2', ['-march=znver2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'winchip-c6', ['-march=winchip-c6'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'winchip2', ['-march=winchip2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'c3', ['-march=c3'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'c3-2', ['-march=c3-2'])
--cpu_flags('gcc', 'OPTIONS', 'x86', 'c7', ['-march=c7'])
- ##
--cpu_flags('gcc', 'OPTIONS', 'x86', 'atom', ['-march=atom'])
- # Sparc
- flags('gcc', 'OPTIONS', ['<architecture>sparc/<address-model>32'], ['-m32'])
- flags('gcc', 'OPTIONS', ['<architecture>sparc/<address-model>64'], ['-m64'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'v7', ['-mcpu=v7'], default=True)
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'cypress', ['-mcpu=cypress'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'v8', ['-mcpu=v8'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'supersparc', ['-mcpu=supersparc'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'sparclite', ['-mcpu=sparclite'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'hypersparc', ['-mcpu=hypersparc'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'sparclite86x', ['-mcpu=sparclite86x'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'f930', ['-mcpu=f930'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'f934', ['-mcpu=f934'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'sparclet', ['-mcpu=sparclet'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'tsc701', ['-mcpu=tsc701'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'v9', ['-mcpu=v9'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'ultrasparc', ['-mcpu=ultrasparc'])
--cpu_flags('gcc', 'OPTIONS', 'sparc', 'ultrasparc3', ['-mcpu=ultrasparc3'])
- # RS/6000 & PowerPC
- flags('gcc', 'OPTIONS', ['<architecture>power/<address-model>32'], ['-m32'])
- flags('gcc', 'OPTIONS', ['<architecture>power/<address-model>64'], ['-m64'])
--cpu_flags('gcc', 'OPTIONS', 'power', '403', ['-mcpu=403'])
--cpu_flags('gcc', 'OPTIONS', 'power', '505', ['-mcpu=505'])
--cpu_flags('gcc', 'OPTIONS', 'power', '601', ['-mcpu=601'])
--cpu_flags('gcc', 'OPTIONS', 'power', '602', ['-mcpu=602'])
--cpu_flags('gcc', 'OPTIONS', 'power', '603', ['-mcpu=603'])
--cpu_flags('gcc', 'OPTIONS', 'power', '603e', ['-mcpu=603e'])
--cpu_flags('gcc', 'OPTIONS', 'power', '604', ['-mcpu=604'])
--cpu_flags('gcc', 'OPTIONS', 'power', '604e', ['-mcpu=604e'])
--cpu_flags('gcc', 'OPTIONS', 'power', '620', ['-mcpu=620'])
--cpu_flags('gcc', 'OPTIONS', 'power', '630', ['-mcpu=630'])
--cpu_flags('gcc', 'OPTIONS', 'power', '740', ['-mcpu=740'])
--cpu_flags('gcc', 'OPTIONS', 'power', '7400', ['-mcpu=7400'])
--cpu_flags('gcc', 'OPTIONS', 'power', '7450', ['-mcpu=7450'])
--cpu_flags('gcc', 'OPTIONS', 'power', '750', ['-mcpu=750'])
--cpu_flags('gcc', 'OPTIONS', 'power', '801', ['-mcpu=801'])
--cpu_flags('gcc', 'OPTIONS', 'power', '821', ['-mcpu=821'])
--cpu_flags('gcc', 'OPTIONS', 'power', '823', ['-mcpu=823'])
--cpu_flags('gcc', 'OPTIONS', 'power', '860', ['-mcpu=860'])
--cpu_flags('gcc', 'OPTIONS', 'power', '970', ['-mcpu=970'])
--cpu_flags('gcc', 'OPTIONS', 'power', '8540', ['-mcpu=8540'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'power', ['-mcpu=power'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'power2', ['-mcpu=power2'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'power3', ['-mcpu=power3'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'power4', ['-mcpu=power4'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'power5', ['-mcpu=power5'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'powerpc', ['-mcpu=powerpc'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'powerpc64', ['-mcpu=powerpc64'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'rios', ['-mcpu=rios'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'rios1', ['-mcpu=rios1'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'rios2', ['-mcpu=rios2'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'rsc', ['-mcpu=rsc'])
--cpu_flags('gcc', 'OPTIONS', 'power', 'rs64a', ['-mcpu=rs64'])
--cpu_flags('gcc', 'OPTIONS', 's390x', 'z196', ['-march=z196'])
--cpu_flags('gcc', 'OPTIONS', 's390x', 'zEC12', ['-march=zEC12'])
--cpu_flags('gcc', 'OPTIONS', 's390x', 'z13', ['-march=z13'])
--cpu_flags('gcc', 'OPTIONS', 's390x', 'z14', ['-march=z14'])
--cpu_flags('gcc', 'OPTIONS', 's390x', 'z15', ['-march=z15'])
- # AIX variant of RS/6000 & PowerPC
- flags('gcc', 'OPTIONS', ['<architecture>power/<address-model>32/<target-os>aix'], ['-maix32'])
- flags('gcc', 'OPTIONS', ['<architecture>power/<address-model>64/<target-os>aix'], ['-maix64'])
diff --git a/dev-util/boost-build/files/site-config.jam b/dev-util/boost-build/files/site-config.jam
deleted file mode 100644
index 6afe52684ccc..000000000000
--- a/dev-util/boost-build/files/site-config.jam
+++ /dev/null
@@ -1,11 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the Boost Software License, Version 1.0.
-# (See accompanying file LICENSE_1_0.txt or http://www.boost.org/LICENSE_1_0.txt)
-
-# Define two new variants to be used when building boost (or separate boost-libs)
-# on Gentoo. The two variants make use of Gentoo-specific optimization and debug-symbols
-# values "none" which are not part of the official boost distribution.
-# DO NOT RELY ON THE FOLLOWING VARIANTS TO BE PRESENT ON OTHER OS!
-variant gentoorelease : release : <optimization>none <debug-symbols>none <runtime-link>shared ;
-variant gentoodebug : debug : <optimization>none <debug-symbols>on <runtime-link>shared ;
-
diff --git a/dev-util/boost-build/metadata.xml b/dev-util/boost-build/metadata.xml
deleted file mode 100644
index 95721d4f811e..000000000000
--- a/dev-util/boost-build/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>soap@gentoo.org</email>
- <name>David Seifert</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">boost</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 83931ae4a33d..d1b158b118cd 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -915,11 +915,6 @@ dev-ruby/vcr:3
# and accept a more unstable release.
>=www-client/chromium-110
-# Andreas Sturmlechner <asturm@gentoo.org> (2022-12-03)
-# No purpose anymore after <dev-libs/boost-1.80 cleanup.
-# Removal on 2022-12-16
-dev-util/boost-build
-
# Hans de Graaff <graaff@gentoo.org> (2022-12-03)
# Obsolete slot without reverse dependencies. Use a newer faraday
# slot instead. Masked for removal in 30 days.