summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-21 04:24:56 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-21 04:24:56 +0100
commitd782c88805db29c8c6717086db57f24bb5f2421d (patch)
treede0c5cd86c5a1530d2e5834bbe8e7f9d26b1aaa4
parentprofiles.desc: Add commented-out arm musl 23.0 profiles. Work in progress. (diff)
downloadgentoo-d782c888.tar.gz
gentoo-d782c888.tar.bz2
gentoo-d782c888.zip
dev-python/botocore: Bump to 1.34.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.5.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index b0db4902752a..84a47aafb940 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.34.1.gh.tar.gz 12561522 BLAKE2B 67b42866c4a00ea960b8d942110acdf9
DIST botocore-1.34.2.gh.tar.gz 12564834 BLAKE2B b22a3d3bd35b769a28ccb1a5116428e1904d0c9fc3452829237704dbec37a31a539f044a728b0785d09406d299d522dd601da39801249747d54e6741b46cafe2 SHA512 a3f3718bf584a871abbb3edc803de9d5329da257c050d56bdbf8a6a6c4067477812582fbd8d1d789ce18ea1f416d0ddb2be9cc3c45172292d061a94a12f3977b
DIST botocore-1.34.3.gh.tar.gz 12574694 BLAKE2B f171337299c886d0b9c78e50ea57b0e2c1cf3cf261bbaca5e69bd374898ced32cf085d43d7a5f935d16573411e88f432f8417f047391f0a8de914886f14fe7ea SHA512 7e74536e6a69d25aff66763e7c817d5a3b54cb9c528a20be758c490621f33c945cb63313391bb25e402aab32a5b3fbb19215118c02559b64983c21db8ca79bc2
DIST botocore-1.34.4.gh.tar.gz 12582501 BLAKE2B fa7578a30cf8e6c72ef83756923c77f4c8d89c6ce0902614f6661d6174b3d1fc176866087dea80b61c8328137796f41a1e295fc04de7fee34267b521cc3d9201 SHA512 07e60e42bfd2be4de0b2cf824978acd87eadeba77e8e191fb4e29001e9868494fe9e4676b38f6769557b0119139cb9f432d426cba34307504e8a218ccec66c0f
+DIST botocore-1.34.5.gh.tar.gz 12587260 BLAKE2B 08ffafc5b6678cb48f7ca59413c787fcb15924076927113634e4db674d6cac52a1cae72f559abf614be622137e28b0862b140bd2e5c92231aa659d15d655fad9 SHA512 c99a9c4d1cc86bf6aab3c8672f2dc95f69577fdbfb5cc4723bc6be41df9a34aa07eae29ab00ec84b55e50694b1288ad8a5b5673f4d6839c13608f28f0c9420b0
diff --git a/dev-python/botocore/botocore-1.34.5.ebuild b/dev-python/botocore/botocore-1.34.5.ebuild
new file mode 100644
index 000000000000..05766e84276c
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x EPYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}