summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-27 20:50:16 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-27 21:25:24 +0300
commitd78eeb80ef8474d402d1275fe1e0796e8e224a0b (patch)
tree64574676ffd7f58f02a642d00f6b0661718740b0
parentdev-python/mkdocs: add 1.4.0 (diff)
downloadgentoo-d78eeb80.tar.gz
gentoo-d78eeb80.tar.bz2
gentoo-d78eeb80.zip
dev-python/sphinx-autodoc-typehints: add 1.19.4
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest1
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.4.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index 876de1377bf8..b139ab8435ae 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -1,2 +1,3 @@
DIST sphinx-autodoc-typehints-1.19.2.gh.tar.gz 26983 BLAKE2B 694edbf94bac05670adad992cfdc7e1146228af7b888a97c4f8e2394623ef3e42251ba0f3c22985517b2a251996cc41a305ea5497b2369363bc00d4bb3d24da7 SHA512 c35c7ed3f0698651be5ba4dd2232912d1f6d9d30e08153527df3fe16001266abc80cd1b11e3a41ccf92140c6baea98105e9bccd9466e65664dcf008f9a944634
DIST sphinx-autodoc-typehints-1.19.3.gh.tar.gz 27694 BLAKE2B c1528fa4d4e055dab723bfc40baea591a201546abdccbb81e7dd9ada8620ea74d7371f9c47a8ef310f57934de95b5c295939fa9c095492e02606ca9828bf921d SHA512 fba1b5b39b9c8556ffa75e1a9d2427623bb8ee6f412b78c293c77b248b81d73f624beca9c155279147951510daed7cf5a5120e714efbcce4d62251f74f0924a4
+DIST sphinx-autodoc-typehints-1.19.4.gh.tar.gz 27724 BLAKE2B 5d22561515286a3530a86dad5cf80f0f66068ee50e10a60513dc66bb17be9a8aabb10fe9a35dd6cbeddc6eb78c2403e8f880cbed01e048c5bb3ce48716ff6bdc SHA512 d36a8b3f32dfb6204a248b91f20882b97efa9aa746cd9eeb445945de165511ddce4f9d3cc63799a5f9acc5b2fa6a4352eb7205e679b8937138a12cc462c94056
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.4.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.4.ebuild
new file mode 100644
index 000000000000..b61995da51f2
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension"
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+SRC_URI="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/sphinx-5.2.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nptyping-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/sphobjinv-2.2.2[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}