summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-09 08:01:16 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-09 08:08:35 +0200
commitd7bc86ecfe912091aa4ca5ea4554e7fbe0faa8c5 (patch)
treee9aa75b46534827483e5f514ab915a52428d04c2
parentdev-python/flatdict: Bump to 4.0.1 (diff)
downloadgentoo-d7bc86ecfe912091aa4ca5ea4554e7fbe0faa8c5.tar.gz
gentoo-d7bc86ecfe912091aa4ca5ea4554e7fbe0faa8c5.tar.bz2
gentoo-d7bc86ecfe912091aa4ca5ea4554e7fbe0faa8c5.zip
dev-python/shellingham: Bump to 1.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/shellingham/Manifest1
-rw-r--r--dev-python/shellingham/shellingham-1.5.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/shellingham/Manifest b/dev-python/shellingham/Manifest
index 8fe740232d11..74b3bc57e213 100644
--- a/dev-python/shellingham/Manifest
+++ b/dev-python/shellingham/Manifest
@@ -1 +1,2 @@
DIST shellingham-1.5.0.gh.tar.gz 21078 BLAKE2B 94469e640b6827312d5efde90916d41d4c33c24738e0dfb5c80aff8d16b858936e6b0d2f90dd5d69ee3b5698196df1c4e475685279eb978b7dd0afba67fa5d5d SHA512 2f73acdb30da499493bb79a3db24133f5bcb88d4d755387a81bc04ec30fe91ca44761d7d49fe793495b09f1c34ff59ef320a1e001cf5628ddc62885c05466076
+DIST shellingham-1.5.1.gh.tar.gz 21429 BLAKE2B 19a3258836616e8da2510d1d3af1d9bba5731494e10c5f20a9a50b153b0a9e5892005f9bab0ad5938731457db072acccd3071614ff854ae5ffe13ea406cd10f3 SHA512 764419bb1bf9ac223210b1b01abdb15ff276eb1651d91f0e0ee423ec475100d781149fcf98a43bac5ebb22761a4b775bc669c6e9722d25870dbde50568622242
diff --git a/dev-python/shellingham/shellingham-1.5.1.ebuild b/dev-python/shellingham/shellingham-1.5.1.ebuild
new file mode 100644
index 000000000000..be6e6357e080
--- /dev/null
+++ b/dev-python/shellingham/shellingham-1.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Tool to Detect Surrounding Shell"
+HOMEPAGE="
+ https://github.com/sarugaku/shellingham/
+ https://pypi.org/project/shellingham/
+"
+# Missing tests in PYPI distribution so we use the GH package
+SRC_URI="
+ https://github.com/sarugaku/shellingham/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest