summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-12-26 09:13:59 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-12-26 09:13:59 +0000
commitd7cd0561fd45bf0189a13abe385c6300f81e91b9 (patch)
tree334bf48c41e70ed25fd9fe135582d13dd7bec7a0
parentgnome-extra/libgda: fix RDEPEND 5.2.2 (diff)
parentapp-admin/lastpass-cli: bump to version 0.7.1 (diff)
downloadgentoo-d7cd0561fd45bf0189a13abe385c6300f81e91b9.tar.gz
gentoo-d7cd0561fd45bf0189a13abe385c6300f81e91b9.tar.bz2
gentoo-d7cd0561fd45bf0189a13abe385c6300f81e91b9.zip
Merge remote-tracking branch 'github/pr/518'.
-rw-r--r--app-admin/lastpass-cli/Manifest1
-rw-r--r--app-admin/lastpass-cli/lastpass-cli-0.7.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-admin/lastpass-cli/Manifest b/app-admin/lastpass-cli/Manifest
index 0cc11340fdde..7d23177972b2 100644
--- a/app-admin/lastpass-cli/Manifest
+++ b/app-admin/lastpass-cli/Manifest
@@ -1 +1,2 @@
DIST lastpass-cli-0.6.0.tar.gz 65047 SHA256 e48f210b34a030e8b8cef3e1d05957aabe757ea4cd31bf03c46b70ddc830733c SHA512 ceaa660e6a7d3b27b09ce6d1d522af216e2c8357859d87034f7f887b53631bf5214b02400f8cb91d0c0020fcfb7889dd0fd8731b1af76a63f94666de2ac4dcd4 WHIRLPOOL 4554d8576e71a0b4c7d69556614a33f3e34d85aec4dd6aa50973ba8eb212864fc45bf3a7cb4e2847cb60a00546e46652cf5baf7f34872ada23431e78078cc6ed
+DIST lastpass-cli-0.7.1.tar.gz 68232 SHA256 e9e2d1dbbb6be0b0d9ce8d6c24026fc537cadc824528c96ac562737a90152f5c SHA512 c6be9b4cf30165835dd4e8716992d43246c91c4e9177226285b5a5214fd5927774155cc75b9aad66c69ec8b10ca0b0e00485a429e2bd064dd406fc55f275a295 WHIRLPOOL b88d4de9fdb120463a8454c098c12a1e2a366429904dec82d271b4ef287bdce192efef5de297733c3a38be21f3241ff402c8448a96daa195b986c671456b0b1d
diff --git a/app-admin/lastpass-cli/lastpass-cli-0.7.1.ebuild b/app-admin/lastpass-cli/lastpass-cli-0.7.1.ebuild
new file mode 100644
index 000000000000..ee61d92e3e6f
--- /dev/null
+++ b/app-admin/lastpass-cli/lastpass-cli-0.7.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Interfaces with LastPass.com from the command line."
+SRC_URI="https://github.com/lastpass/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/lastpass/lastpass-cli"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="X +pinentry"
+
+RDEPEND="
+ X? ( || ( x11-misc/xclip x11-misc/xsel ) )
+ dev-libs/openssl:0
+ net-misc/curl
+ dev-libs/libxml2
+ pinentry? ( app-crypt/pinentry )
+"
+DEPEND="${RDEPEND} app-text/asciidoc"
+
+src_compile() {
+ emake PREFIX="${EPREFIX}/usr"
+ emake PREFIX="${EPREFIX}/usr" doc-man
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install-doc
+}