summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-05 07:25:17 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-05 08:07:45 +0200
commitd7dd3d573d0489a1ed686ea4357615eb59d8b535 (patch)
tree78521de533cda23f991471b32348ae765ede4f94
parentdev-python/hypothesis: Bump to 5.32.0 (diff)
downloadgentoo-d7dd3d57.tar.gz
gentoo-d7dd3d57.tar.bz2
gentoo-d7dd3d57.zip
dev-python/setuptools: Bump to 50.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-50.2.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index c8cac70defc8..ec15941b8285 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -1,3 +1,4 @@
DIST setuptools-46.4.0.zip 865912 BLAKE2B 452d36132f5648c79c7e1616a93ff6a39ab2f64b2864ee397b4f57e7f72c47d418ff274f5decd35b0591b09800ad2a7cbd71c283550bd0e60a4d85744a57d4ec SHA512 31e58fd1d682089a45d23aa07c3c2c4c952ca016fa4c3416b2cba979d8b57369f80baef98ce857912e506e87d6cb456497a1ce1c75a0cdf1ee25d4e753b58726
DIST setuptools-49.6.0.zip 2188590 BLAKE2B b789386d31c0d5cbc0c899d24e9af35baad371b698b488ed46b768e8831bae7245b391971e1e402799bc555475c1d8b78bd59a224c26bc78ba68b122a06e0154 SHA512 aad6e74b0e276da0f79c9429860a6d1c7860a30e9a02ce55527abbe7671366640423a1e5476da9ecadfc62ae1bf803cb0c664e2a09cf7619a9c8ac3965b9cf31
DIST setuptools-50.1.0.zip 2168599 BLAKE2B ebfedb9607dd45f638b689ad73714575a584b112b55f9764d2e72333ded7b9170878b76bc92465fdc4ff60a9ff830c9994efc7d1f0195fd5bf8b50c87e7f8fb4 SHA512 b5b0fa45bf87d567847b0a5275cc06f3847f53282832b8b5a0084412c16f558a9db9b8084e27a34b0e99081275bc714acd494731dd487f5850b7ad59257e5cfc
+DIST setuptools-50.2.0.zip 2168687 BLAKE2B c725fb1103f37cef80f78aa7e0920a8e64c8a03d3f696f521ce94a3466c4a97512bf3a2512a24e9d6e92b277f391e8e5163c22ad28c0d34daace432f44ad4ac9 SHA512 1d6d52bd058b4fd3c8322538b7b31b601c04eaf196b49e89f758d691a65fe6e76fca486ba740fbb96bd817ed67b1d390a3724742977be8cc2963106a73c4c17a
diff --git a/dev-python/setuptools/setuptools-50.2.0.ebuild b/dev-python/setuptools/setuptools-50.2.0.ebuild
new file mode 100644
index 000000000000..0d8d2e8bfb98
--- /dev/null
+++ b/dev-python/setuptools/setuptools-50.2.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ app-arch/unzip
+ test? (
+ dev-python/jaraco-envs[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.7.0[${PYTHON_USEDEP}]
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( {CHANGES,README}.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+python_prepare_all() {
+ # disable tests requiring a network connection
+ rm setuptools/tests/test_packageindex.py || die
+
+ # don't run integration tests
+ rm setuptools/tests/test_integration.py || die
+
+ # xpass-es for me on py3
+ #sed -e '/xfail.*710/s:(:(six.PY2, :' \
+ # -i setuptools/tests/test_archive_util.py || die
+
+ # avoid pointless dep on flake8
+ sed -i -e 's:--flake8::' -e 's:--cov::' pytest.ini || die
+
+ # disable the code disabling non-existing coverage plugin
+ sed -i -e 's:cov = .*:return:' conftest.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" pytest -vv ${PN} || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}