summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-08-12 10:11:15 -0400
committerMike Gilbert <floppym@gentoo.org>2019-08-12 10:12:02 -0400
commitd80667d80ec11906c6b3b570f5bb9a55a0e7b318 (patch)
tree711b0d046aa6920122117aa573645011e431b433
parentwww-apps/drupal: Drop old. (diff)
downloadgentoo-d80667d8.tar.gz
gentoo-d80667d8.tar.bz2
gentoo-d80667d8.zip
sys-apps/systemd: enable some basic services for new installs
Also update the preset-all postinst message. Bug: https://bugs.gentoo.org/691854 Package-Manager: Portage-2.3.71, Repoman-2.3.16_p24 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--sys-apps/systemd/systemd-242-r6.ebuild13
-rw-r--r--sys-apps/systemd/systemd-243_rc1-r2.ebuild13
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild13
3 files changed, 24 insertions, 15 deletions
diff --git a/sys-apps/systemd/systemd-242-r6.ebuild b/sys-apps/systemd/systemd-242-r6.ebuild
index 96430b07ddd7..ca3aee2f6d17 100644
--- a/sys-apps/systemd/systemd-242-r6.ebuild
+++ b/sys-apps/systemd/systemd-242-r6.ebuild
@@ -465,6 +465,14 @@ pkg_postinst() {
systemctl --root="${ROOT:-/}" enable "${ENABLED_UNITS[@]}"
fi
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ if type systemctl &>/dev/null; then
+ systemctl --root="${ROOT:-/}" enable getty@.service remote-fs.target || FAIL=1
+ fi
+ elog "To enable a useful set of services, run the following:"
+ elog " systemctl preset-all --preset-mode=enable-only"
+ fi
+
if [[ -L ${EROOT}/var/lib/systemd/timesync ]]; then
rm "${EROOT}/var/lib/systemd/timesync"
fi
@@ -481,11 +489,6 @@ pkg_postinst() {
eerror "systemd again."
eerror
fi
-
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "To enable a useful set of services, run the following:"
- elog " systemctl preset-all"
- fi
}
pkg_prerm() {
diff --git a/sys-apps/systemd/systemd-243_rc1-r2.ebuild b/sys-apps/systemd/systemd-243_rc1-r2.ebuild
index d67b45ec87d6..988973dd9a7e 100644
--- a/sys-apps/systemd/systemd-243_rc1-r2.ebuild
+++ b/sys-apps/systemd/systemd-243_rc1-r2.ebuild
@@ -449,6 +449,14 @@ pkg_postinst() {
systemctl --root="${ROOT:-/}" enable "${ENABLED_UNITS[@]}"
fi
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ if type systemctl &>/dev/null; then
+ systemctl --root="${ROOT:-/}" enable getty@.service remote-fs.target || FAIL=1
+ fi
+ elog "To enable a useful set of services, run the following:"
+ elog " systemctl preset-all --preset-mode=enable-only"
+ fi
+
if [[ -L ${EROOT}/var/lib/systemd/timesync ]]; then
rm "${EROOT}/var/lib/systemd/timesync"
fi
@@ -465,11 +473,6 @@ pkg_postinst() {
eerror "systemd again."
eerror
fi
-
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "To enable a useful set of services, run the following:"
- elog " systemctl preset-all"
- fi
}
pkg_prerm() {
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index c4350573c99d..7556cea0b553 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -445,6 +445,14 @@ pkg_postinst() {
systemctl --root="${ROOT:-/}" enable "${ENABLED_UNITS[@]}"
fi
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ if type systemctl &>/dev/null; then
+ systemctl --root="${ROOT:-/}" enable getty@.service remote-fs.target || FAIL=1
+ fi
+ elog "To enable a useful set of services, run the following:"
+ elog " systemctl preset-all --preset-mode=enable-only"
+ fi
+
if [[ -L ${EROOT}/var/lib/systemd/timesync ]]; then
rm "${EROOT}/var/lib/systemd/timesync"
fi
@@ -461,11 +469,6 @@ pkg_postinst() {
eerror "systemd again."
eerror
fi
-
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "To enable a useful set of services, run the following:"
- elog " systemctl preset-all"
- fi
}
pkg_prerm() {