summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-03 12:02:32 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-03 12:20:02 +0200
commitd8452e492de4389ffe780ed956e13db2da6a3fea (patch)
treec6e82470c3e425f0fc60ffeca93950692c6353a7
parentdev-python/matplotlib: Stop using in-source build (diff)
downloadgentoo-d8452e49.tar.gz
gentoo-d8452e49.tar.bz2
gentoo-d8452e49.zip
dev-python/matplotlib: Use xdist to speed tests up
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/matplotlib/matplotlib-3.5.2.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/matplotlib/matplotlib-3.5.2.ebuild b/dev-python/matplotlib/matplotlib-3.5.2.ebuild
index 4184c7743b79..cf818c423210 100644
--- a/dev-python/matplotlib/matplotlib-3.5.2.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.5.2.ebuild
@@ -6,7 +6,8 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE='tk?,threads(+)'
-inherit distutils-r1 flag-o-matic virtualx toolchain-funcs prefix
+inherit distutils-r1 flag-o-matic multiprocessing prefix toolchain-funcs \
+ virtualx
FT_PV=2.6.1
DESCRIPTION="Pure python plotting library with matlab like syntax"
@@ -109,6 +110,7 @@ BDEPEND="
dev-python/flaky[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
>=dev-python/pygobject-3.40.1-r1:3[cairo?,${PYTHON_USEDEP}]
>=www-servers/tornado-6.0.4[${PYTHON_USEDEP}]
x11-libs/gtk+:3[introspection]
@@ -275,7 +277,8 @@ python_test() {
# speed tests up
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- nonfatal epytest --pyargs matplotlib -m "not network" || die
+ nonfatal epytest --pyargs matplotlib -m "not network" \
+ -p xdist.plugin -n "$(makeopts_jobs)" || die
}
python_install() {