summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-07 22:01:21 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-07 22:02:19 +0200
commitd846823d08cafd29d8e714eeedc2ccd807035bb2 (patch)
tree3e08198361c1e6b052547cda07362730c92a2f4f
parentacct-user/aspnet: add user (216) for www-servers/xsp (diff)
downloadgentoo-d846823d08cafd29d8e714eeedc2ccd807035bb2.tar.gz
gentoo-d846823d08cafd29d8e714eeedc2ccd807035bb2.tar.bz2
gentoo-d846823d08cafd29d8e714eeedc2ccd807035bb2.zip
www-servers/xsp: migrate to GLEP 81
Closes: https://bugs.gentoo.org/781551 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--www-servers/xsp/xsp-3.8_p2014120900-r1.ebuild95
-rw-r--r--www-servers/xsp/xsp-4.7.1-r1.ebuild91
2 files changed, 186 insertions, 0 deletions
diff --git a/www-servers/xsp/xsp-3.8_p2014120900-r1.ebuild b/www-servers/xsp/xsp-3.8_p2014120900-r1.ebuild
new file mode 100644
index 000000000000..c1ec007657b4
--- /dev/null
+++ b/www-servers/xsp/xsp-3.8_p2014120900-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# TODO: We can probably yank the USE_DOTNET/dotnet.eclass stuff
+# but let's be conservative for now
+USE_DOTNET="net35 net40 net45"
+inherit autotools dotnet systemd
+
+EGIT_COMMIT="e272a2c006211b6b03be2ef5bbb9e3f8fefd0768"
+DESCRIPTION="XSP is a small web server that can host ASP.NET pages"
+HOMEPAGE="http://www.mono-project.com/ASP.NET"
+SRC_URI="https://github.com/mono/xsp/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/xsp-${EGIT_COMMIT}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="developer doc test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-db/sqlite:3"
+RDEPEND="
+ ${DEPEND}
+ acct-group/aspnet
+ acct-user/aspnet
+"
+
+PATCHES=(
+ "${FILESDIR}/aclocal-fix.patch"
+)
+
+METAFILETOBUILD=xsp.sln
+
+src_prepare() {
+ default
+
+ eaclocal -I build/m4/shamrock -I build/m4/shave ${ACLOCAL_FLAGS}
+ if test -z "${NO_LIBTOOLIZE}" ; then
+ _elibtoolize --force --copy
+ fi
+
+ eautoconf
+ eautomake --gnu --add-missing --force --copy
+}
+
+src_configure() {
+ local myeconfargs=(
+ "--enable-maintainer-mode"
+ )
+
+ use test && myeconfargs+=( "--with_unit_tests" )
+ use doc || myeconfargs+=( "--disable-docs" )
+
+ econf "${myeconfargs[@]}"
+}
+
+#src_compile() {
+# exbuild xsp.sln
+
+# if use developer ; then
+# exbuild /p:DebugSymbols=True ${METAFILETOBUILD}
+# else
+# exbuild /p:DebugSymbols=False ${METAFILETOBUILD}
+# fi
+#}
+
+src_install() {
+ default
+
+ local PATCHDIR="${FILESDIR}/2.2/"
+
+ newinitd "${PATCHDIR}"/xsp.initd xsp
+ newinitd "${PATCHDIR}"/mod-mono-server-r1.initd mod-mono-server
+ newconfd "${PATCHDIR}"/xsp.confd xsp
+ newconfd "${PATCHDIR}"/mod-mono-server.confd mod-mono-server
+
+ insinto /etc/xsp4
+ doins "${FILESDIR}"/systemd/mono.webapp
+ insinto /etc/xsp4/conf.d
+
+ # mono-xsp4.service was original name from
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=770458;filename=mono-xsp4.service;att=1;msg=5
+ # I think that using the same commands as in debian
+ # systemctl start mono-xsp4.service
+ # systemctl start mono-xsp4
+ # is better than to have shorter command
+ # systemctl start xsp
+ #
+ # insinto /usr/lib/systemd/system
+ systemd_dounit "${FILESDIR}"/systemd/mono-xsp4.service
+
+ keepdir /var/run/aspnet
+}
diff --git a/www-servers/xsp/xsp-4.7.1-r1.ebuild b/www-servers/xsp/xsp-4.7.1-r1.ebuild
new file mode 100644
index 000000000000..a7a1cdb95503
--- /dev/null
+++ b/www-servers/xsp/xsp-4.7.1-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_DOTNET="net35 net40 net45"
+inherit autotools dotnet systemd
+
+DESCRIPTION="XSP is a small web server that can host ASP.NET pages"
+HOMEPAGE="http://www.mono-project.com/ASP.NET"
+SRC_URI="https://github.com/mono/xsp/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="developer doc test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-db/sqlite:3"
+RDEPEND="
+ ${DEPEND}
+ acct-group/aspnet
+ acct-user/aspnet
+"
+
+PATCHES=(
+ "${FILESDIR}/aclocal-fix.patch"
+)
+
+METAFILETOBUILD=xsp.sln
+
+src_prepare() {
+ default
+
+ eaclocal -I build/m4/shamrock -I build/m4/shave ${ACLOCAL_FLAGS}
+ if test -z "${NO_LIBTOOLIZE}" ; then
+ _elibtoolize --force --copy
+ fi
+
+ eautoconf
+ eautomake --gnu --add-missing --force --copy
+}
+
+src_configure() {
+ local myeconfargs=(
+ "--enable-maintainer-mode"
+ )
+
+ use test && myeconfargs+=( "--with_unit_tests" )
+ use doc || myeconfargs+=( "--disable-docs" )
+
+ econf "${myeconfargs[@]}"
+}
+
+#src_compile() {
+# exbuild xsp.sln
+#
+# if use developer ; then
+# exbuild /p:DebugSymbols=True ${METAFILETOBUILD}
+# else
+# exbuild /p:DebugSymbols=False ${METAFILETOBUILD}
+# fi
+#}
+
+src_install() {
+ default
+
+ local PATCHDIR="${FILESDIR}/2.2/"
+
+ newinitd "${PATCHDIR}"/xsp.initd xsp
+ newinitd "${PATCHDIR}"/mod-mono-server-r1.initd mod-mono-server
+ newconfd "${PATCHDIR}"/xsp.confd xsp
+ newconfd "${PATCHDIR}"/mod-mono-server.confd mod-mono-server
+
+ insinto /etc/xsp4
+ doins "${FILESDIR}"/systemd/mono.webapp
+ insinto /etc/xsp4/conf.d
+
+ # mono-xsp4.service was original name from
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=770458;filename=mono-xsp4.service;att=1;msg=5
+ # I think that using the same commands as in debian
+ # systemctl start mono-xsp4.service
+ # systemctl start mono-xsp4
+ # is better than to have shorter command
+ # systemctl start xsp
+ #
+ # insinto /usr/lib/systemd/system
+ systemd_dounit "${FILESDIR}"/systemd/mono-xsp4.service
+
+ keepdir /var/run/aspnet
+}