summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-02 15:33:21 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-02 16:16:33 +0100
commitd877885705257f2e662758d4dd979b60b674bf79 (patch)
treee4840b64ca2be3e179b0fa5ef336096c4f51bfa9
parentdev-python/snowballstemmer: Bump to 2.0.0 (diff)
downloadgentoo-d877885705257f2e662758d4dd979b60b674bf79.tar.gz
gentoo-d877885705257f2e662758d4dd979b60b674bf79.tar.bz2
gentoo-d877885705257f2e662758d4dd979b60b674bf79.zip
dev-python/sphinxcontrib-applehelp: Bump to 1.0.2, add tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinxcontrib-applehelp/Manifest1
-rw-r--r--dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-applehelp/Manifest b/dev-python/sphinxcontrib-applehelp/Manifest
index 6fe197d3360d..4d57693d4cd8 100644
--- a/dev-python/sphinxcontrib-applehelp/Manifest
+++ b/dev-python/sphinxcontrib-applehelp/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-applehelp-1.0.1.tar.gz 22086 BLAKE2B 6e10329a1712cfcb1f29a3b4c23be5169507398a43f800623f2b24fd350f7e2ad16a887e87a3b68253dc348337342d3d4397d3a9d81a460c389a77ed4bdc973f SHA512 a6500bc2899f25c0b04c8649e86a6f688823e573a3f58f2b786117768e8b415acffbe79b99cff8aeb6ae3c74dd244254de120b82b7432cf61c5fabdd38f21603
+DIST sphinxcontrib-applehelp-1.0.2.tar.gz 24548 BLAKE2B 9532cb990ed97c6773388a66895a066958187e9100d226e2274c26ba07fc5832e42ba407864b69b002da926a79e71ac2d6315125906156214df3920b585d9f71 SHA512 1325ac83ff15dd28d6f2791caf64e6c08d1dd2f0946dc8891f5c4d8fd062a1e8650c9c39a7459195ef41f3b425f5b8d6c5e277ea85621a36dd870ca5162508da
diff --git a/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.2.ebuild b/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.2.ebuild
new file mode 100644
index 000000000000..e4bb6ff3dd99
--- /dev/null
+++ b/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension which outputs Apple help book"
+HOMEPAGE="https://www.sphinx-doc.org
+ https://github.com/sphinx-doc/sphinxcontrib-applehelp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+RDEPEND="dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${PDEPEND} )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}