summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-06 22:37:32 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-06 22:37:32 +0200
commitd87a3be1f1c702d7465fa8c437d0f6a8f489a16a (patch)
treea42748bfd94618ebf4e17cee68902fe7d6ea785c
parentdev-python/setuptools: Remove old (diff)
downloadgentoo-d87a3be1.tar.gz
gentoo-d87a3be1.tar.bz2
gentoo-d87a3be1.zip
dev-python/watchdog: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/watchdog/Manifest2
-rw-r--r--dev-python/watchdog/watchdog-1.0.2.ebuild39
-rw-r--r--dev-python/watchdog/watchdog-2.1.6.ebuild42
3 files changed, 0 insertions, 83 deletions
diff --git a/dev-python/watchdog/Manifest b/dev-python/watchdog/Manifest
index baca7e7a0a98..b60d94a748e2 100644
--- a/dev-python/watchdog/Manifest
+++ b/dev-python/watchdog/Manifest
@@ -1,3 +1 @@
-DIST watchdog-1.0.2.tar.gz 91796 BLAKE2B 001cbe82ff8aff0c4e56e4d1f02519047580cccb48466566ad7c9c1f462f90a9a036cf90846eb38ec4fb24ff1df2a1ddfec20b3f0587afdc1f938ada1bb0b1ef SHA512 e87a0955ce822daabd7d030804876698f98ed2aad58486e26a94585763655302063f091b653abd385ea99642361b6253d8e051d96019b243a77b078ba86b0d6e
-DIST watchdog-2.1.6.tar.gz 99756 BLAKE2B 5ea08660c28f77be02b261a22e6fbfdfaaa59f79af1eecb396fda2e56ab4b5b290dc2c791b31a6841ac6d96c7974d51e846ce0232e9de6728f6031685685e761 SHA512 810ee2c40d92102815685c6e06bee403dfb85df7c8de5f1b7066b27cef2a8e25f506f8d9cc0ff0ec3213b889a7844138692fd9d1ab0c40d0aa2097c55e85f531
DIST watchdog-2.1.7.gh.tar.gz 100442 BLAKE2B 21247e1790077eb1eb2f1dc2bb8ddebc1b7f6a2c503238c52c660246fee8c1d3483119184a62114efb81c44665321d4e3aa18ffd73b3244a44c4c6df5204c834 SHA512 f69265aac6e8a840d230c15cfe88c803f043cb540785446113617c0fd1a3c5dce8a885a376bbadc75372a718800948dd4b00c618e18e033d510b8e2bc2bbb36b
diff --git a/dev-python/watchdog/watchdog-1.0.2.ebuild b/dev-python/watchdog/watchdog-1.0.2.ebuild
deleted file mode 100644
index 1dc52e0423d5..000000000000
--- a/dev-python/watchdog/watchdog-1.0.2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Python API and shell utilities to monitor file system events"
-HOMEPAGE="https://github.com/gorakhargosh/watchdog"
-SRC_URI="https://github.com/gorakhargosh/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
-RDEPEND="${CDEPEND}
- dev-python/argh[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}
- test? (
- >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/--cov/d' setup.cfg || die
- # broken when django is installed
- sed -i -e 's:test_eventlet_monkey_patching:_&:' \
- tests/test_skip_repeats_queue.py || die
- default
-}
-
-pkg_postinst() {
- optfeature "Bash completion" dev-python/argcomplete
-}
diff --git a/dev-python/watchdog/watchdog-2.1.6.ebuild b/dev-python/watchdog/watchdog-2.1.6.ebuild
deleted file mode 100644
index bdf60d233757..000000000000
--- a/dev-python/watchdog/watchdog-2.1.6.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Python API and shell utilities to monitor file system events"
-HOMEPAGE="https://github.com/gorakhargosh/watchdog"
-SRC_URI="https://github.com/gorakhargosh/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/--cov/d' setup.cfg || die
- default
-}
-
-python_test() {
- local deselect=()
-
- [[ ${EPYTHON} == pypy3 ]] && deselect+=(
- tests/test_inotify_buffer.py::test_move_internal_batch
- )
-
- epytest -p no:django ${deselect[@]/#/--deselect }
-}
-
-pkg_postinst() {
- optfeature "Bash completion" dev-python/argcomplete
-}