summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-12-08 15:05:17 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-12-08 15:11:57 -0500
commitd892f13d900fca2e3a604def03866bcb99bd7c61 (patch)
tree71bf849fbfb6a7907552d5b4d2995ca27eb67f34
parentx11-misc/xdotool: implement IUSE=doc (diff)
downloadgentoo-d892f13d.tar.gz
gentoo-d892f13d.tar.bz2
gentoo-d892f13d.zip
net-misc/ytfzf: add 2.5.3
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--net-misc/ytfzf/Manifest1
-rw-r--r--net-misc/ytfzf/ytfzf-2.5.3.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/net-misc/ytfzf/Manifest b/net-misc/ytfzf/Manifest
index 6824a2467eb1..a8ea635c7f78 100644
--- a/net-misc/ytfzf/Manifest
+++ b/net-misc/ytfzf/Manifest
@@ -1 +1,2 @@
DIST ytfzf-2.5.2.tar.gz 3263326 BLAKE2B aa0e6b01ba90217df1e488cfbe74f44baadee0fa5f6e29f45ef79af9a0d9587ef394b345ddf6b8a86282f57f097c6728adccba2e444eda38d1746ae95438900f SHA512 aa87d2f3c50bfed3c49d363b23bdf17c6c5307116648f3042148d828d204cc9f1ce61888a82fade26e46dc46991cb2c8f559f5f9aa671d8bcf425d343fdff389
+DIST ytfzf-2.5.3.tar.gz 3265442 BLAKE2B e920bf60a567741cc84739d20f282c27036eafaa823ea273439e49f9b855798a11f611ee8b4893490538d24c3039f2780451272f82ead73c45fb0f2124e05417 SHA512 fcc9e6064fe381972f30a94fd418ba9a497fed4be891f40b75e608a4c095f7b311000ae104d8e877b52622defa4ff57cb0ec1ace4d034ba08f0ff3985438d58d
diff --git a/net-misc/ytfzf/ytfzf-2.5.3.ebuild b/net-misc/ytfzf/ytfzf-2.5.3.ebuild
new file mode 100644
index 000000000000..13c448f9f13f
--- /dev/null
+++ b/net-misc/ytfzf/ytfzf-2.5.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Posix script to find and watch youtube videos from the terminal"
+HOMEPAGE="https://github.com/pystardust/ytfzf/"
+SRC_URI="https://github.com/pystardust/ytfzf/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X minimal"
+
+RDEPEND="
+ app-misc/jq
+ net-misc/curl[ssl]
+ app-alternatives/awk
+ !minimal? (
+ X? ( media-gfx/ueberzug )
+ app-shells/fzf
+ media-video/mpv[lua]
+ net-misc/yt-dlp
+ )"
+
+src_prepare() {
+ default
+
+ sed -i "/^: ...YTFZF_SYSTEM_ADDON_DIR/s|/usr/local|${EPREFIX}/usr|" ytfzf || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ local emakeargs=(
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}"/usr
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+ )
+
+ emake "${emakeargs[@]}" addons doc install
+ einstalldocs
+
+ rm -r "${ED}"/usr/share/licenses || die
+}
+
+pkg_postinst() {
+ optfeature "external menu support" x11-misc/dmenu
+ optfeature "desktop notifications" x11-libs/libnotify
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Note that ${PN} supports many methods to display menus/thumbnails."
+ elog "This ebuild primarily covers defaults and major features, additional"
+ elog "dependencies may be needed for others. Set USE=minimal if want full"
+ elog "control over optional dependencies (e.g. fzf is optional if use dmenu)."
+ fi
+}