summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-06 12:44:30 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-06 15:06:26 +0100
commitd8ad9d04865e1a1f4a6c754a1ec2017bca93dfec (patch)
tree4131977e2bbcddab07c8f40a505ced5e91b38b45
parentdev-python/qiskit-terra: Remove old (diff)
downloadgentoo-d8ad9d04.tar.gz
gentoo-d8ad9d04.tar.bz2
gentoo-d8ad9d04.zip
dev-python/qiskit-aer: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/qiskit-aer/Manifest1
-rw-r--r--dev-python/qiskit-aer/qiskit-aer-0.10.3.ebuild92
2 files changed, 0 insertions, 93 deletions
diff --git a/dev-python/qiskit-aer/Manifest b/dev-python/qiskit-aer/Manifest
index c2048858b315..f31df6058b1b 100644
--- a/dev-python/qiskit-aer/Manifest
+++ b/dev-python/qiskit-aer/Manifest
@@ -1,2 +1 @@
-DIST qiskit-aer-0.10.3.gh.tar.gz 6657490 BLAKE2B 443f7df2259c720fb93a60659da9b1cded25f9dbdf585bd0322e9f4effe4c5955daf6587d6c3964ab4a7e4a8bf6270f857abae1cf4e6b0718801daa6a96c2aec SHA512 c882624bac373566b003a01fffa6963d4ad8796ce18786b50ef85350daac26814c147b36067eb6fce4f264919b3680246e767b5c13ac338817fd394620392079
DIST qiskit-aer-0.11.1.gh.tar.gz 6699343 BLAKE2B 3795e1f71914bbc0074a2eac10a82a28f3171d50f292a13dcb705f62daa5fa332a1eabd52391c1b168a822ca6428feb79fe08bb7c93cfd2f7ee5b0d38fed012b SHA512 7880f2ee99f34eca285b9e7cd096981db2f981d41c54881c4036e2745e4af1185b740d93cd157b83ce4adaf8c207c9c063b86e9a1fa514d1388437d6f33e219f
diff --git a/dev-python/qiskit-aer/qiskit-aer-0.10.3.ebuild b/dev-python/qiskit-aer/qiskit-aer-0.10.3.ebuild
deleted file mode 100644
index 3fc6e2707460..000000000000
--- a/dev-python/qiskit-aer/qiskit-aer-0.10.3.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="High performance simulator for quantum circuits that includes noise models"
-HOMEPAGE="https://github.com/Qiskit/qiskit-aer"
-SRC_URI="https://github.com/Qiskit/qiskit-aer/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-# The reference implementation of BLAS/CBLAS is not compatible with qiskit-aer right now,
-# because importing library causes an error.
-# /usr/lib/python3.9/site-packages/qiskit/providers/aer/backends/controller_wrappers.cpython-39-x86_64-linux-gnu.so: undefined symbol: slamch_
-# Using sci-libs/openblas instead here,
-# with the option to switch between reference/openblas implementation runtime (eselect-ldso).
-COMMON_DEPEND="
- >=dev-python/numpy-1.16.3[${PYTHON_USEDEP}]
- >=dev-cpp/nlohmann_json-3.1.1
- >=dev-libs/spdlog-1.5.0
- >=dev-cpp/muParserX-4.0.8
- virtual/cblas[eselect-ldso]
- sci-libs/openblas[eselect-ldso]"
-
-BDEPEND="
- ${COMMON_DEPEND}
- >dev-util/cmake-3.17
- >=dev-python/scikit-build-0.11.0[${PYTHON_USEDEP}]
- >=dev-python/pybind11-2.6[${PYTHON_USEDEP}]
- test? (
- dev-python/ddt[${PYTHON_USEDEP}]
- dev-python/fixtures[${PYTHON_USEDEP}]
- )"
-
-RDEPEND="
- ${COMMON_DEPEND}
- >=dev-python/qiskit-terra-0.19.1[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.0[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-# Remove cmake dependency from setup.py because of
-# invalid dependency description. We put this dependency check in BDEPEND.
-PATCHES=( "${FILESDIR}/qiskit-aer-0.10.3-remove-cmake-dependency.patch" )
-
-check_openblas() {
- local libdir=$(get_libdir) me="openblas"
-
- # check blas
- local current_blas=$(eselect blas show ${libdir} | cut -d' ' -f2)
- if [[ ${current_blas} != "${me}" ]]; then
- eerror "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
- eerror "To use qiskit-aer, you have to issue (as root):"
- eerror "\t eselect blas set ${libdir} ${me}"
- return 1
- fi
- return 0
-}
-
-pkg_setup() {
- if use test; then
- check_openblas
- if [ $? -ne 0 ]; then
- die "Set blas implementation to openblas using 'eselect blas set openblas'!"
- fi
- fi
-}
-
-python_prepare_all() {
- export DISABLE_CONAN="ON"
- export DISABLE_DEPENDENCY_INSTALL="ON"
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # We have to hide the source code directory so tests
- # do not use these, but instead the compiled library.
- mv qiskit qiskit.hidden || die
- epytest
- mv qiskit.hidden qiskit || die
-}
-
-pkg_postinst() {
- check_openblas
-}