summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-27 06:29:29 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-27 06:49:30 +0200
commitd8b9606ce1f980befacac7f94029660e7ed0185c (patch)
tree5d1e56f0e45d878efd551852103e07788e8c6623
parentdev-python/pytest: Bump to 7.2.0 (diff)
downloadgentoo-d8b9606c.tar.gz
gentoo-d8b9606c.tar.bz2
gentoo-d8b9606c.zip
dev-python/zeroconf: Bump to 0.39.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.39.3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index 91eea7f76917..6c7925efe0e1 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1,2 +1,3 @@
DIST python-zeroconf-0.39.1.gh.tar.gz 135252 BLAKE2B 82efa3e39b6e18b9d73b45958190c1d76978231842c1f61ff4519b9a763fb2c1564dae9c0b1d31109e291acc966127cfae9fa02400f1695e97dcc1b0e5a509f7 SHA512 3e1bc4bd48b77bce711f8b49b9cdce1769d7af72094c9ebc161ecb833fe90c7bd36ec5b9fc35c524ddd8c30a67af5937f188c81cf3a251d80c0e71f4b7c3add7
DIST python-zeroconf-0.39.2.gh.tar.gz 136788 BLAKE2B ce8130cd3b89969e0cb5a9e9ddc82dc29e2517a29ce44f309950034ece433475336647dcebef8d6ec0d68271b784f9a345d2fb752dc0ad185db0298cfbad4bdd SHA512 0e1f5abdb5ed82bd281353c7bd84eeabd160195d66d641a4ce97f5f4806aab9bcf1c4cdf399e1a8082ac9b7ad979151bfc03b2b6226744075b2025fceaa30c79
+DIST python-zeroconf-0.39.3.gh.tar.gz 137044 BLAKE2B df2ba0b21902296e77fc20ff006872995efc378898d381e61e5f366f27e2532cedbd9482675f8aa163e258b68e0b33d2134783ca1c72a7fee52a209ac821f185 SHA512 3d76b88fed2db3674e3319e27fc85a036ae9d990bea2cf369cbd5853b416fad8315e156d6a7c5f025d09ba069675c4be53c34f9b021d05bff04422ea9101e6a0
diff --git a/dev-python/zeroconf/zeroconf-0.39.3.ebuild b/dev-python/zeroconf/zeroconf-0.39.3.ebuild
new file mode 100644
index 000000000000..e803d214a211
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.39.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/async-timeout-4.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+)