summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-17 23:21:18 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-17 23:45:44 -0400
commitd8d1824e2b68a2c2c279189f74931fdd600f517b (patch)
treed57aa019d6dfeae41c6d9758c0c827faa591e0ed
parentdev-libs/vala-common: Version bump to 0.52.2 (diff)
downloadgentoo-d8d1824e.tar.gz
gentoo-d8d1824e.tar.bz2
gentoo-d8d1824e.zip
dev-lang/vala: Version bump to 0.52.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-lang/vala/Manifest1
-rw-r--r--dev-lang/vala/vala-0.52.2.ebuild52
-rw-r--r--eclass/vala.eclass4
-rw-r--r--profiles/package.mask5
4 files changed, 60 insertions, 2 deletions
diff --git a/dev-lang/vala/Manifest b/dev-lang/vala/Manifest
index 0950b8af2dc5..720eeb2bc2ff 100644
--- a/dev-lang/vala/Manifest
+++ b/dev-lang/vala/Manifest
@@ -4,3 +4,4 @@ DIST vala-0.44.11.tar.xz 3370248 BLAKE2B c111b6175e6339148e30bedc77f62a9ef3ec912
DIST vala-0.46.13.tar.xz 3434196 BLAKE2B 49b7e0b776e185653c1b8c00747a150ceb42cf89006fd55d37e3efd0824dace379d2c72cdb45d481b0545d0b4b37299bc6161b2d083d3221d2d8d8ca7c10d6dc SHA512 6d8d1acebf4706346d5dc986f5c900cfda929ca59ca3f3907cff56892a496bf524b1f74032ac6c8587b236a473124e15c6f83f949636e28141a55c8abeddf004
DIST vala-0.48.12.tar.xz 3492200 BLAKE2B 0a401ac4349dc1c628fa608b5a89504583d6d2bb05ca74eb507e766cca418121e14adfe6e8cfeb8f42212c717280b9b91426309df415d869896654be626c46c5 SHA512 da7becf8b92985a07b139651c14bd41ec86aed3e2b610029d2b376f70335c98607f39de4a1fa4efe9d51e6088edd4c13d22431cada389679d55f684ad548f4d1
DIST vala-0.50.2.tar.xz 3514208 BLAKE2B f2f7e86b90ac1245d593ba82204667a830843e2fdb8e9a5afaa44453a146461f0ce2b9f9338ef4743bc6055bbce6c023ae92f0bf2ca66757cddd7fc3d7a4db63 SHA512 77069b53037adcd4c3fed2dc4a5c740216b950c52e8a0ed777a5cf9a5d9f078d0abbc4dbce08e122817cd3de0ac75ebd150b0f6f0b0cf4a09cb4a46f96bf4c3e
+DIST vala-0.52.2.tar.xz 3573764 BLAKE2B 88340f7142518a0c17ab2347cd76853d18c00f86ed030cdcdbe726d92dc165ce2c83d07301f77c08f839f1d6b0da05c77e19671817483786fa57ed5bbcd240cc SHA512 c30b64f6899c53eb852128b95265ccec99d27a14388525829da1e5f5ff229c695a1e67b9e3bcc8fef751221c8923aa853bd2065ec0cfbc9b19d6c04007ed4110
diff --git a/dev-lang/vala/vala-0.52.2.ebuild b/dev-lang/vala/vala-0.52.2.ebuild
new file mode 100644
index 000000000000..d3cf852fc947
--- /dev/null
+++ b/dev-lang/vala/vala-0.52.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2
+
+DESCRIPTION="Compiler for the GObject type system"
+HOMEPAGE="https://wiki.gnome.org/Projects/Vala"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.52"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-linux"
+IUSE="test valadoc"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.48.0:2
+ >=dev-libs/vala-common-${PV}
+ valadoc? ( >=media-gfx/graphviz-2.16 )
+ !<net-libs/libsoup-2.66.2[vala]
+" # Older libsoup generates a libsoup-2.4.vapi that isn't fine for vala:0.46 anymore
+# We block here, so libsoup[vala] consumers wouldn't have to >= it, which would be bad
+# as the newer is not required with older vala when those are picked instead of 0.46.
+# vala-0.45.91 ships a broken libsoup-2.4.vapi copy too, but that'll be fixed by 0.45.92
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/dbus-glib
+ >=dev-libs/glib-2.26:2
+ dev-libs/gobject-introspection
+ )
+"
+BDEPEND="
+ dev-libs/libxslt
+ sys-devel/flex
+ virtual/pkgconfig
+ virtual/yacc
+"
+
+src_configure() {
+ # weasyprint enables generation of PDF from HTML
+ gnome2_src_configure \
+ --disable-unversioned \
+ $(use_enable valadoc) \
+ VALAC=: \
+ WEASYPRINT=:
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}
diff --git a/eclass/vala.eclass b/eclass/vala.eclass
index 88c5231286ab..7bdf0d9d0e5b 100644
--- a/eclass/vala.eclass
+++ b/eclass/vala.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: vala.eclass
@@ -32,7 +32,7 @@ VALA_MIN_API_VERSION=${VALA_MIN_API_VERSION:-0.36}
# @ECLASS-VARIABLE: VALA_MAX_API_VERSION
# @DESCRIPTION:
# Maximum vala API version (e.g. 0.36).
-VALA_MAX_API_VERSION=${VALA_MAX_API_VERSION:-0.50}
+VALA_MAX_API_VERSION=${VALA_MAX_API_VERSION:-0.52}
# @ECLASS-VARIABLE: VALA_USE_DEPEND
# @DEFAULT_UNSET
diff --git a/profiles/package.mask b/profiles/package.mask
index ac669c703632..244d76f49aee 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -32,6 +32,11 @@
#--- END OF EXAMPLES ---
+# Matt Turner <mattst88@gentoo.org> (2021-04-18)
+# Masked for testing.
+>=dev-libs/vala-common-0.51
+dev-lang/vala:0.52
+
# Michał Górny <mgorny@gentoo.org> (2021-04-17)
# Superseded by dev-python/pycodestyle. Last revdep masked for removal.
# Removal on 2021-05-17. Bug #783369.