summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2017-10-17 14:35:16 +0200
committerTobias Klausmann <klausman@gentoo.org>2017-10-17 14:35:40 +0200
commitd9390b31a4e06bf70af55d9928650d701678b2d7 (patch)
tree88ed0229a54ba387a7408997ea50f30cebf80a6f
parentsys-fs/e2fsprogs: stable 1.43.6 for ia64/ppc/ppc64, bug #634520 (diff)
downloadgentoo-d9390b31.tar.gz
gentoo-d9390b31.tar.bz2
gentoo-d9390b31.zip
app-text/sigil: Add v0.9.8 with fixed patch
Gentoo-Bug: https://bugs.gentoo.org/621204 Fixes: https://bugs.gentoo.org/621204 Package-Manager: Portage-2.3.11, Repoman-2.3.3
-rw-r--r--app-text/sigil/Manifest1
-rw-r--r--app-text/sigil/files/sigil-0.9.8-proper-gumbo-install.patch24
-rw-r--r--app-text/sigil/sigil-0.9.8.ebuild82
3 files changed, 107 insertions, 0 deletions
diff --git a/app-text/sigil/Manifest b/app-text/sigil/Manifest
index 974181917306..5b7c9c044e6e 100644
--- a/app-text/sigil/Manifest
+++ b/app-text/sigil/Manifest
@@ -1,3 +1,4 @@
DIST Sigil-0.9.5-Code.zip 19224845 SHA256 fd9963c4e5b9013bd95ed0659dbc5e67c9848982800f2ec99bf96bbdfb708ff1 SHA512 f2e151f716ce57f9bb94d621ae8e5281c6a0cce12e58b49abe959d1f602fbdb8d28f16d5dc418dca871b100efba2fe13f7f2a66c6704346b5a40755a68e8f625 WHIRLPOOL 8ec15cb19175097b4bd0613139366d58a5fd0c01259e3cfb9203d585e009f1207ba3e9b68cd5213793c8309f9e18720ac9eec674d820947833a90dbcc6dcc3d5
DIST Sigil-0.9.6-Code.zip 19307454 SHA256 7856ad20116ef13fc3f79fa01c1d65c8b15ce1047f1e88b0723c2658cd8f18fd SHA512 8ae5ce89baf199a10b940d25b3bb3cb97a03dab993e318c5a2b5e6fcba7d4741cbc865f3408d36bd5ad784c35833e4ab3d7b3e282047560d57cd7790c6709417 WHIRLPOOL d74290b59247ced4977bf575adb93c7a76a8045f464b649854e49f6028cb2a9fb28c50fc36d00d3ab106768a85c514b5df5252e5172597a6120913a051b9cca7
+DIST Sigil-0.9.8-Code.zip 19807795 SHA256 78f9f200c86da326984543bd86cbb8eab91308a5a4d7f8cfcc88eb9b0779749a SHA512 18cd137ead965bc97626499ec73dddb8db82b4d538c30f70e62546bd1eeb6e2e76ce7587d572354d973363a07e93ec33b60024bbef7914a22cbfc28a76af2a00 WHIRLPOOL 16a3b3ce3f3c67236b95aba91a5d5a2fce88a4d72364fbef7c6c69dcabb6a53849d74334d2684b58a64cf35b6ba43494b3d260909d6d0e9b06f99ec3593069cf
DIST sigil-0.8.7.tar.gz 19394061 SHA256 0352cc46714ebb5067a0fbdbbc76dded8f10ea0f4f43374c7dbcac6eba49e104 SHA512 24b74c835ae1f8fb887c9d2c59b3ccc6720ce1fe8d19a6b0056754ab5ea6e63c34c4b229f4e4b3a880e722876d288e58385f5a0ad15b295f147b77b1acf28652 WHIRLPOOL 2cb7a8a928069a2f005396faa9bdacde1f77f3cca3a3ba2458b8562e48298a127b9de9d7ecea5f106ad68865d5074b13fff5a234497b2b6655ac1a3c3edef827
diff --git a/app-text/sigil/files/sigil-0.9.8-proper-gumbo-install.patch b/app-text/sigil/files/sigil-0.9.8-proper-gumbo-install.patch
new file mode 100644
index 000000000000..375f2e0ab6ca
--- /dev/null
+++ b/app-text/sigil/files/sigil-0.9.8-proper-gumbo-install.patch
@@ -0,0 +1,24 @@
+--- a/src/CMakeLists.txt 2017-10-17 14:22:57.780297490 +0200
++++ b/src/CMakeLists.txt 2017-10-17 14:24:21.754150453 +0200
+@@ -962,12 +962,8 @@
+ endif()
+
+ # Standard Linux 'make install'
+- install( TARGETS sigil DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/sigil/ )
++ install( TARGETS sigil DESTINATION ${CMAKE_INSTALL_PREFIX}/${LIBDIR}/sigil/ )
+ install( PROGRAMS ${LINUX_LAUNCH_INSTALL_SCRIPT_CONFIGURED} DESTINATION ${CMAKE_INSTALL_PREFIX}/bin/ RENAME ${PROJECT_NAME} )
+- if( NOT USE_SYSTEM_LIBS OR NOT HUNSPELL_FOUND )
+- install( PROGRAMS ${HUNSPELL_NAME} DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/sigil/ )
+- endif()
+- install( PROGRAMS ${GUMBO_NAME} DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/sigil/ )
+ if( BUILD_PATCHED_LIBXML2 )
+ install( PROGRAMS ${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/libsigilxml2.so.2.9.4 DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/sigil/ )
+ install( FILES ${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/libxml2.so.2 DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/sigil/ )
+--- a/internal/gumbo/CMakeLists.txt 2017-10-17 14:25:02.539107666 +0200
++++ b/internal/gumbo/CMakeLists.txt 2017-10-17 14:25:27.985457056 +0200
+@@ -40,4 +40,5 @@
+
+ if( UNIX AND NOT APPLE )
+ set( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99" )
++ install( TARGETS sigilgumbo DESTINATION ${CMAKE_INSTALL_PREFIX}/${LIBDIR}/sigil/ )
+ endif()
diff --git a/app-text/sigil/sigil-0.9.8.ebuild b/app-text/sigil/sigil-0.9.8.ebuild
new file mode 100644
index 000000000000..0bdd33c470ee
--- /dev/null
+++ b/app-text/sigil/sigil-0.9.8.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 python3_5 )
+
+inherit cmake-utils python-single-r1
+
+my_pn="Sigil"
+
+DESCRIPTION="Sigil is a multi-platform WYSIWYG ebook editor for ePub format"
+HOMEPAGE="http://sigil-ebook.com/"
+SRC_URI="https://github.com/Sigil-Ebook/${my_pn}/releases/download/${PV}/${my_pn}-${PV}-Code.zip"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-text/hunspell
+ dev-libs/boost[threads]
+ dev-libs/libpcre[pcre16]
+ dev-libs/xerces-c[icu]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/cssutils[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-qt/qtconcurrent-5.4:5
+ >=dev-qt/qtcore-5.4:5
+ >=dev-qt/qtgui-5.4:5
+ >=dev-qt/qtprintsupport-5.4:5
+ >=dev-qt/qtwebkit-5.4:5
+ >=dev-qt/qtwidgets-5.4:5
+ >=dev-qt/qtxmlpatterns-5.4:5
+ sys-libs/zlib[minizip]
+"
+DEPEND="${RDEPEND}
+ >=sys-devel/gcc-4.8
+ virtual/pkgconfig
+ >=dev-qt/linguist-tools-5.4:5
+ app-arch/unzip
+"
+
+S="${WORKDIR}"
+
+PATCHES=(
+ # sigil tries to copy non-needed qt libs for deb package, safe to ignore this completely
+ "${FILESDIR}"/${PN}-0.9.8-proper-gumbo-install.patch
+)
+DOCS=( ChangeLog.txt README.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SYSTEM_LIBS=1
+ -DSYSTEM_LIBS_REQUIRED=1
+ -DLIBDIR="$(get_libdir)"
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ elog "From Sigil's release notes:"
+ elog "When you fire up Sigil for the very first time:"
+ elog "navigate to the new General Preferences and select the default"
+ elog "epub version you plan to work with (epub 2 or epub3) so that new"
+ elog "empty ebooks start with the correct code."
+ elog "if you plan to work with epub3 epubs, you should change your"
+ elog "PreserveEntities setting to use ONLY NUMERIC entities."
+ elog ""
+ elog "For example use & # 1 6 0 ; for non-breaking spaces and etc."
+ elog ""
+ elog "We strongly recommend enabling Mend On Open in your settings"
+ elog "for best performance with Sigil."
+}