summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-11-06 20:27:22 -0400
committerMike Gilbert <floppym@gentoo.org>2021-11-06 20:28:48 -0400
commitd97459e9b0f51457a9ca262fe35158575f2f9178 (patch)
treeb2f114edda247e6150cc62164d8553df4e13bef8
parentsys-fs/ntfs3g: add 'fuse' USE flag (diff)
downloadgentoo-d97459e9b0f51457a9ca262fe35158575f2f9178.tar.gz
gentoo-d97459e9b0f51457a9ca262fe35158575f2f9178.tar.bz2
gentoo-d97459e9b0f51457a9ca262fe35158575f2f9178.zip
sys-fs/ntfs3g: drop silly kernel check for CONFIG_FUSE
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2021.8.22-r3.ebuild10
1 files changed, 2 insertions, 8 deletions
diff --git a/sys-fs/ntfs3g/ntfs3g-2021.8.22-r3.ebuild b/sys-fs/ntfs3g/ntfs3g-2021.8.22-r3.ebuild
index 1b89073cd283..28102ca67d43 100644
--- a/sys-fs/ntfs3g/ntfs3g-2021.8.22-r3.ebuild
+++ b/sys-fs/ntfs3g/ntfs3g-2021.8.22-r3.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit linux-info toolchain-funcs
+
+inherit toolchain-funcs
MY_P="ntfs-3g_ntfsprogs-${PV}"
@@ -10,7 +11,6 @@ DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
HOMEPAGE="http://www.tuxera.com/community/ntfs-3g-download/"
HOMEPAGE="https://jp-andre.pagesperso-orange.fr/advanced-ntfs-3g.html"
SRC_URI="http://tuxera.com/opensource/${MY_P}.tgz"
-#SRC_URI="https://jp-andre.pagesperso-orange.fr/${MY_P}.tgz"
LICENSE="GPL-2"
# The subslot matches the SONAME major #.
@@ -34,12 +34,6 @@ BDEPEND="
S="${WORKDIR}/${MY_P}"
-pkg_setup() {
- CONFIG_CHECK="~FUSE_FS"
- FUSE_FS_WARNING="You need to have FUSE module built to use ntfs-3g"
- linux-info_pkg_setup
-}
-
src_configure() {
tc-ld-disable-gold