summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-10-19 21:05:53 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-10-19 21:13:53 -0400
commitd979c16f62833da4e009dab5db8257737363604a (patch)
tree64c300e3ce93747b13643437887b01ffab0cc5a3
parentx11-drivers/nvidia-drivers: emphasise that fbdev=1 is experimental (diff)
downloadgentoo-d979c16f.tar.gz
gentoo-d979c16f.tar.bz2
gentoo-d979c16f.zip
www-client/qutebrowser: add 3.0.2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--www-client/qutebrowser/Manifest2
-rw-r--r--www-client/qutebrowser/qutebrowser-3.0.2.ebuild206
2 files changed, 208 insertions, 0 deletions
diff --git a/www-client/qutebrowser/Manifest b/www-client/qutebrowser/Manifest
index f985470fac4a..6f44a498049f 100644
--- a/www-client/qutebrowser/Manifest
+++ b/www-client/qutebrowser/Manifest
@@ -1,2 +1,4 @@
DIST qutebrowser-3.0.0.tar.gz 6030459 BLAKE2B 05e1f3c87fe572ec66d199b9c255178c7e7358321c44255b9191624fa4fede0525b16ff0740df5051390f4e3b2a2c3ee99d53fcf6c44279689f9ea0427df13ca SHA512 2aa361b418adad1e2c2dd068148215f3eaea29c70e00634fd1a2370d584ffa2a66b0a0e22623656fc5f634d35ba99a178c269a3accd25edf778b7e3077ceb373
DIST qutebrowser-3.0.0.tar.gz.asc 659 BLAKE2B 19d736ede7cfb2ac4d3ebaea7f4f8a6da722e3eac0c1693d487ed16f2bc5a5cce13bbc69604cd7c34e266c345f3149f2f2250aba71555f3290cd63216adc0b98 SHA512 25c9cd3fa44f712b98ef3f8d1821f61d5f2b96d8bf108ff2277dc6609343237876124f7587cf906127b8d6161923bda0946c6ef75f3cbf6c401cf5d72b7a6ffd
+DIST qutebrowser-3.0.2.tar.gz 6036377 BLAKE2B e7e20eacae745fb6a2c30e16667f1db55dc744d63cc20d287d563b1a69741797a2d473c8a450a93bae700db6798f9dd7549c3bec5497ffc67679d8f63e82d5fb SHA512 fb980d3d55bb6f6ecdb79f3d38e616399828c647b9fbf16c791e8964ba3e6f350ffced0944bbec60b60a2451c60e383ecdd93e535f41292d2dc2b75830049a66
+DIST qutebrowser-3.0.2.tar.gz.asc 659 BLAKE2B ed789a18a5221143632f0abcc112526910952eccfd01c01cc418ef2175b2ca42b1ae7b0a21ac4194789b0ce5713628b328dc36a5328e3e01084672839fcef184 SHA512 b01276f073498f9ef982706b1b8048db22e3fa017d99b9ebe2f4f75615a12c5614ea2b047577632e558e4f3c860fa9a84429a47f0dfa75a287b24fb86a8af950
diff --git a/www-client/qutebrowser/qutebrowser-3.0.2.ebuild b/www-client/qutebrowser/qutebrowser-3.0.2.ebuild
new file mode 100644
index 000000000000..e6b161f1ee7b
--- /dev/null
+++ b/www-client/qutebrowser/qutebrowser-3.0.2.ebuild
@@ -0,0 +1,206 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 xdg
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/qutebrowser/qutebrowser.git"
+else
+ inherit verify-sig
+ SRC_URI="
+ https://github.com/qutebrowser/qutebrowser/releases/download/v${PV}/${P}.tar.gz
+ verify-sig? ( https://github.com/qutebrowser/qutebrowser/releases/download/v${PV}/${P}.tar.gz.asc )
+ "
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DESCRIPTION="Keyboard-driven, vim-like browser based on Python and Qt"
+HOMEPAGE="https://qutebrowser.org/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+adblock pdf +qt6 widevine"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+ adblock? ( dev-python/adblock[${PYTHON_USEDEP}] )
+ qt6? (
+ dev-qt/qtbase:6[icu,sqlite]
+ dev-python/PyQt6[${PYTHON_USEDEP},dbus,gui,network,opengl,printsupport,qml,sql,widgets]
+ dev-python/PyQt6-WebEngine[${PYTHON_USEDEP},widgets]
+ pdf? ( www-plugins/pdfjs )
+ )
+ !qt6? (
+ dev-qt/qtcore:5[icu]
+ dev-qt/qtgui:5[png]
+ dev-qt/qtsql:5[sqlite]
+ dev-python/PyQt5[${PYTHON_USEDEP},dbus,declarative,gui,network,opengl,printsupport,sql,widgets]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ pdf? ( <www-plugins/pdfjs-3 )
+ )
+ widevine? ( www-plugins/chrome-binary-plugins )
+ ')
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ test? (
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/cheroot[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-bdd[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xvfb[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+ qt6? ( dev-python/PyQt6[testlib] )
+ !qt6? ( dev-python/PyQt5[testlib] )
+ )
+ ')
+"
+
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+=" app-text/asciidoc"
+else
+ BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-qutebrowser )"
+fi
+
+distutils_enable_tests pytest
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ else
+ local VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/qutebrowser.gpg
+ verify-sig_src_unpack
+ fi
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ if use pdf; then
+ # does not hurt to enable by default if it was explicitly requested
+ sed -e '/^content.pdfjs:/,+1s/false/true/' \
+ -i ${PN}/config/configdata.yml || die
+ fi
+
+ # ensure the requested backend is used in case multiple are available
+ sed -e "/^_WRAPPER_OVERRIDE =/s/None/\"PyQt$(usex qt6 6 5)\"/" \
+ -i qutebrowser/qt/machinery.py || die
+
+ # let eclass handle python
+ sed -i '/setup.py/d' misc/Makefile || die
+
+ if [[ ${PV} == 9999 ]]; then
+ # call asciidoc(1) rather than the single target python module
+ sed -e '/cmdline = /s/= .*/= ["asciidoc"]/' \
+ -i scripts/asciidoc2html.py || die
+
+ "${EPYTHON}" scripts/asciidoc2html.py || die
+ fi
+
+ if use test; then
+ # unnecessary here, and would require extra deps
+ sed -e '/pytest-benchmark/d' -e 's/--benchmark[^ ]*//' \
+ -e '/pytest-instafail/d' -e 's/--instafail//' \
+ -i pytest.ini || die
+
+ if [[ ${PV} == 9999 ]]; then
+ # likewise, needs vulture
+ rm tests/unit/scripts/test_run_vulture.py || die
+ else
+ # https://github.com/qutebrowser/qutebrowser/issues/7620
+ rm tests/unit/scripts/test_problemmatchers.py || die
+ fi
+ fi
+}
+
+python_test() {
+ local -x PYTEST_QT_API=pyqt$(usex qt6 6 5)
+
+ local EPYTEST_DESELECT=(
+ # end2end/IPC tests are broken with "Name error" if socket path is over
+ # ~108 characters (>124 in /var/tmp/portage) due to Linux limitations,
+ # skip rather than bother using /tmp+cleanup over ${T} (end2end tests
+ # are important, but the other tests should be enough for downstream)
+ tests/end2end
+ tests/unit/misc/test_ipc.py
+ # python eclasses provide a fake "failing" python2 and trips this test
+ tests/unit/misc/test_checkpyver.py::test_old_python
+ # not worth running dbus over
+ tests/unit/browser/test_notification.py::TestDBus
+ # fails in ebuild, seems due to saving fake downloads in the wrong location
+ tests/unit/browser/webengine/test_webenginedownloads.py::TestDataUrlWorkaround
+ # may fail if environment is very large (bug #819393)
+ tests/unit/commands/test_userscripts.py::test_custom_env\[_POSIXUserscriptRunner\]
+ # needs _WRAPPER_OVERRIDE = None, but we have changed it
+ tests/unit/test_qt_machinery.py::TestSelectWrapper::test_autoselect_by_default
+ tests/unit/test_qt_machinery.py::TestInit::test_none_available_{implicit,explicit}
+ # fails if chromium version is unrecognized (aka newer qtwebengine)
+ tests/unit/utils/test_version.py::TestWebEngineVersions::test_real_chromium_version
+ )
+
+ # tests known failing with Qt5 which is considered a 2nd class citizen
+ # and, unless completely broken, new tests issues may not be pursued
+ use qt6 || EPYTEST_DESELECT+=(
+ tests/unit/mainwindow/test_tabwidget.py::TestTabWidget::test_tab_text_not_edlided_for_wide_tabs
+ )
+
+ # skip benchmarks (incl. _tree), and warning tests broken by -Wdefault
+ epytest -p xvfb -k 'not _bench and not _matches_tree and not _warning'
+}
+
+python_install_all() {
+ emake -f misc/Makefile DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+
+ rm "${ED}"/usr/share/${PN}/scripts/{mkvenv,utils}.py || die
+ fperms -x /usr/share/${PN}/{scripts/cycle-inputs.js,userscripts/README.md}
+ python_fix_shebang "${ED}"/usr/share/${PN}
+
+ einstalldocs
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+
+ has_version "${CATEGORY}/${PN}[qt6]" && QUTEBROWSER_HAD_QT6=
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Note that optional scripts in ${EROOT}/usr/share/${PN}/{user,}scripts"
+ elog "have additional dependencies not covered by this ebuild, for example"
+ elog "view_in_mpv needs media-video/mpv[lua] and net-misc/yt-dlp."
+ fi
+
+ if [[ ! -v QUTEBROWSER_HAD_QT6 && ${REPLACING_VERSIONS} ]] && use qt6; then
+ ewarn
+ ewarn "Be warned that starting the Qt6 version of ${PN} performs a one-way"
+ ewarn "conversion of ~/.local/share/${PN}/webengine to Qt6. There will also"
+ ewarn "be a warning on startup, and may optionally want to backup first."
+ fi
+
+ # only show Qt6 warning on arches where USE=qt6 is unmasked
+ if use amd64 && use !qt6; then
+ ewarn
+ ewarn "USE=qt6 is disabled, be warned that Qt5's WebEngine uses an older"
+ ewarn "chromium version. While it is relatively maintained for security, it will"
+ ewarn "cause issues for sites/features designed with a newer version in mind."
+ fi
+}