summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2022-11-20 12:02:27 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2022-11-20 12:03:08 +0100
commitd97b8662a04fac7755d460d90fcf3d91b8669f60 (patch)
treeafc8941cb9e7e06629657f9cca0350867c0c0d02
parentapp-emulation/virtualbox: drop `opus` flag (diff)
downloadgentoo-d97b8662a04fac7755d460d90fcf3d91b8669f60.tar.gz
gentoo-d97b8662a04fac7755d460d90fcf3d91b8669f60.tar.bz2
gentoo-d97b8662a04fac7755d460d90fcf3d91b8669f60.zip
net-wireless/gr-scopy: Add gr-3.10 support
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
-rw-r--r--net-wireless/gr-scopy/Manifest1
-rw-r--r--net-wireless/gr-scopy/gr-scopy-0.0_p20220602.ebuild36
-rw-r--r--net-wireless/gr-scopy/gr-scopy-9999.ebuild9
3 files changed, 42 insertions, 4 deletions
diff --git a/net-wireless/gr-scopy/Manifest b/net-wireless/gr-scopy/Manifest
index bac2b331b822..624db6f795f1 100644
--- a/net-wireless/gr-scopy/Manifest
+++ b/net-wireless/gr-scopy/Manifest
@@ -1 +1,2 @@
DIST gr-scopy-0.0_p20201005.tar.gz 204034 BLAKE2B 17d797822c7920186a6d875119d582fda7b74f9c23248d9821ba172f59b1df1433520e723e4dc6b1eca1f08fb7256893767794b584d7c0bd53aa2ede80cd2b92 SHA512 12c0e76008b0a7570a85707afe28a102541e02f10a55346c76cb7984e8435e20281e6406c86ee22e8b4fbe0211bb6657f88f36bdf6b3b76d4e24b2a3f12e6350
+DIST gr-scopy-0.0_p20220602.tar.gz 213557 BLAKE2B 9dcd1b1beb62fa8f18c478f8990339cbe064a6c60c2e68516f49634d838f42559f2b25527fed78b124b9373be5f9c475c66a4dcc57ea30e69127e7227220742f SHA512 28983f1380943b1cc02c34fe21c7f295e5d4bbf4611fdddc313b9f63624845485a8366bcae6e215d9fe228a51f004d051895af756b157d382c6da2f51a1ca432
diff --git a/net-wireless/gr-scopy/gr-scopy-0.0_p20220602.ebuild b/net-wireless/gr-scopy/gr-scopy-0.0_p20220602.ebuild
new file mode 100644
index 000000000000..0ad510927c21
--- /dev/null
+++ b/net-wireless/gr-scopy/gr-scopy-0.0_p20220602.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="Scopy IIO blocks for GNU Radio"
+HOMEPAGE="https://github.com/analogdevicesinc/gr-scopy"
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/analogdevicesinc/gr-scopy.git"
+ EGIT_BRANCH="3.10"
+ inherit git-r3
+else
+ COMMIT="a69ccb22578621a69acc187fc0d006b5a030a744"
+ SRC_URI="https://github.com/analogdevicesinc/gr-scopy/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ >=net-wireless/gnuradio-3.9.0.0:=[analog]
+ sci-libs/volk:=
+ "
+DEPEND="${RDEPEND}"
+
+src_install() {
+ cmake_src_install
+ python_optimize
+ mv "${ED}/usr/share/doc/${PN}" "${ED}/usr/share/doc/${P}"
+}
diff --git a/net-wireless/gr-scopy/gr-scopy-9999.ebuild b/net-wireless/gr-scopy/gr-scopy-9999.ebuild
index f633fe307051..0ad510927c21 100644
--- a/net-wireless/gr-scopy/gr-scopy-9999.ebuild
+++ b/net-wireless/gr-scopy/gr-scopy-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9,10} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit cmake python-single-r1
@@ -11,9 +11,10 @@ DESCRIPTION="Scopy IIO blocks for GNU Radio"
HOMEPAGE="https://github.com/analogdevicesinc/gr-scopy"
if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="https://github.com/analogdevicesinc/gr-scopy.git"
+ EGIT_BRANCH="3.10"
inherit git-r3
else
- COMMIT="f48b45cabe2a81f491137dbc220032ea65f080c3"
+ COMMIT="a69ccb22578621a69acc187fc0d006b5a030a744"
SRC_URI="https://github.com/analogdevicesinc/gr-scopy/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${COMMIT}"
KEYWORDS="~amd64 ~x86"
@@ -23,13 +24,13 @@ SLOT="0"
REQUIRED_USE=${PYTHON_REQUIRED_USE}
RDEPEND="${PYTHON_DEPS}
- =net-wireless/gnuradio-3.8*:=
+ >=net-wireless/gnuradio-3.9.0.0:=[analog]
sci-libs/volk:=
- dev-libs/log4cpp:=
"
DEPEND="${RDEPEND}"
src_install() {
cmake_src_install
python_optimize
+ mv "${ED}/usr/share/doc/${PN}" "${ED}/usr/share/doc/${P}"
}