summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-29 07:08:51 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-29 07:51:22 +0200
commitd97bf68fc63ebfa00a668873e78e5125f8ce259d (patch)
tree51ab3d2b7ca5a7bd01a5b3d572b274b56e191df1
parentdev-python/botocore: Bump to 1.21.9 (diff)
downloadgentoo-d97bf68f.tar.gz
gentoo-d97bf68f.tar.bz2
gentoo-d97bf68f.zip
dev-python/boto3: Bump to 1.18.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.18.9.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 6999118add2e..099fa77d7d7b 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -9,3 +9,4 @@ DIST boto3-1.18.5.tar.gz 394930 BLAKE2B a7f58699a4a27c85f00f47eb34d861509446d159
DIST boto3-1.18.6.tar.gz 394941 BLAKE2B c7ef6f85fea5a12c248afd03cbe5cca2475c32de0d5b90e8390837e4e1980390e07bc99b6dd1e1831c34135503fe5859e0a837e0aff88f7af2bd8ddcad804a1d SHA512 01cdc6e71b8cd04da7e6f2bf9268625824c12b53fc7322343ae635d5fdd6ed30170fb698d7c4a788b4095fbfc186ef72a11fb6f785a1006fe7861d2db6108da9
DIST boto3-1.18.7.tar.gz 395640 BLAKE2B 6a9fa1dd55644806fe93271805f35fbe0c4cb65d1de08dded2d2f57fcefa96e32c4ebe7b60743c52c0898222bc06d33dbd03d304bbef327b88022450a7943e2c SHA512 20e7fedab7d061ab02f391e9baf36cb554e7f194f38d24d5a75f76715b2acf1b51b6adce5d8cf5a2a0d29df73566db00b8813a219d45a194d9a8eb93d0dab570
DIST boto3-1.18.8.tar.gz 397295 BLAKE2B 34e4e9dbaf53d7e9917b26f62385a012663147bcebe3a3989f3e306ed1bad8fc90c47ecd0901e127ad024f67d6891e3eb2b2f59e179ca45fe88b5cca6968bbef SHA512 59ea0cb50058fde12f748b394b9ba7053755c642d6124343a6fe00d8c7918f123b508441006c5a9ebc6319d4318f7f95c481cca47d692349c4591958c38d53c7
+DIST boto3-1.18.9.tar.gz 397452 BLAKE2B 1a600eb067baebb59141f1e8cb15442d7fa338430534099df84b8b71f6fd90a56aa5ead0c38ba317018897861f996ce38cf995233778ad57e3be82e82870173b SHA512 12d2b8a1baa9993be322b770a13a8895718bd25c6d4a51bdef39413368c9ba62fdc93e4f517d3556e5d6a26e860b21f1bdd1ee6b0f49c83082973ee716d3017c
diff --git a/dev-python/boto3/boto3-1.18.9.ebuild b/dev-python/boto3/boto3-1.18.9.ebuild
new file mode 100644
index 000000000000..819e73691110
--- /dev/null
+++ b/dev-python/boto3/boto3-1.18.9.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ ||
+ die "test failed under ${EPYTHON}"
+}