summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-08-24 02:51:31 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-08-24 03:26:06 +0200
commitd981d84d9ed6c270bde7e53b0f605187fd441a6b (patch)
tree87214de612227ad9f6bbf8e02bd88bea67bf0ab1
parentapp-emacs/geiser: bump to 0.25.1 (diff)
downloadgentoo-d981d84d.tar.gz
gentoo-d981d84d.tar.bz2
gentoo-d981d84d.zip
dev-ml/ocamlbuild: bump to 0.14.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-ml/ocamlbuild/Manifest1
-rw-r--r--dev-ml/ocamlbuild/ocamlbuild-0.14.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-ml/ocamlbuild/Manifest b/dev-ml/ocamlbuild/Manifest
index bda5a1b64c33..654742222d98 100644
--- a/dev-ml/ocamlbuild/Manifest
+++ b/dev-ml/ocamlbuild/Manifest
@@ -1,2 +1,3 @@
DIST ocamlbuild-0.11.0.tar.gz 195297 BLAKE2B 2d653c402edf58035fa6efb65c99c956fe78efc4759f29c8ddab8263310a5d243d25d37d4c1a4f0699f151afb6d4c6df4c1550f95d6e915963b3d86923877225 SHA512 14bc44cc63b6c99e711658a1145247bad8263632fbb4550238cef15e226a76b83e51b83575a7a96f16b96ec321dedd0ef23f36166c354838aec1922f58179efd
DIST ocamlbuild-0.14.0.tar.gz 198267 BLAKE2B 355d61ba68e61b9ee18a9fc0fbb9062405f44707b180ca7ad4bfec727ca3d3d2cc08f17be118ca3a4161c7789d975e7f431812e9139d4fde85a1a27ab68c8ac3 SHA512 ae60247396399dfd35644c8c1986ef7679e5a9964df82e3388bfc6dd4c5b88a13d6869a698d14a9ac70dc48e4ce1c003f543c85426d8c862ca31dea37a554b07
+DIST ocamlbuild-0.14.1.tar.gz 199103 BLAKE2B e29d5cf2b333dd45c0aa86cc1fa4ddb160079b8a7badfe6127039d9215d3e6ad655eeacc9410887eadf1d61615025a59ea008254cae5fd65c13eb2afc7937ec8 SHA512 1f5b43215b1d3dc427b9c64e005add9d423ed4bca9686d52c55912df8955647cb2d7d86622d44b41b14c4f0d657b770c27967c541c868eeb7c78e3bd35b827ad
diff --git a/dev-ml/ocamlbuild/ocamlbuild-0.14.1.ebuild b/dev-ml/ocamlbuild/ocamlbuild-0.14.1.ebuild
new file mode 100644
index 000000000000..d401b427c72a
--- /dev/null
+++ b/dev-ml/ocamlbuild/ocamlbuild-0.14.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Generic build tool with built-in rules for building OCaml library and programs"
+HOMEPAGE="https://github.com/ocaml/ocamlbuild"
+SRC_URI="https://github.com/ocaml/ocamlbuild/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( ocamlopt )"
+
+RDEPEND=">=dev-lang/ocaml-4.02.3-r1:=[ocamlopt?]"
+DEPEND="${RDEPEND}
+ dev-ml/findlib"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.14.0-Disable-tests-failing-with-OCaml-4.08.0.patch
+)
+
+QA_FLAGS_IGNORED='.*'
+src_prepare() {
+ sed -i \
+ -e "/package_exists/s:camlp4.macro:xxxxxx:" \
+ -e "/package_exists/s:menhirLib:xxxxxx:" \
+ testsuite/external.ml || die
+ default
+}
+
+src_configure() {
+ emake -f configure.make Makefile.config \
+ PREFIX="${EPREFIX}/usr" \
+ BINDIR="${EPREFIX}/usr/bin" \
+ LIBDIR="$(ocamlc -where)" \
+ OCAML_NATIVE=$(usex ocamlopt true false) \
+ OCAML_NATIVE_TOOLS=$(usex ocamlopt true false) \
+ NATDYNLINK=$(usex ocamlopt true false)
+}
+
+src_compile() {
+ emake src/ocamlbuild_config.cmo
+ default
+}
+
+src_install() {
+ emake CHECK_IF_PREINSTALLED=false DESTDIR="${D}" install
+ dodoc Changes
+}