summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-06-30 09:03:38 +0200
committerUlrich Müller <ulm@gentoo.org>2022-06-30 09:04:52 +0200
commitd98cbfb414bf24f758b06f334ce1744847dc31b5 (patch)
tree072665815f80e1d283d5245129d409728086d056
parentapp-editors/nano: Don't warn when we're replaced by another version (diff)
downloadgentoo-d98cbfb4.tar.gz
gentoo-d98cbfb4.tar.bz2
gentoo-d98cbfb4.zip
app-editors/nano: Sync live ebuild
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--app-editors/nano/nano-9999.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/app-editors/nano/nano-9999.ebuild b/app-editors/nano/nano-9999.ebuild
index 25ad3e614940..c2da47a585b9 100644
--- a/app-editors/nano/nano-9999.ebuild
+++ b/app-editors/nano/nano-9999.ebuild
@@ -91,3 +91,13 @@ src_install() {
use split-usr && dosym ../../bin/nano /usr/bin/nano
}
+
+pkg_postrm() {
+ local e
+ [[ -n ${REPLACED_BY_VERSION} ]] && return
+ e=$(unset EDITOR; . "${EROOT}"/etc/profile &>/dev/null; echo "${EDITOR}")
+ if [[ ${e##*/} == nano ]]; then
+ ewarn "The EDITOR variable is still set to ${e}."
+ ewarn "You can update it with \"eselect editor\"."
+ fi
+}