summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2021-09-24 13:33:47 -0400
committerAnthony G. Basile <blueness@gentoo.org>2021-09-24 13:34:01 -0400
commitd9d0f3734e4b5ef86a4d287baae4ce4519f9b7a4 (patch)
treed183450684ea11f11684252df372d321d7e2117a
parentnet-im/telegram-desktop: Bump to 3.1.0 (diff)
downloadgentoo-d9d0f373.tar.gz
gentoo-d9d0f373.tar.bz2
gentoo-d9d0f373.zip
www-servers/varnish: version bump to 7.0.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--www-servers/varnish/Manifest1
-rw-r--r--www-servers/varnish/varnish-7.0.0.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/www-servers/varnish/Manifest b/www-servers/varnish/Manifest
index 439384ec9520..eca4f04b43e6 100644
--- a/www-servers/varnish/Manifest
+++ b/www-servers/varnish/Manifest
@@ -1,2 +1,3 @@
DIST varnish-6.5.2.tgz 3464372 BLAKE2B 68a7bca159ed9539126f66d21450c87780b49b66a2d45a5abc7db6fe9d68c8526aa059546fb1d865de753736793e700611f4f110edb1c649f4e9753c4dfedacc SHA512 31673eaa95e5d3413cd3a4a6fb324c1f0ad2efb22b75409fc0e02c61446787eb167bd530ee5b0a199da4fc76cc36f3603984d86781f856cc6a4aac48260fe4ef
DIST varnish-6.6.1.tgz 3518308 BLAKE2B 6a88165394c0578427de20588ac2c17f502242bf94f30e9284f7bc2c271b77c3d6511a9dfb8d1cb6d75e1fc4563360fb0bec762aa17481fa598cb5e9d9527705 SHA512 af3ee1743af2ede2d3efbb73e5aa9b42c7bbd5f86163ec338c8afd1989c3e51ff3e1b40bed6b72224b5d339a74f22d6e5f3c3faf2fedee8ab4715307ed5d871b
+DIST varnish-7.0.0.tgz 3721912 BLAKE2B 872b9526a252ad5b3c1388363e3aedd68772a87dc2459dd25455c0c694f2c8b5a7897c8627183a92a8cdde10a8288084e8de88e87d329710290c49e2da538277 SHA512 39c694db4ec7b35236d12fe2c03036260d6799395b1c8bb5a58e96fc88d67dcaa5eb8bc75643540d3aa0edc1a8924d7d839e88293b0521fadef4cd12f466fb4b
diff --git a/www-servers/varnish/varnish-7.0.0.ebuild b/www-servers/varnish/varnish-7.0.0.ebuild
new file mode 100644
index 000000000000..cbc2e0eb6a25
--- /dev/null
+++ b/www-servers/varnish/varnish-7.0.0.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit autotools systemd python-r1
+
+DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator"
+HOMEPAGE="https://varnish-cache.org/"
+SRC_URI="http://varnish-cache.org/_downloads/${P}.tgz"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="jemalloc jit static-libs"
+
+CDEPEND="
+ sys-libs/readline:0=
+ dev-libs/libpcre[jit?]
+ jemalloc? ( dev-libs/jemalloc )
+ sys-libs/ncurses:0="
+
+#varnish compiles stuff at run time
+RDEPEND="
+ ${PYTHON_DEPS}
+ ${CDEPEND}
+ acct-user/varnish
+ acct-group/varnish
+ sys-devel/gcc"
+
+DEPEND="
+ ${CDEPEND}
+ dev-python/docutils
+ dev-python/sphinx
+ virtual/pkgconfig"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="test" #315725
+
+src_prepare() {
+ # Remove -Werror bug #528354
+ sed -i -e 's/-Werror\([^=]\)/\1/g' configure.ac
+
+ # Upstream doesn't put varnish.m4 in the m4/ directory
+ # We link because the Makefiles look for the file in
+ # the original location
+ ln -sf ../varnish.m4 m4/varnish.m4
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable jit pcre2-jit)
+ $(use_with jemalloc)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ python_replicate_script "${D}/usr/share/varnish/vmodtool.py"
+
+ newinitd "${FILESDIR}"/varnishlog.initd varnishlog
+ newconfd "${FILESDIR}"/varnishlog.confd varnishlog
+
+ newinitd "${FILESDIR}"/varnishncsa.initd varnishncsa
+ newconfd "${FILESDIR}"/varnishncsa.confd varnishncsa
+
+ newinitd "${FILESDIR}"/varnishd.initd-r4 varnishd
+ newconfd "${FILESDIR}"/varnishd.confd-r4 varnishd
+
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}/varnishd.logrotate-r2" varnishd
+
+ diropts -m750
+
+ keepdir /var/lib/varnish
+ keepdir /var/log/varnish
+
+ systemd_dounit "${FILESDIR}/${PN}d.service"
+
+ insinto /etc/varnish/
+ doins vmod/vmod_*.vcc
+ doins etc/example.vcl
+
+ dodoc README.rst
+ dodoc doc/changes.rst
+
+ fowners root:varnish /etc/varnish/
+ fowners varnish:varnish /var/lib/varnish/
+ fperms 0750 /var/lib/varnish/ /etc/varnish/
+}