summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-13 07:16:12 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-13 08:57:33 +0200
commitd9f9e8c0d683180ef88b7d078db4bc6e579d9a43 (patch)
tree6ffef2000bb1c794afa5b5b4cd0588fbddd5bb75
parentdev-python/awxkit: Bump to 19.3.0 (diff)
downloadgentoo-d9f9e8c0d683180ef88b7d078db4bc6e579d9a43.tar.gz
gentoo-d9f9e8c0d683180ef88b7d078db4bc6e579d9a43.tar.bz2
gentoo-d9f9e8c0d683180ef88b7d078db4bc6e579d9a43.zip
dev-python/trustme: Bump to 0.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/trustme/Manifest1
-rw-r--r--dev-python/trustme/trustme-0.9.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/trustme/Manifest b/dev-python/trustme/Manifest
index 34e9d7e6c9ce..38df5b00f115 100644
--- a/dev-python/trustme/Manifest
+++ b/dev-python/trustme/Manifest
@@ -1 +1,2 @@
DIST trustme-0.8.0.tar.gz 29046 BLAKE2B 5f2dd542974466dd8e61fa0ba5cd78e824afd243dd3b27ca21aec4ba4905daaa0c46db8f4edb30dcb483acf44758d7ad8de4db9c3e07a05d4d3d084565722def SHA512 93b1007319f7d625410eddf92910607c8190533f9bb02a71ecc4c424e44ecea70749f6bceb917297241e179b0d50ce1ed330c208cf3de77d4d3a619f5436af9d
+DIST trustme-0.9.0.tar.gz 30081 BLAKE2B 5623fba91f07027032f48ee355b5c4f853518bc6a5c1e93b4ea387ff25838302efa42476db8eb64e364980805aa1c3be97f827260efc31ffb536c53fe30ba988 SHA512 f0d983a4c52374f178c0bf96f758fdb5f132e7f7c4bac187c84fbc8dc82dc36d6c801c340bf8871e872178f7b2ac66d6159b5462d073beec9a13a086f64b58b7
diff --git a/dev-python/trustme/trustme-0.9.0.ebuild b/dev-python/trustme/trustme-0.9.0.ebuild
new file mode 100644
index 000000000000..3f23c392ed2b
--- /dev/null
+++ b/dev-python/trustme/trustme-0.9.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="#1 quality TLS certs while you wait, for the discerning tester"
+HOMEPAGE="https://github.com/python-trio/trustme"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/service_identity[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest