summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-07-26 23:52:04 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-07-26 23:57:40 +0200
commitd9fd0bf6484fc0336ff983b31155d5e17fc55905 (patch)
treea16f3363e26011b41c4fe053238706583b0dbe1d
parentx11-misc/sddm: amd64 stable wrt bug #661510 (diff)
downloadgentoo-d9fd0bf6.tar.gz
gentoo-d9fd0bf6.tar.bz2
gentoo-d9fd0bf6.zip
dev-python/inflect: bump to 1.0.0, introduces new dependencies
Package-Manager: Portage-2.3.43, Repoman-2.3.10
-rw-r--r--dev-python/inflect/Manifest1
-rw-r--r--dev-python/inflect/inflect-1.0.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/inflect/Manifest b/dev-python/inflect/Manifest
index c481e1861e27..97de70ea7d26 100644
--- a/dev-python/inflect/Manifest
+++ b/dev-python/inflect/Manifest
@@ -1,2 +1,3 @@
DIST inflect-0.2.5.tar.gz 109756 BLAKE2B ecb64b0fea04602f112dfba11ade6828eae7a7f3f44d4c4fb15c2300ac18025ea4c51f9c36aae5e7e92bd09e24d08091ce096b888a520fd2d4c40374356333d5 SHA512 68371158ac90d9662c19657cbf697f44ee9ceac090286d53e29ee04252efbb7d0bfbd99ae6847e6eec1991ef4ef670eff60693d1f0a301885bab2a09c7ce4616
DIST inflect-0.3.1.tar.gz 109456 BLAKE2B b57009a933f49762da315c55950ca20ad04a53559b1bd1fb7d8395bf4bfbb74b618eb1a0d0a0ca0f2b64adde93665fdf1f643f56299820ffe0c56a20f57237dc SHA512 c832f0f36b56f5f59d8c3a7c0b128c0ae00f7a90c57f303e79a2118657ee7b62ed3db7cd4c3297e41a07c4d2bdbc18d6c754c319a43004af6d35cab3701169a6
+DIST inflect-1.0.0.tar.gz 110186 BLAKE2B c9a47237e7fabfbbf512c3c88632e910e1bdc2f6b370f0224f1ae775a63de75c0c5ab25385b44786e349fb7243ef5d22f22d9001dec3c1a6adde3112551bdcb5 SHA512 7a82789ebd3db279589844752ab4e6c99a664ad5058778a9049d484c63a391c7e6623e80c07ca6a4845971062a496cb3062e7fc94607c5843b99a92860708b90
diff --git a/dev-python/inflect/inflect-1.0.0.ebuild b/dev-python/inflect/inflect-1.0.0.ebuild
new file mode 100644
index 000000000000..bf150255a033
--- /dev/null
+++ b/dev-python/inflect/inflect-1.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Correctly inflect words and numbers"
+HOMEPAGE="https://github.com/jazzband/inflect"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests -v tests || die "tests failed with ${EPYTHON}"
+}