summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-01-02 11:08:18 +0100
committerPacho Ramos <pacho@gentoo.org>2023-01-02 11:08:18 +0100
commitda225ddca5968b2eda74b4f5609a75904dd8a8bd (patch)
tree272144d3e5ec89f249e364ea707b1a569cc5774a
parentsys-power/switcheroo-control: Add missing dep (diff)
downloadgentoo-da225ddc.tar.gz
gentoo-da225ddc.tar.bz2
gentoo-da225ddc.zip
gnome-base/nautilus: Apply some upstream fixes
One to drop shotcuts for a functionality not available on 43.x and the other to fix maximized state not being remembered. Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--gnome-base/nautilus/files/43.1-maximized-signal.patch34
-rw-r--r--gnome-base/nautilus/files/43.1-treeview-shortcuts.patch41
-rw-r--r--gnome-base/nautilus/nautilus-43.1-r1.ebuild122
3 files changed, 197 insertions, 0 deletions
diff --git a/gnome-base/nautilus/files/43.1-maximized-signal.patch b/gnome-base/nautilus/files/43.1-maximized-signal.patch
new file mode 100644
index 000000000000..2a333bd86687
--- /dev/null
+++ b/gnome-base/nautilus/files/43.1-maximized-signal.patch
@@ -0,0 +1,34 @@
+From d4061be4c72b952f1c20ec770f910ee311850478 Mon Sep 17 00:00:00 2001
+From: Gary Li <gary.li1@uwaterloo.ca>
+Date: Wed, 28 Dec 2022 22:19:57 +0000
+Subject: [PATCH] nautilus-window: Fix window maximized notify signal
+
+Nautilus does not persist the window maximized state.
+
+This is because we are listening to the property is-maximized for
+change, which is now maximized in GTK4.
+https://docs.gtk.org/gtk4/property.Window.maximized.html
+
+Use notify::maximized instead of notify::is-maximized.
+
+Fixes: https://gitlab.gnome.org/GNOME/nautilus/-/issues/2682
+---
+ src/nautilus-window.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/nautilus-window.c b/src/nautilus-window.c
+index 7cd980d987..092afcbbd2 100644
+--- a/src/nautilus-window.c
++++ b/src/nautilus-window.c
+@@ -2084,7 +2084,7 @@ nautilus_window_init (NautilusWindow *window)
+ window,
+ G_CONNECT_SWAPPED);
+
+- g_signal_connect (window, "notify::is-maximized",
++ g_signal_connect (window, "notify::maximized",
+ G_CALLBACK (on_is_maximized_changed), NULL);
+
+ window->slots = NULL;
+--
+GitLab
+
diff --git a/gnome-base/nautilus/files/43.1-treeview-shortcuts.patch b/gnome-base/nautilus/files/43.1-treeview-shortcuts.patch
new file mode 100644
index 000000000000..206c1c6d9b81
--- /dev/null
+++ b/gnome-base/nautilus/files/43.1-treeview-shortcuts.patch
@@ -0,0 +1,41 @@
+From 98e34a4215f24a2414ca34a65804c86b8e4405c8 Mon Sep 17 00:00:00 2001
+From: Peter Eisenmann <p3732@getgoogleoff.me>
+Date: Wed, 30 Nov 2022 02:40:17 +0100
+Subject: [PATCH] help-overlay: drop tree view shortcuts
+
+Expanding folders in list view is not implemented in version 43. This
+removes the shortcuts from the keyboard shortcut help view.
+
+Fixes #2674
+---
+ src/resources/gtk/help-overlay.ui | 14 --------------
+ 1 file changed, 14 deletions(-)
+
+diff --git a/src/resources/gtk/help-overlay.ui b/src/resources/gtk/help-overlay.ui
+index 27e5906b6e..42bad9ffd1 100644
+--- a/src/resources/gtk/help-overlay.ui
++++ b/src/resources/gtk/help-overlay.ui
+@@ -301,20 +301,6 @@
+ <property name="accelerator">&lt;Primary&gt;2</property>
+ </object>
+ </child>
+- <child>
+- <object class="GtkShortcutsShortcut">
+- <property name="visible">True</property>
+- <property name="title" translatable="yes" context="shortcut window">Expand folder</property>
+- <property name="accelerator">Right</property>
+- </object>
+- </child>
+- <child>
+- <object class="GtkShortcutsShortcut">
+- <property name="visible">True</property>
+- <property name="title" translatable="yes" context="shortcut window">Collapse folder</property>
+- <property name="accelerator">Left</property>
+- </object>
+- </child>
+ </object>
+ </child>
+ <child>
+--
+GitLab
+
diff --git a/gnome-base/nautilus/nautilus-43.1-r1.ebuild b/gnome-base/nautilus/nautilus-43.1-r1.ebuild
new file mode 100644
index 000000000000..3a4480054434
--- /dev/null
+++ b/gnome-base/nautilus/nautilus-43.1-r1.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson readme.gentoo-r1 virtualx xdg
+
+DESCRIPTION="Default file manager for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Nautilus"
+
+LICENSE="GPL-3+ LGPL-2.1+"
+SLOT="0"
+IUSE="gnome +gstreamer gtk-doc +introspection +previewer selinux sendto"
+REQUIRED_USE="gtk-doc? ( introspection )"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.72.0:2
+ >=media-libs/gexiv2-0.14.0
+ >=x11-libs/gdk-pixbuf-2.30.0:2
+ gstreamer? ( media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0 )
+ >=app-arch/gnome-autoar-0.4.0
+ >=gnome-base/gnome-desktop-43:4=
+ >=gnome-base/gsettings-desktop-schemas-42
+ >=gui-libs/gtk-4.7.2:4[introspection?]
+ >=gui-libs/libadwaita-1.2:1
+ >=dev-libs/libportal-0.5:=[gtk]
+ >=x11-libs/pango-1.28.3
+ selinux? ( >=sys-libs/libselinux-2.0 )
+ >=app-misc/tracker-3.0:3
+ >=dev-libs/libxml2-2.7.8:2
+ >=net-libs/libcloudproviders-0.3.1
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+RDEPEND="${DEPEND}
+ >=app-misc/tracker-miners-3.0:3=
+" # uses org.freedesktop.Tracker.Miner.Files gsettings schema from tracker-miners
+BDEPEND="
+ >=dev-util/gdbus-codegen-2.51.2
+ dev-util/glib-utils
+ gtk-doc? (
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/gi-docgen
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+PDEPEND="
+ gnome? ( x11-themes/adwaita-icon-theme )
+ previewer? ( >=gnome-extra/sushi-0.1.9 )
+ sendto? ( >=gnome-extra/nautilus-sendto-3.0.1 )
+ >=gnome-base/gvfs-1.14[gtk(+)]
+" # Need gvfs[gtk] for recent:/// support; always built (without USE=gtk) since gvfs-1.34
+
+PATCHES=(
+ "${FILESDIR}"/43.0-docs-build.patch # Always install pregenerated manpage, keeping docs option for gtk-doc
+ "${FILESDIR}"/43.0-optional-gstreamer.patch # Allow controlling audio-video-properties build
+
+ # help-overlay: drop tree view shortcuts as they are not implemented
+ # in 43.x
+ "${FILESDIR}"/${PV}-treeview-shortcuts.patch
+
+ # nautilus-window: Fix window maximized notify signal
+ "${FILESDIR}"/43.1-maximized-signal.patch
+)
+
+src_prepare() {
+ default
+ xdg_environment_reset
+
+ if use previewer; then
+ DOC_CONTENTS="nautilus uses gnome-extra/sushi to preview media files.
+ To activate the previewer, select a file and press space; to
+ close the previewer, press space again."
+ fi
+
+ # Disable test-nautilus-search-engine-tracker; bug #831170
+ sed -e '/^tracker_tests = /{n;N;N;d}' -i test/automated/displayless/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc docs)
+ -Dextensions=true # image file properties, sendto support; also required for -Dgstreamer=true
+ $(meson_use gstreamer) # gstreamer audio-video-properties extension
+ $(meson_use introspection)
+ -Dpackagekit=false
+ $(meson_use selinux)
+ -Dprofiling=false
+ -Dtests=$(usex test all none)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ use previewer && readme.gentoo_create_doc
+ meson_src_install
+}
+
+src_test() {
+ gnome2_environment_reset # Avoid dconf that looks at XDG_DATA_DIRS, which can sandbox fail if flatpak is installed
+ # TODO: Tests require tracker testutils (e.g. tracker-sandbox), which may need some sorting out with tracker use flag deps
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if use previewer; then
+ readme.gentoo_print_elog
+ else
+ elog "To preview media files, emerge nautilus with USE=previewer"
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}