summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-08 20:28:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-08 20:29:10 +0200
commitda2f445a42895c1a47eeafda7340449c8b9bbe68 (patch)
treea85b3107c9e83e3a667794faa32b9360377ef67d
parentapp-misc/recoll: Version bump to 1.35.0 (diff)
downloadgentoo-da2f445a42895c1a47eeafda7340449c8b9bbe68.tar.gz
gentoo-da2f445a42895c1a47eeafda7340449c8b9bbe68.tar.bz2
gentoo-da2f445a42895c1a47eeafda7340449c8b9bbe68.zip
dev-lang/python: Correct dev-python/ensurepip-* dependencies
Make USE=ensurepip depend on dev-python/ensurepip-pip specifically since this is the only package that is actually required by ensurepip. Adjust test dependencies to include dev-python/ensurepip-setuptools and dev-python/ensurepip-wheel as well, as it is required by additional tests required by Python 3.12. Closes: https://bugs.gentoo.org/909151 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-lang/python/python-3.12.0_beta3.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-lang/python/python-3.12.0_beta3.ebuild b/dev-lang/python/python-3.12.0_beta3.ebuild
index a413c1ef6a6c..8c769c87e1b7 100644
--- a/dev-lang/python/python-3.12.0_beta3.ebuild
+++ b/dev-lang/python/python-3.12.0_beta3.ebuild
@@ -50,7 +50,7 @@ RDEPEND="
>=sys-libs/zlib-1.1.3:=
virtual/libcrypt:=
virtual/libintl
- ensurepip? ( dev-python/ensurepip-wheels )
+ ensurepip? ( dev-python/ensurepip-pip )
gdbm? ( sys-libs/gdbm:=[berkdb] )
kernel_linux? ( sys-apps/util-linux:= )
ncurses? ( >=sys-libs/ncurses-5.2:= )
@@ -73,7 +73,9 @@ DEPEND="
bluetooth? ( net-wireless/bluez )
test? (
app-arch/xz-utils[extra-filters(+)]
- dev-python/ensurepip-wheels
+ dev-python/ensurepip-pip
+ dev-python/ensurepip-setuptools
+ dev-python/ensurepip-wheel
)
valgrind? ( dev-util/valgrind )
"