summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-10-08 11:39:27 +0200
committerPacho Ramos <pacho@gentoo.org>2016-10-08 11:51:01 +0200
commitda3abb401fe23d5d5ce5451eda37ac36112c8683 (patch)
tree6bc727c3d130c5250c838789809896ef6cd68e97
parentmedia-gfx/shotwell: Drop old (diff)
downloadgentoo-da3abb401fe23d5d5ce5451eda37ac36112c8683.tar.gz
gentoo-da3abb401fe23d5d5ce5451eda37ac36112c8683.tar.bz2
gentoo-da3abb401fe23d5d5ce5451eda37ac36112c8683.zip
media-gfx/shotwell: Version bump
Package-Manager: portage-2.3.1
-rw-r--r--media-gfx/shotwell/Manifest1
-rw-r--r--media-gfx/shotwell/shotwell-0.24.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/media-gfx/shotwell/Manifest b/media-gfx/shotwell/Manifest
index bc63ee1aa322..995f2b2905e7 100644
--- a/media-gfx/shotwell/Manifest
+++ b/media-gfx/shotwell/Manifest
@@ -1 +1,2 @@
DIST shotwell-0.23.7.tar.xz 5348360 SHA256 daa627aa69f17b1b9bef4ad5d4813c32e9a05f5b5aa2762b4f91d837ed14c7aa SHA512 b3d80d01ec5ac2f3245512926302e6b5e4e1d468e98d7567ec8788d35bdc9ecc839b43eca1a2fa2333deb047c760d165e2f2a9913951f0bcbbcd6404927374dc WHIRLPOOL 6ff8722f7d4007c37d6b7e1da388dd28853921f8e5740f3ac6dd4e70cdc7fe0eafdc889a4c8493948c4643f409847f34c6e915d0b79b4f9039298de8f671d4aa
+DIST shotwell-0.24.0.tar.xz 5344220 SHA256 95d60e30b52c5f8a9633c98cbbcd1ad0889fe94b7a036bb4880450fa6d44fe75 SHA512 151ba94b429e41f6ff7085dbecf008679e4522b5be19577a914996e11636ba67ceba978f8b223dd562014bbacefad4bdc1c477e660352c4a963a3c80794b7e32 WHIRLPOOL 79ad5052d2fd0ed095be010df061f63b7dab1f118386a659d908df38f884413266d44dca4a670051b9847a6646877c0b419c4dd0938985ffb5bc23cea8310dae
diff --git a/media-gfx/shotwell/shotwell-0.24.0.ebuild b/media-gfx/shotwell/shotwell-0.24.0.ebuild
new file mode 100644
index 000000000000..e178d0cae95b
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.24.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+VALA_MIN_API_VERSION="0.28"
+
+inherit gnome2 multilib toolchain-funcs vala versionator
+
+MY_PV=$(get_version_component_range 1-2)
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Shotwell"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ app-text/gnome-doc-utils
+ >=dev-db/sqlite-3.5.9:3
+ >=dev-libs/glib-2.30.0:2
+ >=dev-libs/json-glib-0.7.6
+ >=dev-libs/libgee-0.8.5:0.8
+ >=dev-libs/libxml2-2.6.32:2
+ >=dev-util/desktop-file-utils-0.13
+ gnome-base/dconf
+ >=media-libs/gexiv2-0.4.90
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ media-libs/gstreamer:1.0
+ media-libs/lcms:2
+ >=media-libs/libexif-0.6.16:=
+ >=media-libs/libgphoto2-2.5:=
+ >=media-libs/libraw-0.13.2:=
+ >=net-libs/libsoup-2.26.0:2.4
+ net-libs/webkit-gtk:4
+ virtual/libgudev:=[introspection]
+ >=x11-libs/gtk+-3.12.2:3[X]
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.7
+ >=sys-devel/m4-1.4.13
+"
+
+# This probably comes from libraries that
+# shotwell-video-thumbnailer links to.
+# Nothing we can do at the moment. #435048
+QA_FLAGS_IGNORED="/usr/libexec/${PN}/${PN}-video-thumbnailer"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}