summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-18 18:04:15 +0100
committerSam James <sam@gentoo.org>2024-05-18 18:05:38 +0100
commitda661632dfc75ef84447f412afa96588e23f0f81 (patch)
treeabb8a65b140b5ed2974ba096a47cdc99f1985eaf
parentapp-arch/bzip2: drop 1.0.8-r4 (diff)
downloadgentoo-da661632dfc75ef84447f412afa96588e23f0f81.tar.gz
gentoo-da661632dfc75ef84447f412afa96588e23f0f81.tar.bz2
gentoo-da661632dfc75ef84447f412afa96588e23f0f81.zip
dev-debug/gdb: drop 13.2-r2, 14.1-r1
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-debug/gdb/Manifest2
-rw-r--r--dev-debug/gdb/files/gdb-13.2-fix-sparc-debugging.patch126
-rw-r--r--dev-debug/gdb/gdb-13.2-r2.ebuild314
-rw-r--r--dev-debug/gdb/gdb-14.1-r1.ebuild325
4 files changed, 0 insertions, 767 deletions
diff --git a/dev-debug/gdb/Manifest b/dev-debug/gdb/Manifest
index bc28a63793c7..81b93c4c69ae 100644
--- a/dev-debug/gdb/Manifest
+++ b/dev-debug/gdb/Manifest
@@ -1,3 +1 @@
-DIST gdb-13.2.tar.xz 23664644 BLAKE2B bf5216ba2286448a46f9e0a405367c5a678e6d7540204722d355b618018b7b75a2ebc5b51353304c5ded02a3979223a81781d305f5afa5be82516cdc2863d49f SHA512 8185d3e11ab60dafff5860a5016577bfe7dd7547ef01ebc867bc247603d82b74ff74c4f29492c7d2aee57076f52be33e289f4c6b414a4b870d4b3004909f4c34
-DIST gdb-14.1.tar.xz 24108624 BLAKE2B 52a07b4745f95561f360a597d6ec1d212dafc8e9134dc415cd7bcfb02c26934a60807c8400b545a756c68392e16e104178cdc1464430c53611973881e921a942 SHA512 575e198105076fc4a88f68591aa114ab9c1196e84386a3f7b9b58fe5f30cdeed33f6a5f957b68f08c47284ec922bb60c964627e238471419673fd913575ce427
DIST gdb-14.2.tar.xz 24111936 BLAKE2B 65765dfd1ed08e19bb881fc7ae98d6ee4914f38a9a2bb0d0ca73bef472669664f807fe9c04e8dffd7025be98e736ac52f88ff5851ceddbb01a361885b18befc8 SHA512 7e07941f1fe661288cc571b4964012ceabc1760624fce20320db2f470c01439b2386f859b5288da13204b758e2e3b22a74c68c012178db93b9529b06f1e22ede
diff --git a/dev-debug/gdb/files/gdb-13.2-fix-sparc-debugging.patch b/dev-debug/gdb/files/gdb-13.2-fix-sparc-debugging.patch
deleted file mode 100644
index 3d5201cd94e3..000000000000
--- a/dev-debug/gdb/files/gdb-13.2-fix-sparc-debugging.patch
+++ /dev/null
@@ -1,126 +0,0 @@
-https://sourceware.org/git/?p=binutils-gdb.git;a=commit;h=31a56a22c45d76df4c597439f337e3f75ac3065c
-https://sourceware.org/bugzilla/show_bug.cgi?id=30525
-https://bugs.gentoo.org/907906
-
-From 31a56a22c45d76df4c597439f337e3f75ac3065c Mon Sep 17 00:00:00 2001
-From: Pedro Alves <pedro@palves.net>
-Date: Wed, 7 Jun 2023 10:38:14 +0100
-Subject: [PATCH] Linux: Avoid pread64/pwrite64 for high memory addresses (PR
- gdb/30525)
-
-Since commit 05c06f318fd9 ("Linux: Access memory even if threads are
-running"), GDB prefers pread64/pwrite64 to access inferior memory
-instead of ptrace. That change broke reading shared libraries on
-SPARC64 Linux, as reported by PR gdb/30525 ("gdb cannot read shared
-libraries on SPARC64").
-
-On SPARC64 Linux, surprisingly (to me), userspace shared libraries are
-mapped at high 64-bit addresses:
-
- (gdb) info sharedlibrary
- Cannot access memory at address 0xfff80001002011e0
- Cannot access memory at address 0xfff80001002011d8
- Cannot access memory at address 0xfff80001002011d8
- From To Syms Read Shared Object Library
- 0xfff80001000010a0 0xfff8000100021f80 Yes (*) /lib64/ld-linux.so.2
- (*): Shared library is missing debugging information.
-
-Those addresses are 64-bit addresses with the high bits set. When
-interpreted as signed, they're negative.
-
-The Linux kernel rejects pread64/pwrite64 if the offset argument of
-type off_t (a signed type) is negative, which happens if the memory
-address we're accessing has its high bit set. See
-linux/fs/read_write.c sys_pread64 and sys_pwrite64 in Linux.
-
-Thankfully, lseek does not fail in that situation. So the fix is to
-use the 'lseek + read|write' path if the offset would be negative.
-
-Fix this in both native GDB and GDBserver.
-
-Tested on a SPARC64 GNU/Linux and x86-64 GNU/Linux.
-
-Bug: https://sourceware.org/bugzilla/show_bug.cgi?id=30525
-Change-Id: I79c724f918037ea67b7396fadb521bc9d1b10dc5
---- a/gdb/linux-nat.c
-+++ b/gdb/linux-nat.c
-@@ -3909,18 +3909,26 @@ linux_proc_xfer_memory_partial_fd (int fd, int pid,
-
- gdb_assert (fd != -1);
-
-- /* Use pread64/pwrite64 if available, since they save a syscall and can
-- handle 64-bit offsets even on 32-bit platforms (for instance, SPARC
-- debugging a SPARC64 application). */
-+ /* Use pread64/pwrite64 if available, since they save a syscall and
-+ can handle 64-bit offsets even on 32-bit platforms (for instance,
-+ SPARC debugging a SPARC64 application). But only use them if the
-+ offset isn't so high that when cast to off_t it'd be negative, as
-+ seen on SPARC64. pread64/pwrite64 outright reject such offsets.
-+ lseek does not. */
- #ifdef HAVE_PREAD64
-- ret = (readbuf ? pread64 (fd, readbuf, len, offset)
-- : pwrite64 (fd, writebuf, len, offset));
--#else
-- ret = lseek (fd, offset, SEEK_SET);
-- if (ret != -1)
-- ret = (readbuf ? read (fd, readbuf, len)
-- : write (fd, writebuf, len));
-+ if ((off_t) offset >= 0)
-+ ret = (readbuf != nullptr
-+ ? pread64 (fd, readbuf, len, offset)
-+ : pwrite64 (fd, writebuf, len, offset));
-+ else
- #endif
-+ {
-+ ret = lseek (fd, offset, SEEK_SET);
-+ if (ret != -1)
-+ ret = (readbuf != nullptr
-+ ? read (fd, readbuf, len)
-+ : write (fd, writebuf, len));
-+ }
-
- if (ret == -1)
- {
---- a/gdbserver/linux-low.cc
-+++ b/gdbserver/linux-low.cc
-@@ -5377,21 +5377,26 @@ proc_xfer_memory (CORE_ADDR memaddr, unsigned char *readbuf,
- {
- int bytes;
-
-- /* If pread64 is available, use it. It's faster if the kernel
-- supports it (only one syscall), and it's 64-bit safe even on
-- 32-bit platforms (for instance, SPARC debugging a SPARC64
-- application). */
-+ /* Use pread64/pwrite64 if available, since they save a syscall
-+ and can handle 64-bit offsets even on 32-bit platforms (for
-+ instance, SPARC debugging a SPARC64 application). But only
-+ use them if the offset isn't so high that when cast to off_t
-+ it'd be negative, as seen on SPARC64. pread64/pwrite64
-+ outright reject such offsets. lseek does not. */
- #ifdef HAVE_PREAD64
-- bytes = (readbuf != nullptr
-- ? pread64 (fd, readbuf, len, memaddr)
-- : pwrite64 (fd, writebuf, len, memaddr));
--#else
-- bytes = -1;
-- if (lseek (fd, memaddr, SEEK_SET) != -1)
-+ if ((off_t) memaddr >= 0)
- bytes = (readbuf != nullptr
-- ? read (fd, readbuf, len)
-- : write (fd, writebuf, len));
-+ ? pread64 (fd, readbuf, len, memaddr)
-+ : pwrite64 (fd, writebuf, len, memaddr));
-+ else
- #endif
-+ {
-+ bytes = -1;
-+ if (lseek (fd, memaddr, SEEK_SET) != -1)
-+ bytes = (readbuf != nullptr
-+ ? read (fd, readbuf, len)
-+ : write (fd, writebuf, len));
-+ }
-
- if (bytes < 0)
- return errno;
---
-2.39.3
diff --git a/dev-debug/gdb/gdb-13.2-r2.ebuild b/dev-debug/gdb/gdb-13.2-r2.ebuild
deleted file mode 100644
index 43890c7910aa..000000000000
--- a/dev-debug/gdb/gdb-13.2-r2.ebuild
+++ /dev/null
@@ -1,314 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# See https://sourceware.org/gdb/wiki/DistroAdvice for general packaging
-# tips & notes.
-
-PYTHON_COMPAT=( python3_{10..11} )
-inherit flag-o-matic python-single-r1 strip-linguas toolchain-funcs
-
-export CTARGET=${CTARGET:-${CHOST}}
-
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-is_cross() { [[ ${CHOST} != ${CTARGET} ]] ; }
-
-case ${PV} in
- 9999*)
- # live git tree
- EGIT_REPO_URI="https://sourceware.org/git/binutils-gdb.git"
- inherit git-r3
- SRC_URI=""
- ;;
- *.*.50_p2???????|*.*.90_p2???????)
- # Weekly snapshots
- MY_PV="${PV/_p/.}"
- SRC_URI="
- https://sourceware.org/pub/gdb/snapshots/branch/gdb-weekly-${MY_PV}.tar.xz
- https://sourceware.org/pub/gdb/snapshots/current/gdb-weekly-${MY_PV}.tar.xz
- https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/gdb-weekly-${MY_PV}.tar.xz
- "
- S="${WORKDIR}/${PN}-${MY_PV}"
-
- # e.g. 13.1.90_p20230325 is a snapshot on the stable branch, so it's fine
- if [[ ${PV} == *.[123456789].9?_p2??????? ]] ; then
- REGULAR_RELEASE=1
- fi
- ;;
- *.*.9?)
- # Prereleases
- MY_PV="${PV/_p/.}"
- SRC_URI="
- https://sourceware.org/pub/gdb/snapshots/branch/gdb-${MY_PV}.tar.xz
- https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/gdb-${MY_PV}.tar.xz
- "
- S="${WORKDIR}/${PN}-${MY_PV}"
- ;;
- *)
- # Normal upstream release
- SRC_URI="
- mirror://gnu/gdb/${P}.tar.xz
- https://sourceware.org/pub/gdb/releases/${P}.tar.xz
- "
-
- REGULAR_RELEASE=1
-esac
-
-PATCH_DEV=""
-PATCH_VER=""
-DESCRIPTION="GNU debugger"
-HOMEPAGE="https://sourceware.org/gdb/"
-SRC_URI="
- ${SRC_URI}
- ${PATCH_DEV:+https://dev.gentoo.org/~${PATCH_DEV}/distfiles/${CATEGORY}/${PN}/${P}-patches-${PATCH_VER}.tar.xz}
- ${PATCH_VER:+mirror://gentoo/${P}-patches-${PATCH_VER}.tar.xz}
-"
-
-LICENSE="GPL-3+ LGPL-2.1+"
-SLOT="0"
-IUSE="cet debuginfod guile lzma multitarget nls +python +server sim source-highlight test vanilla xml xxhash zstd"
-if [[ -n ${REGULAR_RELEASE} ]] ; then
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
-fi
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/mpfr:=
- dev-libs/gmp:=
- >=sys-libs/ncurses-5.2-r2:=
- >=sys-libs/readline-7:=
- sys-libs/zlib
- elibc_glibc? ( net-libs/libnsl:= )
- debuginfod? (
- dev-libs/elfutils[debuginfod(-)]
- )
- lzma? ( app-arch/xz-utils )
- python? ( ${PYTHON_DEPS} )
- guile? ( >=dev-scheme/guile-2.0 )
- xml? ( dev-libs/expat )
- source-highlight? (
- dev-util/source-highlight
- )
- xxhash? (
- dev-libs/xxhash
- )
- zstd? ( app-arch/zstd:= )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- app-arch/xz-utils
- sys-apps/texinfo
- app-alternatives/yacc
- nls? ( sys-devel/gettext )
- source-highlight? ( virtual/pkgconfig )
- test? ( dev-util/dejagnu )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-8.3.1-verbose-build.patch
- "${FILESDIR}"/${P}-fix-sparc-debugging.patch
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- strip-linguas -u bfd/po opcodes/po
-
- # Avoid using ancient termcap from host on Prefix systems
- sed -i -e 's/termcap tinfow/tinfow/g' \
- gdb/configure{.ac,} || die
-}
-
-gdb_branding() {
- printf "Gentoo ${PV} "
-
- if ! use vanilla && [[ -n ${PATCH_VER} ]] ; then
- printf "p${PATCH_VER}"
- else
- printf "vanilla"
- fi
-
- [[ -n ${EGIT_COMMIT} ]] && printf " ${EGIT_COMMIT}"
-}
-
-src_configure() {
- strip-unsupported-flags
-
- # https://sourceware.org/PR22395, bug #853898
- filter-lto
-
- # See https://www.gnu.org/software/make/manual/html_node/Parallel-Output.html
- # Avoid really confusing logs from subconfigure spam, makes logs far
- # more legible.
- MAKEOPTS="--output-sync=line ${MAKEOPTS}"
-
- local myconf=(
- # portage's econf() does not detect presence of --d-d-t
- # because it greps only top-level ./configure. But not
- # libiberty's or gdb's configure.
- --disable-dependency-tracking
- --disable-silent-rules
-
- --with-pkgversion="$(gdb_branding)"
- --with-bugurl='https://bugs.gentoo.org/'
- --disable-werror
- # Disable modules that are in a combined binutils/gdb tree. bug #490566
- --disable-{binutils,etc,gas,gold,gprof,gprofng,ld}
-
- $(use_with debuginfod)
-
- $(use_enable test unit-tests)
-
- # Allow user to opt into CET for host libraries.
- # Ideally we would like automagic-or-disabled here.
- # But the check does not quite work on i686: bug #760926.
- $(use_enable cet)
-
- # Helps when cross-compiling. Not to be confused with --with-sysroot.
- --with-build-sysroot="${ESYSROOT}"
- )
-
- is_cross && myconf+=(
- --with-sysroot="\${prefix}/${CTARGET}"
- --includedir="\${prefix}/include/${CTARGET}"
- --with-gdb-datadir="\${datadir}/gdb/${CTARGET}"
- )
-
- # gdbserver only works for native targets (CHOST==CTARGET).
- # it also doesn't support all targets, so rather than duplicate
- # the target list (which changes between versions), use the
- # "auto" value when things are turned on, which is triggered
- # whenever no --enable or --disable is given
- if is_cross || use !server ; then
- myconf+=( --disable-gdbserver )
- fi
-
- myconf+=(
- --enable-64-bit-bfd
- --disable-install-libbfd
- --disable-install-libiberty
- --enable-obsolete
- # This only disables building in the readline subdir.
- # For gdb itself, it'll use the system version.
- --disable-readline
- --with-system-readline
- # This only disables building in the zlib subdir.
- # For gdb itself, it'll use the system version.
- --without-zlib
- --with-system-zlib
- --with-separate-debug-dir="${EPREFIX}"/usr/lib/debug
- $(use_with xml expat)
- $(use_with lzma)
- $(use_enable nls)
- $(use_enable sim)
- $(use_enable source-highlight)
- $(use multitarget && echo --enable-targets=all)
- $(use_with python python "${EPYTHON}")
- $(use_with xxhash)
- $(use_with guile)
- $(use_with zstd)
-
- # Find libraries using the toolchain sysroot rather than the configured
- # prefix. Needed when cross-compiling.
- #
- # Check which libraries to apply this to with:
- # "${S}"/gdb/configure --help | grep without-lib | sort
- --without-lib{babeltrace,expat,gmp,iconv,ipt,lzma,mpfr,xxhash}-prefix
- )
-
- # source-highlight is detected with pkg-config: bug #716558
- export ac_cv_path_pkg_config_prog_path="$(tc-getPKG_CONFIG)"
-
- export CC_FOR_BUILD="$(tc-getBUILD_CC)"
-
- # ensure proper compiler is detected for Clang builds: bug #831202
- export GCC_FOR_TARGET="${CC_FOR_TARGET:-$(tc-getCC)}"
-
- econf "${myconf[@]}"
-}
-
-src_test() {
- # Run the unittests (nabbed invocation from Fedora's spec file) at least
- emake -k -C gdb run GDBFLAGS='-batch -ex "maintenance selftest"'
-
- # Too many failures
- # In fact, gdb's test suite needs some work to get passing.
- # See e.g. https://sourceware.org/gdb/wiki/TestingGDB.
- # As of 11.2, on amd64: "# of unexpected failures 8600"
- # Also, ia64 kernel crashes when gdb testsuite is running.
- #emake -k check
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- find "${ED}"/usr -name libiberty.a -delete || die
-
- # Delete translations that conflict with binutils-libs. bug #528088
- # Note: Should figure out how to store these in an internal gdb dir.
- if use nls ; then
- find "${ED}" \
- -regextype posix-extended -regex '.*/(bfd|opcodes)[.]g?mo$' \
- -delete || die
- fi
-
- # Don't install docs when building a cross-gdb
- if [[ ${CTARGET} != ${CHOST} ]] ; then
- rm -rf "${ED}"/usr/share/{doc,info,locale} || die
- local f
- for f in "${ED}"/usr/share/man/*/* ; do
- if [[ ${f##*/} != ${CTARGET}-* ]] ; then
- mv "${f}" "${f%/*}/${CTARGET}-${f##*/}" || die
- fi
- done
- return 0
- fi
-
- # Install it by hand for now:
- # https://sourceware.org/ml/gdb-patches/2011-12/msg00915.html
- # Only install if it exists due to the twisted behavior (see
- # notes in src_configure above).
- [[ -e gdbserver/gdbreplay ]] && dobin gdbserver/gdbreplay
-
- docinto gdb
- dodoc gdb/CONTRIBUTE gdb/README gdb/MAINTAINERS \
- gdb/NEWS gdb/PROBLEMS
- docinto sim
- dodoc sim/{MAINTAINERS,README-HACKING}
-
- if use server ; then
- docinto gdbserver
- dodoc gdbserver/README
- fi
-
- # Remove shared info pages
- rm -f "${ED}"/usr/share/info/{annotate,bfd,configure,ctf-spec,standards}.info*
-
- if use python ; then
- python_optimize "${ED}"/usr/share/gdb/python/gdb
- fi
-}
-
-pkg_postinst() {
- # Portage doesn't unmerge files in /etc
- rm -vf "${EROOT}"/etc/skel/.gdbinit
-
- if use prefix && [[ ${CHOST} == *-darwin* ]] ; then
- ewarn "gdb is unable to get a mach task port when installed by Prefix"
- ewarn "Portage, unprivileged. To make gdb fully functional you'll"
- ewarn "have to perform the following steps:"
- ewarn " % sudo chgrp procmod ${EPREFIX}/usr/bin/gdb"
- ewarn " % sudo chmod g+s ${EPREFIX}/usr/bin/gdb"
- fi
-}
diff --git a/dev-debug/gdb/gdb-14.1-r1.ebuild b/dev-debug/gdb/gdb-14.1-r1.ebuild
deleted file mode 100644
index 6894ea21be93..000000000000
--- a/dev-debug/gdb/gdb-14.1-r1.ebuild
+++ /dev/null
@@ -1,325 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# See https://sourceware.org/gdb/wiki/DistroAdvice for general packaging
-# tips & notes.
-
-PYTHON_COMPAT=( python3_{10..12} )
-inherit flag-o-matic python-single-r1 strip-linguas toolchain-funcs
-
-export CTARGET=${CTARGET:-${CHOST}}
-
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-is_cross() { [[ ${CHOST} != ${CTARGET} ]] ; }
-
-case ${PV} in
- 9999*)
- # live git tree
- EGIT_REPO_URI="https://sourceware.org/git/binutils-gdb.git"
- inherit git-r3
- SRC_URI=""
- ;;
- *.*.50_p2???????|*.*.90_p2???????)
- # Weekly snapshots
- MY_PV="${PV/_p/.}"
- SRC_URI="
- https://sourceware.org/pub/gdb/snapshots/branch/gdb-weekly-${MY_PV}.tar.xz
- https://sourceware.org/pub/gdb/snapshots/current/gdb-weekly-${MY_PV}.tar.xz
- https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/gdb-weekly-${MY_PV}.tar.xz
- "
- S="${WORKDIR}/${PN}-${MY_PV}"
-
- # e.g. 13.1.90_p20230325 is a snapshot on the stable branch, so it's fine
- if [[ ${PV} == *.[123456789].9?_p2??????? ]] ; then
- REGULAR_RELEASE=1
- fi
- ;;
- *.*.9?)
- # Prereleases
- MY_PV="${PV/_p/.}"
- SRC_URI="
- https://sourceware.org/pub/gdb/snapshots/branch/gdb-${MY_PV}.tar.xz
- https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/gdb-${MY_PV}.tar.xz
- "
- S="${WORKDIR}/${PN}-${MY_PV}"
- ;;
- *)
- # Normal upstream release
- SRC_URI="
- mirror://gnu/gdb/${P}.tar.xz
- https://sourceware.org/pub/gdb/releases/${P}.tar.xz
- "
-
- REGULAR_RELEASE=1
-esac
-
-PATCH_DEV=""
-PATCH_VER=""
-DESCRIPTION="GNU debugger"
-HOMEPAGE="https://sourceware.org/gdb/"
-SRC_URI="
- ${SRC_URI}
- ${PATCH_DEV:+https://dev.gentoo.org/~${PATCH_DEV}/distfiles/${CATEGORY}/${PN}/${P}-patches-${PATCH_VER}.tar.xz}
- ${PATCH_VER:+mirror://gentoo/${P}-patches-${PATCH_VER}.tar.xz}
-"
-
-LICENSE="GPL-3+ LGPL-2.1+"
-SLOT="0"
-IUSE="cet debuginfod guile lzma multitarget nls +python +server sim source-highlight test vanilla xml xxhash zstd"
-if [[ -n ${REGULAR_RELEASE} ]] ; then
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
-fi
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/mpfr:=
- dev-libs/gmp:=
- >=sys-libs/ncurses-5.2-r2:=
- >=sys-libs/readline-7:=
- sys-libs/zlib
- elibc_glibc? ( net-libs/libnsl:= )
- debuginfod? (
- dev-libs/elfutils[debuginfod(-)]
- )
- lzma? ( app-arch/xz-utils )
- python? ( ${PYTHON_DEPS} )
- guile? ( >=dev-scheme/guile-2.0 )
- xml? ( dev-libs/expat )
- source-highlight? (
- dev-util/source-highlight
- )
- xxhash? (
- dev-libs/xxhash
- )
- zstd? ( app-arch/zstd:= )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- app-arch/xz-utils
- sys-apps/texinfo
- app-alternatives/yacc
- nls? ( sys-devel/gettext )
- source-highlight? ( virtual/pkgconfig )
- test? ( dev-util/dejagnu )
-"
-
-QA_CONFIG_IMPL_DECL_SKIP=(
- MIN # gnulib FP (bug #898688)
-)
-
-PATCHES=(
- "${FILESDIR}"/${PN}-8.3.1-verbose-build.patch
- "${FILESDIR}"/${PN}-14.1-fix-list-segfault.patch
- "${FILESDIR}"/${PN}-14.1-fix-print-global-variable-stubs.patch
- "${FILESDIR}"/${PN}-14.1-fix-dll-export-forwarding.patch
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- strip-linguas -u bfd/po opcodes/po
-
- # Avoid using ancient termcap from host on Prefix systems
- sed -i -e 's/termcap tinfow/tinfow/g' \
- gdb/configure{.ac,} || die
- if [[ ${CHOST} == *-solaris* ]] ; then
- # code relies on C++11, so make sure we get that selected
- # due to Python 3.11 pymacro.h doing stuff to work around
- # versioning mess based on the C version, while we're compiling
- # C++ here, so we need to make it clear we're doing C++11/C11
- # because Solaris system headers act on these
- sed -i -e 's/-x c++/-std=c++11/' gdb/Makefile.in || die
- fi
-}
-
-gdb_branding() {
- printf "Gentoo ${PV} "
-
- if ! use vanilla && [[ -n ${PATCH_VER} ]] ; then
- printf "p${PATCH_VER}"
- else
- printf "vanilla"
- fi
-
- [[ -n ${EGIT_COMMIT} ]] && printf " ${EGIT_COMMIT}"
-}
-
-src_configure() {
- strip-unsupported-flags
-
- # See https://www.gnu.org/software/make/manual/html_node/Parallel-Output.html
- # Avoid really confusing logs from subconfigure spam, makes logs far
- # more legible.
- MAKEOPTS="--output-sync=line ${MAKEOPTS}"
-
- local myconf=(
- # portage's econf() does not detect presence of --d-d-t
- # because it greps only top-level ./configure. But not
- # libiberty's or gdb's configure.
- --disable-dependency-tracking
- --disable-silent-rules
-
- --with-pkgversion="$(gdb_branding)"
- --with-bugurl='https://bugs.gentoo.org/'
- --disable-werror
- # Disable modules that are in a combined binutils/gdb tree. bug #490566
- --disable-{binutils,etc,gas,gold,gprof,gprofng,ld}
-
- $(use_with debuginfod)
-
- $(use_enable test unit-tests)
-
- # Allow user to opt into CET for host libraries.
- # Ideally we would like automagic-or-disabled here.
- # But the check does not quite work on i686: bug #760926.
- $(use_enable cet)
-
- # Helps when cross-compiling. Not to be confused with --with-sysroot.
- --with-build-sysroot="${ESYSROOT}"
- )
-
- is_cross && myconf+=(
- --with-sysroot="\${prefix}/${CTARGET}"
- --includedir="\${prefix}/include/${CTARGET}"
- --with-gdb-datadir="\${datadir}/gdb/${CTARGET}"
- )
-
- # gdbserver only works for native targets (CHOST==CTARGET).
- # it also doesn't support all targets, so rather than duplicate
- # the target list (which changes between versions), use the
- # "auto" value when things are turned on, which is triggered
- # whenever no --enable or --disable is given
- if is_cross || use !server ; then
- myconf+=( --disable-gdbserver )
- fi
-
- myconf+=(
- --enable-64-bit-bfd
- --disable-install-libbfd
- --disable-install-libiberty
- --enable-obsolete
- # This only disables building in the readline subdir.
- # For gdb itself, it'll use the system version.
- --disable-readline
- --with-system-readline
- # This only disables building in the zlib subdir.
- # For gdb itself, it'll use the system version.
- --without-zlib
- --with-system-zlib
- --with-separate-debug-dir="${EPREFIX}"/usr/lib/debug
- $(use_with xml expat)
- $(use_with lzma)
- $(use_enable nls)
- $(use_enable sim)
- $(use_enable source-highlight)
- $(use multitarget && echo --enable-targets=all)
- $(use_with python python "${EPYTHON}")
- $(use_with xxhash)
- $(use_with guile)
- $(use_with zstd)
-
- # Find libraries using the toolchain sysroot rather than the configured
- # prefix. Needed when cross-compiling.
- #
- # Check which libraries to apply this to with:
- # "${S}"/gdb/configure --help | grep without-lib | sort
- --without-lib{babeltrace,expat,gmp,iconv,ipt,lzma,mpfr,xxhash}-prefix
- )
-
- # source-highlight is detected with pkg-config: bug #716558
- export ac_cv_path_pkg_config_prog_path="$(tc-getPKG_CONFIG)"
-
- export CC_FOR_BUILD="$(tc-getBUILD_CC)"
-
- # ensure proper compiler is detected for Clang builds: bug #831202
- export GCC_FOR_TARGET="${CC_FOR_TARGET:-$(tc-getCC)}"
-
- econf "${myconf[@]}"
-}
-
-src_test() {
- # Run the unittests (nabbed invocation from Fedora's spec file) at least
- emake -k -C gdb run GDBFLAGS='-batch -ex "maintenance selftest"'
-
- # Too many failures
- # In fact, gdb's test suite needs some work to get passing.
- # See e.g. https://sourceware.org/gdb/wiki/TestingGDB.
- # As of 11.2, on amd64: "# of unexpected failures 8600"
- # Also, ia64 kernel crashes when gdb testsuite is running.
- #emake -k check
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- find "${ED}"/usr -name libiberty.a -delete || die
-
- # Delete translations that conflict with binutils-libs. bug #528088
- # Note: Should figure out how to store these in an internal gdb dir.
- if use nls ; then
- find "${ED}" \
- -regextype posix-extended -regex '.*/(bfd|opcodes)[.]g?mo$' \
- -delete || die
- fi
-
- # Don't install docs when building a cross-gdb
- if [[ ${CTARGET} != ${CHOST} ]] ; then
- rm -rf "${ED}"/usr/share/{doc,info,locale} || die
- local f
- for f in "${ED}"/usr/share/man/*/* ; do
- if [[ ${f##*/} != ${CTARGET}-* ]] ; then
- mv "${f}" "${f%/*}/${CTARGET}-${f##*/}" || die
- fi
- done
- return 0
- fi
-
- # Install it by hand for now:
- # https://sourceware.org/ml/gdb-patches/2011-12/msg00915.html
- # Only install if it exists due to the twisted behavior (see
- # notes in src_configure above).
- [[ -e gdbserver/gdbreplay ]] && dobin gdbserver/gdbreplay
-
- docinto gdb
- dodoc gdb/CONTRIBUTE gdb/README gdb/MAINTAINERS \
- gdb/NEWS gdb/PROBLEMS
- docinto sim
- dodoc sim/{MAINTAINERS,README-HACKING}
-
- if use server ; then
- docinto gdbserver
- dodoc gdbserver/README
- fi
-
- # Remove shared info pages
- rm -f "${ED}"/usr/share/info/{annotate,bfd,configure,ctf-spec,standards}.info*
-
- if use python ; then
- python_optimize "${ED}"/usr/share/gdb/python/gdb
- fi
-}
-
-pkg_postinst() {
- # Portage doesn't unmerge files in /etc
- rm -vf "${EROOT}"/etc/skel/.gdbinit
-
- if use prefix && [[ ${CHOST} == *-darwin* ]] ; then
- ewarn "gdb is unable to get a mach task port when installed by Prefix"
- ewarn "Portage, unprivileged. To make gdb fully functional you'll"
- ewarn "have to perform the following steps:"
- ewarn " % sudo chgrp procmod ${EPREFIX}/usr/bin/gdb"
- ewarn " % sudo chmod g+s ${EPREFIX}/usr/bin/gdb"
- fi
-}