summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-09 20:49:13 +0000
committerSam James <sam@gentoo.org>2023-02-09 21:46:42 +0000
commitda6c270a478d8b9fcb6a15c64eeb1e22dae36525 (patch)
treeb1035a50d62aacffb3309bcfd08b310b883dc4f3
parentdev-ml/ppx_bin_prot: add deps on ppxlib (diff)
downloadgentoo-da6c270a.tar.gz
gentoo-da6c270a.tar.bz2
gentoo-da6c270a.zip
sys-apps/hwdata: add 0.367
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/hwdata/Manifest1
-rw-r--r--sys-apps/hwdata/hwdata-0.367.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/sys-apps/hwdata/Manifest b/sys-apps/hwdata/Manifest
index abef5131ec5c..6d4441e11519 100644
--- a/sys-apps/hwdata/Manifest
+++ b/sys-apps/hwdata/Manifest
@@ -1,2 +1,3 @@
DIST hwdata-0.364.tar.gz 2290206 BLAKE2B f41fbc85fffa0561ccee55c2bbb9c32f2f67532dd2cd8c3731a2805712969a5950f31b4e5662adf3b55c6226c31cb00f0670af4a1fbff1a7c19d46ba067792fd SHA512 94cae67d9155b7abbaa7fc9047702a6f166721477b6320736d7984efd7c7c3c028b9f794269750f0ef421275a7e243fe1ae59816f63576fffc1bcd8deb49c6e9
DIST hwdata-0.366.tar.gz 2306172 BLAKE2B bac953c59897d96fbbd19e8e275cb9345c7788de034fd4f9f80b7f35e8db9a39aa406b16fc6d60a78d1cbd1fe59d59c522391fd21103bd1e79c8a5c0c8c23f47 SHA512 41b8a97f7ebd7f0ead78318fce65c148e2e01a55132f83780c29993b82df40f5df993243b6421413a4f59aaffa916f53a0358d0d1d4a89022a7639075f96671b
+DIST hwdata-0.367.tar.gz 2313810 BLAKE2B 7f4be3f0b3c8ec6d90860031677b1e1bc6fac9159291ee772501e5f5aee0d43855e27fb6f9c4b0c65b04353fee1222f5e6c0f0a40fa743a32fdcb9509ebc772d SHA512 ed04282c4046193debb02b325b57cd0ef78d5ceb485d104f10d8aa1fe3ba42aeee8071ac806db95c03b40e6fc1d7c8c5f036adca7744a9d9376b0a146f6ec5a8
diff --git a/sys-apps/hwdata/hwdata-0.367.ebuild b/sys-apps/hwdata/hwdata-0.367.ebuild
new file mode 100644
index 000000000000..afddd20d2fd1
--- /dev/null
+++ b/sys-apps/hwdata/hwdata-0.367.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo
+
+DESCRIPTION="Hardware identification and configuration data"
+HOMEPAGE="https://github.com/vcrhonek/hwdata"
+SRC_URI="https://github.com/vcrhonek/hwdata/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RESTRICT="test"
+
+src_configure() {
+ # configure is not compatible with econf
+ local conf=(
+ ./configure
+ --prefix="${EPREFIX}/usr"
+ --libdir="${EPREFIX}/lib"
+ --datadir="${EPREFIX}/usr/share"
+ )
+
+ edo "${conf[@]}"
+}